La guida su Gnash è obsoleta?

Discussioni relative alla Gestione del wiki Guide@Debianizzati.Org

La guida su Gnash è obsoleta?

Messaggioda Spoon » 08/02/2015, 20:41

Ciao a tutti,
oggi purtroppo ho dovuto installare flashplugin-nonfree :(

Prima di farlo ho dato un'occhiata alle guide, e mi sono imbattuto in quella su Gnash. A quel punto ho notato che nella mia Wheezy gnash era installato di default, soprattutto non c'è più bisogno del workaround con Greasemonkey per far funzionare il plugin su iceweasel/firefox. Infine, il pacchetto mozilla-plugin-gnash è al momento fittizio, quello effettivo è browser-plugin-gnash.

Prima di modificare la guida vorrei chiedervi conferma su queste osservazioni, perchè riferendosi all'installazione del sistema non ho modo di verificare personalmente.
Grazie
Spoon
wiki member
wiki member
 
Messaggi: 343
Iscritto il: 23/11/2013, 14:37

Re: La guida su Gnash è obsoleta?

Messaggioda s3v » 08/02/2015, 20:49

Per me puoi modificarla in quanto, oltre al fatto che è superata, indica YT come esempio. Questo è passato da tempo ad HTML5 e non richiede più flash per funzionare. Inoltre, con il plugin della Cisco, si raggiunge anche un'ottima risoluzione (1080p) senza rallentamenti e con consumo hardware decisamente ridotto rispetto a gstreamer+x264.

Comunque aspetta il parere anche di altri.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5657
Iscritto il: 31/12/2008, 11:54

Re: La guida su Gnash è obsoleta?

Messaggioda Selky » 08/02/2015, 23:26

Spoon ha scritto:A quel punto ho notato che nella mia Wheezy gnash era installato di default...

Prima di modificare la guida vorrei chiedervi conferma su queste osservazioni, perchè riferendosi all'installazione del sistema non ho modo di verificare personalmente.
Grazie

Se può esserti di aiuto per sistemare la guida: su Wheezy Xfce default netinstall, Gnash non ce 'ho installato.

Questo l'output se simulo l'installazione
Codice: Seleziona tutto
$ apt-get -s install gnash
Nota: questa è solo una simulazione.
      apt-get necessita dei privilegi di root per la normale esecuzione.
      Inoltre, il meccanismo di blocco non è attivato e non è quindi
      utile dare importanza a tutto ciò per una situazione reale.
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno inoltre installati:
   gnash-common (0.8.11~git20120629-1+deb7u1)
   libboost-program-options1.49.0 (1.49.0-3.2)
   libboost-thread1.49.0 (1.49.0-3.2)
I seguenti pacchetti NUOVI saranno installati:
   gnash (0.8.11~git20120629-1+deb7u1)
   gnash-common (0.8.11~git20120629-1+deb7u1)
   libboost-program-options1.49.0 (1.49.0-3.2)
   libboost-thread1.49.0 (1.49.0-3.2)
0 aggiornati, 4 installati, 0 da rimuovere e 0 non aggiornati.
Selky
wiki member
wiki member
 
Messaggi: 1424
Iscritto il: 30/12/2011, 1:00

Re: La guida su Gnash è obsoleta?

Messaggioda Spoon » 06/04/2015, 10:47

Ho scritto una guida aggiornata sull'utilizzo di gnash e relativo plugin per iceweasel, basandomi sulla guida precedentemente esistente e inserendo un richiamo ad essa. Come potete vedere l'ho salvata nel mio spazietto personale, perchè prima di pubblicarla in modo definitivo aspetterei il "via libera" di qualcuno di più esperto: è solo la seconda volta che metto mano a una guida.

Nel caso questa dovesse andare bene, credo che si possa anche marcare come "aggiornata" la vecchia guida, modificando le versioni disponibili (fino a Squeeze) e inserendo un banner che rimandi alla nuova guida.
Spoon
wiki member
wiki member
 
Messaggi: 343
Iscritto il: 23/11/2013, 14:37

Re: La guida su Gnash è obsoleta?

Messaggioda HAL 9000 » 06/04/2015, 11:42

Le guide sul wiki sono parte di un progetto collaborativo, quindi non preoccuparti di scriverne di nuove, né devi chiedere alcun permesso per farlo. Chi partecipa controlla le nuove cose inserite, e può facilmente correggerle, riformattarle, verificarle, ecc... :)

A un rapido controllo risulta che i due pacchetti non sono più presenti in Jessie, ma si trovano in Wheezy e in Sid, quindi rimuoverei Jessie dalle versioni compatibili, almeno finché non saranno aggiunti ai backports.

Riguardo l'altra guida invece, credo che andrebbe marcata come obsoleta, e andrebbero rimossi i riferimenti a Wheezy e Jessie, magari rimandando alla nuova guida in un box in alto, ma non so se esiste un formato standard per questi casi. Prima però aspetterei di sentire l'autore se possibile, e in caso contrario aprirei una discussione nella wiki con un rimando a questo thread.

EDIT: Utilizzerei apt-get in luogo di aptitude per le nuove guide, perché a partire da Jessie ha maggiore priorità (anche se di default sono installati i pacchetti di entrambi), oltre che per usare gli stessi comandi nella nostra wiki. Il mio è solo un suggerimento, non è niente di vincolante, regolati come ritieni più giusto. ;)
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01

Re: La guida su Gnash è obsoleta?

Messaggioda Selky » 06/04/2015, 15:51

Visto che Squeezy è una LTS che sarà supportata sino al 2016 e che ancora qualcuno la utilizza (ne abbiamo le prove su questo forum), personalmente avrei optato per una suddivisione della guida tra "vecchia maniera" e "nuova".
Distinguendo che sino a Squeeze la procedura è di un certo tipo, da Wheezy un altro e non marcare la prima come obsoleta.

Ovviamente è solo un mio modo di vedere la situazione.
Selky
wiki member
wiki member
 
Messaggi: 1424
Iscritto il: 30/12/2011, 1:00

Re: La guida su Gnash è obsoleta?

Messaggioda HAL 9000 » 06/04/2015, 16:23

Hai ragione, mi ero completamente dimenticato di squeeze-lts. :)

Non saprei sinceramente per le due guide, il problema della prima è anche nel titolo che richiama il metodo utilizzato, necessario solo per Squeeze. Non mi sono mai occupato di queste cose, forse si potrebbe integrare la vecchia nella nuova, invece che il contrario?
Ignoro inoltre se i progressi sono dovuti a cambiamenti di youtube oppure a miglioramenti di gnash.

Per il supporto a Squeeze credo bisogni prendere una decisione coerente con il resto della wiki (o la si considera supportata ovunque oppure no senza fare riferimento a squeeze-lts), ma non so se il problema è già stato affrontato, anche perché non è chiaro se ci sarà una wheezy-lts e se le LTS diverranno ufficiali oppure no.

Concordo però di non marcare la vecchia guida come obsoleta, visto che può essere ancora utile, almeno finché ci sarà il supporto semiufficiale a squeeze-lts. Intanto rimuovo dalle versioni compatibili quelle successive a Squeeze, che possono essere riaggiunte se si farà l'unione dei due metodi. ;)
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01

Re: La guida su Gnash è obsoleta?

Messaggioda Selky » 06/04/2015, 16:34

Ho proprio affrontato il discorso poco tempo fa privatamente con s3v.
Purtroppo da quello che ho potuto appurare in questi mesi (tutto è cominciato dando supporto ad un utente), mi sono accorta che è una LTS particolare quella presente su Debian. Non è da intendersi come quelle di altre distro supportate al 100%.
In sostanza la maggior parte dei pacchetti non è supportata ne aggiornata e si è obbligati a risolvere prelevando da release successive.
Hai ragione bisognerebbe essere coerenti con il resto del wiki.
Selky
wiki member
wiki member
 
Messaggi: 1424
Iscritto il: 30/12/2011, 1:00

Re: La guida su Gnash è obsoleta?

Messaggioda Spoon » 06/04/2015, 17:31

La mia idea iniziale era di tenere la "vecchia guida", sia per chi si trovasse ad utilizzare ancora Squeeze sia per motivi storici. Al più avrei inserito un avvertimento all'inizio e l'avrei marcata come aggiornata.
Si può anche pensare di integrare le due guide, però la "vecchia" è stata creata per risolvere un problema ben specifico (far andare Gnash su YT), mentre quella da me scritta oggi riguarda solo l'installazione del software e del plugin: in realtà ho fatto ben poco, a parte modificare le indicazioni ai pacchetti obsoleti, togliere la parte relativa a GreaseMonkey e sistemare il resto.
Spoon
wiki member
wiki member
 
Messaggi: 343
Iscritto il: 23/11/2013, 14:37

Re: La guida su Gnash è obsoleta?

Messaggioda Spoon » 18/04/2015, 15:12

Ho creato una guida ex novo su Gnash qua, lasciando la "vecchia guida" così com'è.
Spoon
wiki member
wiki member
 
Messaggi: 343
Iscritto il: 23/11/2013, 14:37

Re: La guida su Gnash è obsoleta?

Messaggioda HAL 9000 » 18/04/2015, 15:45

Ottimo, ho solo aggiunto un box alla guida vecchia, così che sia più facile trovare la nuova.
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01


Torna a Guide@Debianizzati.Org

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti