TECRA Z50-A: Installazione nuovo kernel da jessie-backports

Questioni legate al Kernel Linux: configurazione, installazione, ottimizzazione, patch

Re: Installazione nuovo kernel da jessie-backports

Messaggioda dennis » 25/09/2016, 13:38

dennis
Jr. Member
Jr. Member
 
Messaggi: 64
Iscritto il: 12/09/2015, 16:17

Re: Installazione nuovo kernel da jessie-backports

Messaggioda Aki » 25/09/2016, 14:02

Dal log inviato non risulta riconosciuta una scheda di rete WiFi:
Codice: Seleziona tutto
lspci -knn
******************************************
00:00.0 Host bridge [0600]: Intel Corporation Haswell-ULT DRAM Controller [8086:0a04] (rev 0b)
        Subsystem: Toshiba America Info Systems Device [1179:0001]
        Kernel driver in use: hsw_uncore
00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b)
        Subsystem: Toshiba America Info Systems Device [1179:0003]
        Kernel driver in use: i915
00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 0b)
        Subsystem: Toshiba America Info Systems Device [1179:0001]
        Kernel driver in use: snd_hda_intel
00:14.0 USB controller [0c03]: Intel Corporation 8 Series USB xHCI HC [8086:9c31] (rev 04)
        Subsystem: Toshiba America Info Systems Device [1179:0001]
        Kernel driver in use: xhci_hcd
00:16.0 Communication controller [0780]: Intel Corporation 8 Series HECI #0 [8086:9c3a] (rev 04)
        Subsystem: Toshiba America Info Systems Device [1179:0001]
        Kernel driver in use: mei_me
00:16.3 Serial controller [0700]: Intel Corporation 8 Series HECI KT [8086:9c3d] (rev 04)
        Subsystem: Toshiba America Info Systems Device [1179:0001]
        Kernel driver in use: serial
00:19.0 Ethernet controller [0200]: Intel Corporation Ethernet Connection I218-LM [8086:155a] (rev 04)
        Subsystem: Toshiba America Info Systems Device [1179:0001]
        Kernel driver in use: e1000e
00:1b.0 Audio device [0403]: Intel Corporation 8 Series HD Audio Controller [8086:9c20] (rev 04)
        Subsystem: Toshiba America Info Systems Device [1179:0001]
        Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation 8 Series PCI Express Root Port 6 [8086:9c1a] (rev e4)
        Kernel driver in use: pcieport
00:1d.0 USB controller [0c03]: Intel Corporation 8 Series USB EHCI #1 [8086:9c26] (rev 04)
        Subsystem: Toshiba America Info Systems Device [1179:0001]
        Kernel driver in use: ehci-pci
00:1f.0 ISA bridge [0601]: Intel Corporation 8 Series LPC Controller [8086:9c43] (rev 04)
        Subsystem: Toshiba America Info Systems Device [1179:0001]
        Kernel driver in use: lpc_ich
00:1f.2 SATA controller [0106]: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] [8086:9c03] (rev 04)
        Subsystem: Toshiba America Info Systems Device [1179:0001]
        Kernel driver in use: ahci
01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader [10ec:5227] (rev 01)
        Subsystem: Toshiba America Info Systems Device [1179:0001]
        Kernel driver in use: rtsx_pci

Non mi sembra neppure sia tra le periferiche usb:
Codice: Seleziona tutto
******************************************
lsusb
******************************************
Bus 003 Device 002: ID 8087:8000 Intel Corp.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 04f2:b3b2 Chicony Electronics Co., Ltd
Bus 001 Device 005: ID 0b97:7772 O2 Micro, Inc. OZ776 CCID Smartcard Reader
Bus 001 Device 003: ID 0b97:7761 O2 Micro, Inc. Oz776 1.1 Hub
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Forse è disattivata a livello di BIOS/firmware UEFI, oppure tramite un qualche pulsante.

A quanti potesse interessare, allego il log competo.
Allegati
89337-log_25set_143527.xz
(29.14 KiB) Scaricato 120 volte
Aki
Global Moderator
Global Moderator
 
Messaggi: 7804
Iscritto il: 27/12/2007, 16:59

Re: Installazione nuovo kernel da jessie-backports

Messaggioda dennis » 25/09/2016, 15:25

Ho provato pure a dare
Codice: Seleziona tutto
apt-get -t jessie-backports install firmware-iwlwifi

e riavviato, ma niente, ancora non funziona

Faccio una precisazione, col vecchio kernel, una volta installato il firmware-iwlwifi il wifi funzionava correttamente, quindi non credo sia disattivato a livello di bios

Avevo seguito questa guida
https://wiki.debian.org/it/iwlwifi
dennis
Jr. Member
Jr. Member
 
Messaggi: 64
Iscritto il: 12/09/2015, 16:17

Re: Installazione nuovo kernel da jessie-backports

Messaggioda Aki » 25/09/2016, 17:02

Non è un problema di firmware: il kernel non riconosce proprio la scheda di rete wireless (è come se non fosse presente nel computer)
Aki
Global Moderator
Global Moderator
 
Messaggi: 7804
Iscritto il: 27/12/2007, 16:59

Re: Installazione nuovo kernel da jessie-backports

Messaggioda dennis » 25/09/2016, 17:13

Aki ha scritto:Non è un problema di firmware: il kernel non riconosce proprio la scheda di rete wireless (è come se non fosse presente nel computer)


Non potrei installare un kernel antecedente questo?
dennis
Jr. Member
Jr. Member
 
Messaggi: 64
Iscritto il: 12/09/2015, 16:17

Re: Installazione nuovo kernel da jessie-backports

Messaggioda Aki » 25/09/2016, 18:01

Dovresti avere la precedente versione del kernel ancora installata: la puoi richiamare dalla seconda voce di grub al boot
Aki
Global Moderator
Global Moderator
 
Messaggi: 7804
Iscritto il: 27/12/2007, 16:59

Re: Installazione nuovo kernel da jessie-backports

Messaggioda dennis » 25/09/2016, 18:18

Aki ha scritto:Dovresti avere la precedente versione del kernel ancora installata: la puoi richiamare dalla seconda voce di grub al boot


Sì, la 3.16, ma in questo modo non mi funziona lo scroll a due dita del touchpad..e non puoi capire quanto è scomodo..
dennis
Jr. Member
Jr. Member
 
Messaggi: 64
Iscritto il: 12/09/2015, 16:17

Re: Installazione nuovo kernel da jessie-backports

Messaggioda Aki » 25/09/2016, 19:38

Prova a forzare il caricamento del driver wifi:
Codice: Seleziona tutto
script.log
modprobe -r iwlwifi ; modprobe iwlwifi
dmesg
exit

In ogni caso sarebbe utile che fornissi un log del sistema avviato con il precedente kernel in mido da verificare come è riconosciuta la scheda wifi.
Aki
Global Moderator
Global Moderator
 
Messaggi: 7804
Iscritto il: 27/12/2007, 16:59

Re: Installazione nuovo kernel da jessie-backports

Messaggioda dennis » 25/09/2016, 20:14

Aki ha scritto:Prova a forzare il caricamento del driver wifi:
Codice: Seleziona tutto
script.log
modprobe -r iwlwifi ; modprobe iwlwifi
dmesg
exit

In ogni caso sarebbe utile che fornissi un log del sistema avviato con il precedente kernel in mido da verificare come è riconosciuta la scheda wifi.


il log dei comandi che mi hai consigliato
https://ufile.io/ebd13
dennis
Jr. Member
Jr. Member
 
Messaggi: 64
Iscritto il: 12/09/2015, 16:17

Re: Installazione nuovo kernel da jessie-backports

Messaggioda Aki » 25/09/2016, 20:19

Il modulo del kernel, dal log, risulta essere stato caricato: ha sortito effetto ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 7804
Iscritto il: 27/12/2007, 16:59

Re: Installazione nuovo kernel da jessie-backports

Messaggioda dennis » 25/09/2016, 20:24

Aki ha scritto:Il modulo del kernel, dal log, risulta essere stato caricato: ha sortito effetto ?

No, tutto come prima.
Ho provato pure a riavviare col kernel originale che c'era appena installato, ho seguito questa guida
https://wiki.debian.org/it/iwlwifi
ma niente, non funziona neanche con questo kernel. (in una precedente installazione avevo seguito la solita guida prima di aggiornare il kernel e il wifi funzionava correttamente)
dennis
Jr. Member
Jr. Member
 
Messaggi: 64
Iscritto il: 12/09/2015, 16:17

Re: Installazione nuovo kernel da jessie-backports

Messaggioda Aki » 25/09/2016, 20:26

La scheda di rete WiFi sembra disattivata.
Aki
Global Moderator
Global Moderator
 
Messaggi: 7804
Iscritto il: 27/12/2007, 16:59

Re: Installazione nuovo kernel da jessie-backports

Messaggioda dennis » 25/09/2016, 20:28

Aki ha scritto:La scheda di rete WiFi sembra disattivata.

C'è modo di vedere questo con qualche comando? Come la posso attivare?

A me sembra che il modulo wifi non viene proprio tirato su
Codice: Seleziona tutto
root@debian:/home/phate# ifconfig
eth0      Link encap:Ethernet  HWaddr b8:6b:23:56:45:73 
          inet addr:192.168.1.183  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::ba6b:23ff:fe56:4573/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:804 errors:0 dropped:0 overruns:0 frame:0
          TX packets:840 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:589657 (575.8 KiB)  TX bytes:134801 (131.6 KiB)
          Interrupt:20 Memory:f0500000-f0520000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:27 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:3090 (3.0 KiB)  TX bytes:3090 (3.0 KiB)

root@debian:/home/phate# iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

dennis
Jr. Member
Jr. Member
 
Messaggi: 64
Iscritto il: 12/09/2015, 16:17

Re: Installazione nuovo kernel da jessie-backports

Messaggioda Aki » 25/09/2016, 21:17

Non lo so: sei sicuro che funziona ? Hai aperto il computer o l'ha fatto qualcun altro per Te ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 7804
Iscritto il: 27/12/2007, 16:59

PrecedenteProssimo

Torna a Kernel

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite