[Risolto] Kernel 4.8.0-1-amd64 e fglrx dkms

Questioni legate al Kernel Linux: configurazione, installazione, ottimizzazione, patch

[Risolto] Kernel 4.8.0-1-amd64 e fglrx dkms

Messaggioda wtf » 17/11/2016, 21:53

Installando i seguenti pacchetti:
Codice: Seleziona tutto
linux-headers-amd64 linux-image-amd64

ho ottenuto il seguente errore:
Codice: Seleziona tutto
/etc/kernel/header_postinst.d/dkms:
Error! Bad return status for module build on kernel: 4.8.0-1-amd64 (x86_64)
Consult /var/lib/dkms/fglrx/15.12/build/make.log for more information.

Premesso che ho anche installato il pacchetto fglrx-modules-dkms, il contenuto del file di log è qui

Mi devo preoccupare?
Cose da sapere:
Avatar utente
wtf
Global Moderator
Global Moderator
 
Messaggi: 697
Iscritto il: 12/04/2011, 10:58
Località: Brianza

Re: Kernel 4.8.0-1-amd64 e fglrx dkms

Messaggioda Ombra » 18/11/2016, 1:15

Beh ad occhio mi sembra che sia fallita la compilazione ( e di conseguenza l'inserimento nel kernel) del modulo fglrx.
Lo puoi verificare con
Codice: Seleziona tutto
lmod | grep fglrx

Premetto che sono secoli che non uso i driver proprietari della ATI, ma se è rimasto com'era allora non dovresti avere l'accelerazione 3D ( il resto più o meno dovrebbe andare).
Per tamponare puoi usare il kernel precedente al 4.8 oppure impostare xorg per utilizzare i driver open ( se la tua scheda video non è troppo nuova)
Ombra
wiki member
wiki member
 
Messaggi: 469
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: Kernel 4.8.0-1-amd64 e fglrx dkms

Messaggioda luciano » 18/11/2016, 8:24

i driver fglrx non sono più supportati da ati e non è più possibile compilare, forse è per questo che ti ha dato quel problema
io ad esempio ho rinunciato per ora a stretch su un portatile asus A53B, che ha due schede grafiche, viste come

VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler [Radeon HD 6320]
VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]

perché già con il kernel 4.2 se uso i driver open, sono costretto ad accedere con nomodeset e non ho effetti grafici decenti

si dovrebbe passare ai driver open amdgpu che infatti sono presenti nei repo testing ... ma ancora lo sviluppo pare non sia completo, ad esempio nel mio caso le schede non sono ancora supportate
luciano
Full Member
Full Member
 
Messaggi: 214
Iscritto il: 06/04/2008, 13:26

Re: Kernel 4.8.0-1-amd64 e fglrx dkms

Messaggioda Ombra » 18/11/2016, 9:18

i driver fglrx non sono più supportati da ati

questa in effetti me l'ero persa. Cmq leggendo in giro pare che il driver non sia compatibile con Xorg>=1.18, quindi in Debian rimane solo la stable che ha ancora 1.16.
Il supporto del driver open "radeon" non è male, solo che dipende da quanto è nuova al scheda video, e poi ci sono dei modelli un po' sfigati che funzionano male (tipo i chip mobile spesso funzionano peggio di quelli normali). Cmq secondo me dipende molto da quello che uno si aspetta e da cosa ci devi fare
Qui c'è una tabella coi chip supportati dal driver radeon e da amdgpu ( per il chip più nuovo)
Ombra
wiki member
wiki member
 
Messaggi: 469
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: Kernel 4.8.0-1-amd64 e fglrx dkms

Messaggioda wtf » 18/11/2016, 19:18

Grazie per le risposte.
Io ho installato entrambi i pacchetti amd e al momento non sembro avere problemi di sorta (ho una radeon 7850). Ho provato a caricare sia Pillars of Eternity che Insurgency (steam) e tutto sembra funzionare correttamente.

EDIT:
A quanto pare il pacchetto fglrx-modules-dkms non serve più, almeno nel mio caso. L'ho rimosso mantenendo solo i seguenti due pacchetti:
Codice: Seleziona tutto
firmware-amd-graphics
xserver-xorg-video-amdgpu

e come già detto tutto sembra funzionare correttamente.
Cose da sapere:
Avatar utente
wtf
Global Moderator
Global Moderator
 
Messaggi: 697
Iscritto il: 12/04/2011, 10:58
Località: Brianza


Torna a Kernel

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti