[RISOLTO] dubbi su impostazione backports

Repository Ufficiali e non, come utilizzarli e come risolvere i problemi legati al loro utilizzo

Re: dubbi su impostazione backports

Messaggioda HAL 9000 » 15/06/2014, 14:28

Almeno iceweasel è aggiornato, fai sapere per libreoffice. :)

Riguardo il resto, effettua prima gli aggiornamenti così da avere tutto aggiornato, poi non avendo più il pinning devi indicargli che vuoi utilizzare i backports esplicitamente (gli aggiornamenti, una volta installati, sono automatici; ma la prima installazione no, neanche se il pacchetto è già installato da un altro repository):

Codice: Seleziona tutto
# aptitude install -t wheezy-backports linux-image-686-pae linux-headers-686-pae
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01

Re: dubbi su impostazione backports

Messaggioda sbubba » 16/06/2014, 14:43

libreoffice l'ho dovuto togliere assieme a gnome, reinstallato libreoffice dai backports e gnome da stable.
il kernel l'ho installato come hai detto qua sopra.

che dire, grazie per la pazienza e spero che i prossimi aggiornamenti vadano come previsto, il test lo farò il prossimo fine settimana
buon proseguimento :D :D
sbubba
Jr. Member
Jr. Member
 
Messaggi: 78
Iscritto il: 28/04/2011, 20:11

Re: [RISOLTO] dubbi su impostazione backports

Messaggioda sbubba » 23/06/2014, 13:37

gli aggiornamenti sono a posto. ho controllato la versione dei pacchetti di libreoffice, linux-image e linux-headers su packages.debian.org e ho quelle di wheezy-backports.
grazie e buon proseguimento :D
sbubba
Jr. Member
Jr. Member
 
Messaggi: 78
Iscritto il: 28/04/2011, 20:11

Re: [RISOLTO] dubbi su impostazione backports

Messaggioda Selky » 23/06/2014, 14:45

Ci sei riuscita, non è giusto! :'(

Ero in attesa del tuo resoconto :D
Selky
wiki member
wiki member
 
Messaggi: 1419
Iscritto il: 30/12/2011, 1:00

Re: [RISOLTO] dubbi su impostazione backports

Messaggioda sbubba » 23/06/2014, 21:47

Selky ha scritto:Ci sei riuscita, non è giusto! :'(

bwahahahahha ;D ;D

il resoconto è questo: ho wheezy e volevo libreoffice, linux-image e linux-kernel dai wheezy-backports.
avevo settato preferences e apt.conf per il pinning ma non ce n'era bisogno. bastava aggiungere wheezy-backports nel source.list e ciò che viene installato dai wheezy-backports, da lì viene aggiornato.

non so perchè avevo il problema di gnome che mi tirava tutto dietro per la rimozione, boh.
in pratica ho tolto apt.conf e preferences, nessun pinning Selky, mi spiace se la risoluzione non ha dissipato eventuali tuoi dubbi (in realtà nemmeno io ho capito perchè gli aggiornamenti non funzionavano a dovere, ma non era dato dal pinning. probabilmente qualche pasticcio fatto durante l'installazione dei pacchetti).
sbubba
Jr. Member
Jr. Member
 
Messaggi: 78
Iscritto il: 28/04/2011, 20:11

Re: [RISOLTO] dubbi su impostazione backports

Messaggioda Selky » 23/06/2014, 22:46

Grazie sbubba, in effetti sulla mia attuale whezzy ho anche io solo backport per libreoffice e debian mozilla. La questione era diversa all'epoca che volevo xfce 4.10 prelevandolo dalla testing.
Ho continuato a creare il file atp.conf per capirne le caratteristiche e i settaggi, di conseguenza e istintivamente a tenere anche il file preferences.
Farò un ripulisci per vedere che succede ;)

non so perchè avevo il problema di gnome che mi tirava tutto dietro per la rimozione, boh.
Non ne ho la certezza, non ho approfondito, ma credo che vi sia una differenza sostanziale in qualche elemeneto della versione presente di default su wheezy da quella presente nei backport. Nel tuo caso qualche elemento fortemente legato a gnome, come ad esempio libreoffice-gnome che io su xfce non ho.

Ciao alla prossima :)
Selky
wiki member
wiki member
 
Messaggi: 1419
Iscritto il: 30/12/2011, 1:00

Re: [RISOLTO] dubbi su impostazione backports

Messaggioda HAL 9000 » 24/06/2014, 9:14

Grazie del resoconto, sbubba. :)
Provvederò ad aggiornare la guida sul pinning, specificando che non è più necessario (così come Default-Release in apt.conf) per una configurazione "standard" (e consigliata): solo una distribuzione tra stable e testing (con relativo repository per security), eventuali updates (ex-volatile) e backports ufficiali (e a quanto pare anche quelli non ufficiali di mozilla.debian.net).
Basta che la prima installazione/aggiornamento dai backports sia effettuata specificando manualmente il repository.

Ho sempre avuto gli aggiornamenti su libreoffice dai backports, anche se la mia situazione è un po' diversa, visto che ho pasticciato con altre versioni per via di qualche bug fastidioso (in programmi minori che si portano dietro poche dipendenze), e ho comunque un leggero pinning per evitare il passaggio a testing/sid di tutto quanto.
Con un Pin-Priority inferiore a stable l'avanzamento dei backports è comunque automatico una volta che sono installati, ma non potevo confermare in prima persona riguardo una situazione pulita (e più corretta in ottica Debian).
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01

Re: [RISOLTO] dubbi su impostazione backports

Messaggioda Selky » 24/06/2014, 13:12

Piccolo OT forse

In una installazione normale, come supposto in questo thread, però posso tenere il file apt.conf per settare alcuni comandi senza doverli per forza digitare ogni volta da riga di comando? Cioè elimino la voce
Codice: Seleziona tutto
Default-Release "wheezy";
mentre tengo il resto che mi interessa ad esempio
Codice: Seleziona tutto
Show-Upgraded "true";
Show-Versions "true";


Per il problema degli aggiornamenti dai backport basta non avere il file preferences, giusto?
Selky
wiki member
wiki member
 
Messaggi: 1419
Iscritto il: 30/12/2011, 1:00

Re: [RISOLTO] dubbi su impostazione backports

Messaggioda HAL 9000 » 24/06/2014, 13:22

Sì, esatto, il resto si può configurare a piacimento. :)

Per fare proprio i pignoli, si può configurare anche la Default-Release. È solo "non necessario".
Ha però l'effetto di bloccare gli aggiornamenti automatici (se predisposti) dagli updates (tzdata, clamav, e altra roba) e dai proposed-updates, salvo per pacchetti già prelevati da quei repository. Quindi se si mette quello, poi può essere necessario il pinning.
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01

Re: [RISOLTO] dubbi su impostazione backports

Messaggioda Selky » 24/06/2014, 13:36

Sto proprio aggiornando ora con le modifiche.
Codice: Seleziona tutto
APT
{
   Cache-Limit 36000000;
   Get
      {
      AllowUnauthenticated 0;
      AutomaticRemove "true";
      Fix-Broken "true";
      Fix-Missing "true";
      Purge "true";
      Show-Upgraded "true";
      Show-Versions "true";
        }
}
Aptitude
{
   Autoclean-After-Update "true";
   Auto-Fix-Broken "true";
   Purge-Unused "true";
}


Su wheezy generalmente gli aggiornamenti non sono così intensivi, nonstante avessi aggiornato il 19 giugno oggi ho 53 pacchetti.
Libreoffice va da solo yeahhhhhhhhh

Hal 9000 sei un mito! :-*
Selky
wiki member
wiki member
 
Messaggi: 1419
Iscritto il: 30/12/2011, 1:00

Re: [RISOLTO] dubbi su impostazione backports

Messaggioda sbubba » 26/06/2014, 20:03

Nel tuo caso qualche elemento fortemente legato a gnome, come ad esempio libreoffice-gnome che io su xfce non ho.
molto probabile

grazie a te HAL 9000, ora il wiki è più chiaro

buona serata ragazzi :D
sbubba
Jr. Member
Jr. Member
 
Messaggi: 78
Iscritto il: 28/04/2011, 20:11

Precedente

Torna a Repository

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron