[RISOLTO] Problemi reinstallazione LibreOffice

Problemi con l'installazione di pacchetti

[RISOLTO] Problemi reinstallazione LibreOffice

Messaggioda mith » 27/05/2017, 11:26

Salve a tutti,

ho combinato un pasticcio. La versione del repository di LibO 5.2.7.2 mi dà dei problemi di stabilità con Debian Stretch Kde (così come anche la 5.2.6.2) con Intel i7-6500u e scheda grafica nVidia Geforce 940M. Ho deciso allora di installare manualmente la versione 5.3.3 di LibO.

Successivamente, per essere sicuro di resettare tutto l'ambiente legato a LibO e l'eventuale causa di instabilità che probabilmente è legata a un bug, ho deciso di rimuoverlo, cominciando dall'estensione Zotero che uso per la bibliografia dei miei testi. Dopo aver disinstallato LibO, ho cercato nel sistema tutto ciò che poteva aver relazione con LibO e l'ho irresponsabilmente rimosso manualmente. Così, oltre ad alcuni errori durante il processo di reinstallazione che va comunque in porto, non riesco a reinstallare Zotero. LibO dice che è già installato, ma in realtà il menu di Zotero non compare in LibO. Non me lo fa disinstallare e non me lo fa installare.

I comandi irresponsabili che ho dato sono i seguenti:

Codice: Seleziona tutto
sudo find / -iname 'libreoff*'
cd /opt
ls
cd libreoffice5.3/
ls
cd ..
sudo rm -rf libreoffice5.3/
cd /var/lib/dpkg/info/
ls
sudo rm libreoffice*
ls
sudo find / -iname 'libreoff*'
cd /var/cache/apt/archives/
ls
sudo rm libreoffice*
sudo find / -iname 'libreoff*'
clear
sudo find / -iname 'libreoff*'
sudo rm -rf /usr/lib/libreoffice/
sudo rm -rf /usr/lib/menu/libreoffice5.3


È possibile recuperare la situazione o devo reinstallare Debian Stretch per riavere le librerie e le cartelle di sistema come prima?

Grazie anticipatamente per l'aiuto,
Ultima modifica di mith il 02/06/2017, 10:12, modificato 1 volta in totale.
mith
Newbie
Newbie
 
Messaggi: 31
Iscritto il: 23/08/2016, 21:16

Re: Problemi reinstallazione LibreOffice

Messaggioda Aki » 27/05/2017, 11:44

mith ha scritto:La versione del repository di LibO 5.2.7.2 mi dà dei problemi di stabilità con Debian Stretch Kde (così come anche la 5.2.6.2) con Intel i7-6500u e scheda grafica nVidia Geforce 940M.

Puoi essere più preciso: cosa intendi per "problemi di stabilità" ?

Inoltre, la versione 5.2.7.2 non sembra essere nei repository di Debian Stretch (c'è la 5.2.7-1): quale versione hai installato e da quale repository (indirizzo internet del repository) hai installato e con quali comandi ?

mith ha scritto:[..], oltre ad alcuni errori durante il processo di reinstallazione che va comunque in porto, non riesco a reinstallare Zotero. LibO dice che è già installato, ma in realtà il menu di Zotero non compare in LibO. Non me lo fa disinstallare e non me lo fa installare.

Puoi fornire un log con l'elenco degli errori di installazione di libre-office ?

Hai eseguito recentemente un dist-upgrade ?

Puoi fornire il log generato da questi comandi (impartiti come utente root):
Codice: Seleziona tutto
script log.txt
dpkg-query -l "libreoffice*"
apt-get --reinstall  install libreoffice
apt-get --reinstall --install-suggests install libreoffice-zotero-integration zotero-standalone
exit

Troverai il log nel file log.txt che potrai inviare per referenza nel prossimo messaggio del forum.
Aki
Global Moderator
Global Moderator
 
Messaggi: 7445
Iscritto il: 27/12/2007, 16:59

Re: Problemi reinstallazione LibreOffice

Messaggioda mith » 27/05/2017, 21:37

Ciao Aki, grazie per la tua risposta.

Per problemi di instabilità intendo questo:

Codice: Seleziona tutto
[ 6805.696753] [drm] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [800], reason: Hang on render ring, action: reset
[ 6805.696756] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 6805.696757] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 6805.696759] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 6805.696760] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 6805.696762] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 6805.696843] drm/i915: Resetting chip after gpu hang
[ 6805.696919] [drm] RC6 on
[ 6805.712268] [drm] GuC firmware load skipped
[ 6816.736051] drm/i915: Resetting chip after gpu hang
[ 6816.736133] [drm] RC6 on
[ 6816.750185] [drm] GuC firmware load skipped
[ 6816.835554] traps: SHCLIP[9222] general protection ip:7fb78f026865 sp:7fb6d80c5a30 error:0
[ 6816.835559]  in libc-2.24.so[7fb78eff1000+195000]


Succede solo quando ho LibO aperto, mentre sto scrivendo in genere, ma non necessariamente. La sessione si blocca per una decina di secondi e poi si riavvia. La prima volta si riesce a riavviare la sessione dalla schermata di login, ma ad esempio non riesco a gestire pienamente la scheda wireless come normalmente (ad esempio non mi funziona più il comando create_ap di github che trasforma la scheda di rete in un access point). Quando risuccede la seconda volta, la sessione si blocca, ma anche autenticandosi sulla schermata di login il sistema non si riprende più, bisogna riavviare. Sarà che uso zotero, sarà che uso tre mappature di tastiera (non contemporaneamente ovviamente), sarà che bumblebee non gestisce abbastanza serenamente la scheda ibrida e litiga con LibO, sta di fatto che da ottobre mi ritrovo con un buon pc che non mi permette di lavorare adeguatamente. Ho impostato LibO per salvare ogni minuto, ma quando si prende appunti, o si scrivono tesi, ci sono momenti di illuminazione che vanno irrimediabilmente persi quando succedono queste cose. OpenOffice sembra non dare problemi come LibO in questo caso, anche se capisco che non stia crescendo come LibO.

Se installo LibO dal repository anche a me installa in effetti la versione 5.2.7-1, il numero di versione 5.2.7.2 mi sembrava di averlo letto da dentro LibO quando si avviava, ma ora dopo l'installazione non si avvia e quindi non posso verificare.

Non ho eseguito un dist-upgrade recentemente, in genere non lo uso mai, uso solo apt update e apt upgrade.

Non sono in grado di esibire gli errori di installazione della versione che ho scaricato dal sito di LibO, ma se riusciamo a far funzionare LibO 5.2.7-1 poi posso disinstallare e tentare l'installazione della versione 5.3.3 fornita dal sito.

Il plugin per LibO di Zotero viene fornito esplicitando che è stato testato fino alla versione 5.2.3.3. Però lo sto usando su un pc desktop con Debian Jessie e con LibO 5.2.6.2-2 (scaricata dal sito di LibO e installata manualmente) senza nessun problema.

Il forum mi dice "L’estensione txt non è permessa" quando cerco di allegare il file di log, faccio quindi un link al paste.debian per il file log.txt

https://paste.debian.net/946296/

Non ho installato zotero-standalone perché uso la configurazione per Firefox.

Ho disinstallato OpenOffice prima di dare i comandi di installazione di LibO, ma se ora cerco di avviare Writer di LibO non si avvia e mi dà i seguenti errori:

Codice: Seleziona tutto
mith@debian:~$ libreoffice --writer %U
/usr/lib/libreoffice/program/oosplash: error while loading shared libraries: libuno_sal.so.3: cannot open shared object file: No such file or directory
mith@debian:~$ lowriter
/usr/lib/libreoffice/program/oosplash: error while loading shared libraries: libuno_sal.so.3: cannot open shared object file: No such file or directory

Spero di aver risposto a tutto, aspetto lumi... =)
mith
Newbie
Newbie
 
Messaggi: 31
Iscritto il: 23/08/2016, 21:16

Re: Problemi reinstallazione LibreOffice

Messaggioda mith » 27/05/2017, 22:02

Ho visto che la libreria libuno_sal.so.3 dipende dal pacchetto uno-libs3. Ho reinstallato il pacchetto ma ora mi dà un altro errore

Codice: Seleziona tutto
mith@debian:~$ libreoffice --writer %U
Warning: failed to launch javaldx - java may not function correctly
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libjvmaccesslo.so: cannot open shared object file: No such file or directory
mith@debian:~$ lowriter
Warning: failed to launch javaldx - java may not function correctly
/usr/lib/libreoffice/program/soffice.bin: error while loading shared libraries: libjvmaccesslo.so: cannot open shared object file: No such file or directory


Temo che il problema sia che avevo rimosso la cartella /usr/lib/libreoffice...
mith
Newbie
Newbie
 
Messaggi: 31
Iscritto il: 23/08/2016, 21:16

Re: Problemi reinstallazione LibreOffice

Messaggioda Aki » 27/05/2017, 22:40

Prima di tutto, prova ad eseguire un dist-upgrade: stai usando testing e, se non lo fai da tempo come hai scritto, hai un sistema mancante di molti aggiornamenti, anche perchè Debian testing è molto vicina al rilascio della release stable. Dopo aver effettuato l'aggiornamento con dist-upgrade, genera ed invia un log con lo script citato in calce in rosso nel mio messaggio.

Forse hai cancellato i file collegati a vari pacchetti senza disinstallarli successivamente. Usando il portale http://packages.debian.org puoi trovare di volta in volta i pacchetti contenenti le librerie mancanti ed installarli.

Il fatto che possa riuscire ad installare con successo e far funzionare libreoffice dai repository Debian, non significa che a questo consegue il successo di una eventuale successiva installazione della versione più aggiornata eventualmente scaricata dal sito di libreoffice, anzi questa è la premessa di futuri problemi di installazione perché la versione più recente disponibile sul sito ufficiale di libreoffice potrebbe tranquillamente essere incompatibile a livello binario con una parte dei pacchetti a supporto della versione Debian.

Per quanto riguarda il malfunzionamento del driver della scheda video Intel di cui hai inviato il log, una possibile soluzione è indicata qui: https://communities.intel.com/message/372326#372326 . Nota che il messaggio di errore del modulo drm riporta al server X e non specificamente al programma libreoffice. Il malfunzionamento che hai riferito a carico della scheda di rete potrebbero essere legati ad oops del kernel ed in tal senso dovresti trovarne traccia nel log di sistema.
Aki
Global Moderator
Global Moderator
 
Messaggi: 7445
Iscritto il: 27/12/2007, 16:59

Re: Problemi reinstallazione LibreOffice

Messaggioda Aki » 02/06/2017, 7:33

@mith: puoi aggiornare la discussione ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 7445
Iscritto il: 27/12/2007, 16:59

Re: Problemi reinstallazione LibreOffice

Messaggioda mith » 02/06/2017, 10:12

hai ragione @Aki, mi scuso per il ritardo.

Per quanto riguarda il dist-upgrade non credo ce ne sia bisogno perchè l'installazione che ho fatto partiva da un cd netinst di quelli aggiornati settimanalmente, per cui credo di avere un sistema aggiornato.
Mi ha un po' scoraggiato il fatto che installare la versione dal repository non significasse poter installare poi la versione più aggiornata. Ho deciso quindi di abbandonare la strada e di reinstallare. Invece di bumblebee utilizzo i driver proprietari nVidia, e il sistema sembra stabile. Il problema sembra dunque risolto.
Secondo me il progetto bumblebee non è supportato come dovrebbe, ho fatto una ricerca on line e sembra che non ci siano aggiornamenti dal 2013, non so se puoi confermare o meno questa informazione. Se così fosse credo che il problema possa essere bumblebee stesso, che non è seguito come dovrebbe.
Per quanto riguarda il link che mi hai indicato la soluzione sarebbe inserire nel kernel i915.enable_rc6=0?
Purtroppo non saprei come intervenire nel kernel inserendo quel parametro... che files di configurazione dovrei aprire?
mith
Newbie
Newbie
 
Messaggi: 31
Iscritto il: 23/08/2016, 21:16

Re: Problemi reinstallazione LibreOffice

Messaggioda marcomg » 02/06/2017, 10:22

mith ha scritto:Purtroppo non saprei come intervenire nel kernel inserendo quel parametro... che files di configurazione dovrei aprire?

Guarda "Rendere definitive le modifiche".
http://wiki.ubuntu-it.org/Installazione/ParametriAvvio
Windows is what you open when you want fresh air from outside.
Avatar utente
marcomg
Global Moderator
Global Moderator
 
Messaggi: 5491
Iscritto il: 22/08/2011, 18:54

Re: Problemi reinstallazione LibreOffice

Messaggioda mith » 02/06/2017, 11:05

marcomg ha scritto:Guarda "Rendere definitive le modifiche".
http://wiki.ubuntu-it.org/Installazione/ParametriAvvio


Si questo l'ho fatto tante volte per varie ragioni, credevo che fosse necessario intervenire nella compilazione del kernel, cosa che non ho mai fatto. Grazie!
mith
Newbie
Newbie
 
Messaggi: 31
Iscritto il: 23/08/2016, 21:16

Re: Problemi reinstallazione LibreOffice

Messaggioda Aki » 02/06/2017, 11:55

mith ha scritto:Per quanto riguarda il dist-upgrade non credo ce ne sia bisogno perchè l'installazione che ho fatto partiva da un cd netinst di quelli aggiornati settimanalmente, per cui credo di avere un sistema aggiornato.

Purtroppo questo assunto è quasi certamente errato: puoi verificarlo con i seguenti comandi impartiti come utente root che simulano, ma non effettuano, il dist-upgrade:
Codice: Seleziona tutto
apt-get update
apt-get --simulate dist-upgrade

mith ha scritto: Invece di bumblebee utilizzo i driver proprietari nVidia, e il sistema sembra stabile. Il problema sembra dunque risolto.

Il malfunzionamento che hai segnalato e del quale ti ho riferito non è relativo al programma bumblebee, ma ai moduli del kernel (driver) che pilotano la scheda grafica intel che è utilizzata di default nel Tuo computer. Pertanto, se non hai più errori relativamente alla sezione grafica, probabilmente è perché tramite bumblebee (o altro programma) in modo volontario o involontario hai configurato il computer a passare il controllo della scheda grafica da quella intel a quella nvidia. Utilizzando principalmente la scheda grafica nvidia ed i relativi moduli del kernel (driver) non incorri più nel malfunzionamento del driver intel (perché pur presente è meno utilizzato).

mith ha scritto: Secondo me il progetto bumblebee non è supportato come dovrebbe, ho fatto una ricerca on line e sembra che non ci siano aggiornamenti dal 2013

Non direi: vedi i changelog del progetto Debian. Considera, comunque, che bumblebee non pilota le schede grafiche, ma si limita ad rendere fruibile in Debian GNU/Linux l'architettura optimus e, quindi, accende la scheda grafica primaria (intel) e poi, su richiesta dell'utente o in automatico, fa in modo che le chiamate alle funzionalità grafiche siano indirizzate alla scheda grafica secondaria accelerata (nvidia, nel tuo caso) pur utilizzando comunque la scheda grafica primaria per visualizzare a schermo le immagini (vedi https://en.wikipedia.org/wiki/Nvidia_Optimus).

mith ha scritto: Per quanto riguarda il link che mi hai indicato la soluzione sarebbe inserire nel kernel i915.enable_rc6=0

Mi sembra che hai già ricevuto risposta.

Grazie per il riscontro.
Aki
Global Moderator
Global Moderator
 
Messaggi: 7445
Iscritto il: 27/12/2007, 16:59

Re: [Risolto] Problemi reinstallazione LibreOffice

Messaggioda mith » 02/06/2017, 12:38

Purtroppo come vedi le mie conoscenze in questi ambiti sono un po' ridotte e non mi sento tanto all'altezza. Certo, provare e riprovare serve a imparare tante cose, ma avendo una macchina che uso per lavorare diventa complicato fare interventi che non so come vanno a finire. Lo dico in genere non tanto per dist-upgrade.
Grazie @Aki per l'attenzione, cercherò di mettere comunque a frutto le tue indicazioni =)
mith
Newbie
Newbie
 
Messaggi: 31
Iscritto il: 23/08/2016, 21:16

Re: [Risolto] Problemi reinstallazione LibreOffice

Messaggioda Aki » 02/06/2017, 14:05

Usare una macchina "in produzione" per "smanettarci" è giustamente da evitare. Installare un sistema operativo considerato in fase di testing per una macchina "in produzione" può essere ugualmente fonte di sorprese, come nel tuo caso.
Aki
Global Moderator
Global Moderator
 
Messaggi: 7445
Iscritto il: 27/12/2007, 16:59

Re: [Risolto] Problemi reinstallazione LibreOffice

Messaggioda mith » 02/06/2017, 19:09

Non vorrei uscire dall'argomento del thread, comunque su questa macchina Debian Jessie non riconosceva in nessun modo la scheda audio e sono stato costretto a installare Debian Stretch. A volte con l'hw nuovo la gestione con linux è problematica. Probabilmente tra qualche mese saranno risolti tutti i problemi anche con Stretch.
mith
Newbie
Newbie
 
Messaggi: 31
Iscritto il: 23/08/2016, 21:16

Re: [RISOLTO] Problemi reinstallazione LibreOffice

Messaggioda c_estrena » 12/06/2017, 12:36

Mi permetto un intervento un po' off-topic.
Se usi Zotero, immagino che tu debba scrivere dei documenti corposi con vari riferimenti bibliografici (tipo tesi, articoli scientifici, ecc.).
Un potente mezzo per far tutto ciò (con una gestione bibliografica che integra Zotero ed è un po' magica) è LaTeX.
Non so se tu lo conosca e/o ne abbia già sentito parlare e/o tu abbia già provato ad usarlo, ma te lo consiglio vivamente.
Il forum http://www.guitex.org/home/ è una miniera di informazioni...
Se ti occupi di discipline umanistiche, non bisogna lasciarsi scoraggiare dall'apparente obiettivo "matematico" del software.
Ti assicuro che è davvero uno strumento formidabile per citazioni, riferimenti bibliografici, indici e quant'altro.
In ogni caso, non mi dilungo ancora in questo OT.
Se avessi bisogno di informazioni su LaTeX, scrivimi pure in privato.
Ciao e buon lavoro.
c_estrena
Sr. Member
Sr. Member
 
Messaggi: 284
Iscritto il: 23/06/2005, 15:27

Re: [RISOLTO] Problemi reinstallazione LibreOffice

Messaggioda mith » 13/06/2017, 9:31

Ti ringrazio per il suggerimento, ne ho sentito parlare e alcuni amici informatici mi hanno già suggerito questa possibilità. In effetti lavoro in ambito umanistico, ma guarderò il forum che hai indicato e se avrò bisogno di qualche indicazione ti contatterò.
Grazie e a presto!
mith
Newbie
Newbie
 
Messaggi: 31
Iscritto il: 23/08/2016, 21:16


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron