Curiosità sullo sviluppo dei pacchetti

Problemi con l'installazione di pacchetti
Rispondi
samiel
wiki member
wiki member
Messaggi: 2202
Iscritto il: 12/08/2006, 15:05
Località: Venezia

Curiosità sullo sviluppo dei pacchetti

Messaggio da samiel »

All'indirizzo https://tracker.debian.org/pkg/fontforge leggo alla prima riga di Action needed
A new upstream version is available: 20200314
e più sotto, alla voce version in VCS is newer than in repository, is it time to upload?
la notizia secondo cui
vcswatch reports that this package seems to have a new changelog entry (version 1:20200314~dfsg-1, distribution UNRELEASED) and new commits in its VCS. You should consider whether it's time to make an upload.
.
Ora, mi pare di capire che questa nuova versione non è nemmeno in experimental
e perciò non si può scaricare nemmeno a rischio e pericolo del'utente.
Le tempistiche perché il nuovo pacchetto sia realizzato sono dunque imprevedibili?

grazie
m
Aki
Global Moderator
Global Moderator
Messaggi: 9721
Iscritto il: 27/12/2007, 16:59

Re: Curiosità sullo sviluppo dei pacchetti

Messaggio da Aki »

Prova a chiedere ai maintainers del pacchetto: c'è un bug report aperto, ma nessuno dei maintainers ha risposto: https://bugs.debian.org/cgi-bin/bugrepo ... bug=961841
samiel
wiki member
wiki member
Messaggi: 2202
Iscritto il: 12/08/2006, 15:05
Località: Venezia

Re: Curiosità sullo sviluppo dei pacchetti

Messaggio da samiel »

Il bug a cui ti riferisci è «Found in version fontforge/1:20190801~dfsg-5».
Ma io trovo in VCS la versione 1:20200314~dfsg-1.
Questo significa che finché non viene risolto il bug di 20190801~dfsg-5
non si passa (nemmeno al limite in experimental) alla 20200314~dfsg-1?
grazie
m
Aki
Global Moderator
Global Moderator
Messaggi: 9721
Iscritto il: 27/12/2007, 16:59

Re: Curiosità sullo sviluppo dei pacchetti

Messaggio da Aki »

samiel ha scritto:Il bug a cui ti riferisci è «Found in version fontforge/1:20190801~dfsg-5».
Ma io trovo in VCS la versione 1:20200314~dfsg-1.
Questo significa che finché non viene risolto il bug di 20190801~dfsg-5
non si passa (nemmeno al limite in experimental) alla 20200314~dfsg-1?
grazie
m
No, sto dicendo che i manutentori del pacchetto per qualche motivo non stanno ancora pacchetizzando la nuova ultima versione disponibile upstream. Puoi scrivere nella specifica mailing per chiedere eventuali ragguagli in merito.
samiel
wiki member
wiki member
Messaggi: 2202
Iscritto il: 12/08/2006, 15:05
Località: Venezia

Re: Curiosità sullo sviluppo dei pacchetti

Messaggio da samiel »

Puoi scrivere nella specifica mailing per chiedere eventuali ragguagli in merito.
Probabilmente sono cieco io, ma dove trovo il contatto per questa specifica mailing list?
grazie
m
Aki
Global Moderator
Global Moderator
Messaggi: 9721
Iscritto il: 27/12/2007, 16:59

Re: Curiosità sullo sviluppo dei pacchetti

Messaggio da Aki »

Ad esempio, dalla sezione maintainer della pagina del tracker del pacchetto: debian-fonts@lists.debian.org .

In ogni caso, se non erro, lo scorso 5 agosto in testing è arrivata la versione 1:20190801~dfsg-4 :
fontforge (1:20190801~dfsg-4) unstable; urgency=high

* Team upload.
* debian/control: Set maintainer email to new mailing list.
* debian/control.in: Also reflect some changes in the .in file.
* debian/rules: Fix broken dev-dep list for cdbs.
* debian/copyright:
+ Properly set Upstream-Name and Upstream-Contact.
+ Update license information for AppStream metadata file.

-- Boyuan Yang <byang@debian.org> Thu, 05 Mar 2020 22:10:07 -0500
Rispondi