Problemi alsa dopo aggiornamento sid

Problemi con l'installazione di pacchetti

Problemi alsa dopo aggiornamento sid

Messaggioda bitols » 28/05/2006, 17:28

Ciao a tutti. Ieri dopo aver aggiornato debian unstable non riesco più a visualizzare video nè con xine nè con mplayer. Infatti quando li lancio da shell, alla fine di tutto l\'output, trovo scritto quanto segue: alsa-init: using device default
gmplayer: relocation error: gmplayer: symbol snd_pcm_hw_params_set_channels_near, version ALSA_0.9.0rc4 not defined in file libasound.so.2 with link time reference

Posso risolvere il problema senza aspettare il nuovo aggiornamento di sid?

Post modificato da: bitols, alle: 28/05/2006 12:32
bitols
Full Member
Full Member
 
Messaggi: 160
Iscritto il: 15/09/2005, 6:58

Re:Problemi alsa dopo aggiornamento sid

Messaggioda Ldonesty » 28/05/2006, 18:08

Problema noto.. devi riportare il pacchetto libasound alla versione precedente (anche il -dev se lo usi)..
Questa versione da me funziona:
Codice: Seleziona tutto
Chiba:/home/io# dpkg -l | grep libas
ii  libasound2                         1.0.11-4                       ALSA library
ii  libasound2-dev                     1.0.11-4                       ALSA library development files
Il reggiseno e' uno strumento democratico perche' separa la destra dalla sinistra, solleva le masse e attira i popoli.
Avatar utente
Ldonesty
Hero Member
Hero Member
 
Messaggi: 763
Iscritto il: 22/12/2004, 17:31
Località: Un po' a Gaeta, un po' a Signa

Re:Problemi alsa dopo aggiornamento sid

Messaggioda bitols » 28/05/2006, 19:11

Ho lanciato il comando ed è uscito questo output:
Codice: Seleziona tutto
ii  libasound2                       1.0.11-5                    ALSA library
ii  libaspell15                      0.60.4-4                    GNU Aspell spell-checker runtime library

Ho effettuato il downgrade del pacchetto scaricandolo da http://snapshot.debian.net/archive/2006 ... 4_i386.deb poi tramite dpkg -i l\'ho installato. Grazie B)

Post modificato da: bitols, alle: 28/05/2006 15:56
bitols
Full Member
Full Member
 
Messaggi: 160
Iscritto il: 15/09/2005, 6:58


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron