Impossibile installare XFCE - pacchetti danneggiati bloccat

Problemi con l'installazione di pacchetti

Impossibile installare XFCE - pacchetti danneggiati bloccat

Messaggioda vimana » 03/10/2013, 9:38

Salve a tutti :)

Vorrei installare xfce per avere qualche prestazione in più.
Ho debian 7.1 con gnome 3.4.2 (non so se bastano queste info per potermi aiutare)
Se provo a selezionare xfce da gestore pacchetti ho questo errore:

http://imageshack.us/photo/my-images/823/loi6.png

da terminale:

Codice: Seleziona tutto
vimana@debian:~$ sudo apt-get install xfce4
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:
 
I seguenti pacchetti hanno dipendenze non soddisfatte:
 xfce4 : Dipende: xfce4-settings (>= 4.10.0) ma non sta per essere installato
         Dipende: xfce4-session (>= 4.10.0) ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.


Ho letto che potevano esserci dei pacchetti bloccati quindi ho dato:
dpkg -l >> pkglist
ed ho visto che l'unico pacchetto ad avere problemiè questo:
rc xfce4-settings 4.10.1-2 i386 graphical application for managing Xfce settings

il mio /etc/apt/sources.list

Codice: Seleziona tutto
vimana@debian:~$ cat /etc/apt/sources.list
#
 
# deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official Multi-architecture amd64/i386 NETINST #1 20130615-23:44]/ wheezy main
 
#deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official Multi-architecture amd64/i386 NETINST #1 20130615-23:44]/ wheezy main
 
deb http://ftp.it.debian.org/debian/ wheezy main
deb-src http://ftp.it.debian.org/debian/ wheezy main
 
deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main
 
# wheezy-updates, previously known as 'volatile'
deb http://ftp.it.debian.org/debian/ wheezy-updates main
deb-src http://ftp.it.debian.org/debian/ wheezy-updates main
 
#deb http://www.bunkus.org/debian/wheezy/ ./
#deb-src http://www.bunkus.org/debian/wheezy/ ./


Dove sbaglio?
Grazie in anticipo
vimana
Newbie
Newbie
 
Messaggi: 7
Iscritto il: 03/10/2013, 9:19

Re: Impossibile installare XFCE - pacchetti danneggiati bloc

Messaggioda metaldaze » 03/10/2013, 11:35

Sicuro di aver aggiornato la lista dei pacchetti prima di tentare l'installazione?
Il mio consiglio è di evitare synaptic e di usare aptitude e non apt-get da terminale.
In sostanza, aggiorna la lista dei pacchetti con
Codice: Seleziona tutto
aptitude update

e installa xfce4 con
Codice: Seleziona tutto
aptitude install xfce4 lightdm xfce4-goodies

Riporta eventuali errori se ancora non riesci ad installare.
metaldaze
Administrator
Administrator
 
Messaggi: 2350
Iscritto il: 13/12/2005, 5:18
Località: Torino

Re: Impossibile installare XFCE - pacchetti danneggiati bloc

Messaggioda vimana » 03/10/2013, 16:52

con l'install mi esce questo, ma sinceramente mi sono fermato non ho ben capito se quelle dipendenze le devo soddisfare prima o posso andare avanti tranquillamente.

Codice: Seleziona tutto
vimana@debian:~$ sudo aptitude install xfce4 lightdm xfce4-goodies
I seguenti pacchetti NUOVI (NEW) saranno installati:
  a2ps{a} gtk2-engines-xfce{a} hddtemp{a} libhal-storage1{a} libhal1{a} libjpeg-progs{a} libkeybinder0{a} liblightdm-gobject-1-0{a}
  libnotify-bin{a} libthunar-vfs-1-2{a} libthunar-vfs-1-common{a} libtumbler-1-0{a} libunique-1.0-0{a} libxfce4ui-utils{a}
  libxfcegui4-4{a} lightdm lightdm-gtk-greeter{a} mousepad{a} orage{a} ristretto{a} squeeze{a} tango-icon-theme{a} tumbler{a}
  tumbler-common{a} wdiff{a} xfburn{a} xfce4 xfce4-appfinder{a} xfce4-artwork{a} xfce4-battery-plugin{a} xfce4-clipman{a}
  xfce4-clipman-plugin{a} xfce4-cpufreq-plugin{a} xfce4-cpugraph-plugin{a} xfce4-datetime-plugin{a} xfce4-dict{a}
  xfce4-diskperf-plugin{a} xfce4-fsguard-plugin{a} xfce4-genmon-plugin{a} xfce4-goodies xfce4-mailwatch-plugin{a} xfce4-mixer{a}
  xfce4-mount-plugin{a} xfce4-netload-plugin{a} xfce4-notes{a} xfce4-notes-plugin{a} xfce4-notifyd{a} xfce4-panel{a}
  xfce4-places-plugin{a} xfce4-power-manager{a} xfce4-power-manager-data{a} xfce4-quicklauncher-plugin{a} xfce4-screenshooter{a}
  xfce4-sensors-plugin{a} xfce4-session{a} xfce4-settings{ab} xfce4-smartbookmark-plugin{a} xfce4-systemload-plugin{a}
  xfce4-taskmanager{a} xfce4-terminal{a} xfce4-timer-plugin{a} xfce4-verve-plugin{a} xfce4-volumed{a} xfce4-wavelan-plugin{a}
  xfce4-weather-plugin{a} xfce4-xkb-plugin{a} xfdesktop4{a} xfdesktop4-data{a} xfprint4{a} xfwm4{a} xfwm4-themes{a} xscreensaver{a}
  xscreensaver-data{a}
0 pacchetti aggiornati, 73 installati, 0 da rimuovere e 0 non aggiornati.
È necessario prelevare 29,5 MB/34,0 MB di archivi. Dopo l'estrazione, verranno occupati 89,9 MB.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 xfce4-settings : Dipende: libglib2.0-0 (>= 2.35.9) ma 2.33.12+really2.32.4-5 è installato.
                  Dipende: libpango-1.0-0 (>= 1.14.0) che è un pacchetto virtuale.
Le seguenti azioni permetteranno di soddisfare queste dipendenze:

     Mantenere i seguenti pacchetti alla versione attuale:
1)     xfce4 [Non installato]                             
2)     xfce4-session [Non installato]                     
3)     xfce4-settings [Non installato]                   



Accettare questa soluzione? [Y/n/q/?]
vimana
Newbie
Newbie
 
Messaggi: 7
Iscritto il: 03/10/2013, 9:19

Re: Impossibile installare XFCE - pacchetti danneggiati bloc

Messaggioda metaldaze » 03/10/2013, 17:47

Dall'output che hai pubblicato sembra che tu abbia provato ad installare il pacchetto xfce4-settings di Jessie e non di Wheezy. Questo va in conflitto con il file sources.list che ci hai mostrato. Non è che ti sei dimenticato di dirci qualcosa? Ogni cosa tentata è importante.
metaldaze
Administrator
Administrator
 
Messaggi: 2350
Iscritto il: 13/12/2005, 5:18
Località: Torino

Re: Impossibile installare XFCE - pacchetti danneggiati bloc

Messaggioda vimana » 03/10/2013, 18:05

ora che ci ripenso si, ho seguito questo guida, senza sucesso:

http://www.lffl.org/2012/11/installare- ... heezy.html
vimana
Newbie
Newbie
 
Messaggi: 7
Iscritto il: 03/10/2013, 9:19

Re: Impossibile installare XFCE - pacchetti danneggiati bloc

Messaggioda metaldaze » 03/10/2013, 19:15

Bene, il che mi fa pensare che hai un bel minestrone nei pacchetti installati.
Prova a fare
Codice: Seleziona tutto
aptitude purge xfce4-settings

e poi a installare xfce4 come ti ho detto prima.
Speriamo che questo sia sufficiente!
metaldaze
Administrator
Administrator
 
Messaggi: 2350
Iscritto il: 13/12/2005, 5:18
Località: Torino

Re: Impossibile installare XFCE - pacchetti danneggiati bloc

Messaggioda vimana » 03/10/2013, 19:43

mi da questo:

Codice: Seleziona tutto
vimana@debian:~$ sudo aptitude purge xfce4-settings
Nessun pacchetto verrà installato, aggiornato o rimosso.
0 pacchetti aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
È necessario prelevare 0 B di archivi. Dopo l'estrazione, verranno occupati 0 B.
                                                     
vimana@debian:~$


ed il comando di prima da lo stesso messaggio. quindi non sono andato avanti.
vimana
Newbie
Newbie
 
Messaggi: 7
Iscritto il: 03/10/2013, 9:19

Re: Impossibile installare XFCE - pacchetti danneggiati bloc

Messaggioda metaldaze » 03/10/2013, 20:23

Allora i casi sono due: o hai ancora qualche repository sbagliato nel tuo /etc/apt/sources.list (o dentro /etc/apt/sources.list.d), oppure non hai fatto l'aggiornamento della lista dei pacchetti come ti ho suggerito prima.
metaldaze
Administrator
Administrator
 
Messaggi: 2350
Iscritto il: 13/12/2005, 5:18
Località: Torino

Re: Impossibile installare XFCE - pacchetti danneggiati bloc

Messaggioda vimana » 03/10/2013, 20:30

l'update l'ho fatto proprio come mi hai detto


Codice: Seleziona tutto
vimana@debian:~$ cat /etc/apt/sources.list
#

# deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official Multi-architecture amd64/i386 NETINST #1 20130615-23:44]/ wheezy main

#deb cdrom:[Debian GNU/Linux 7.1.0 _Wheezy_ - Official Multi-architecture amd64/i386 NETINST #1 20130615-23:44]/ wheezy main

deb http://ftp.it.debian.org/debian/ wheezy main
deb-src http://ftp.it.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'volatile'
deb http://ftp.it.debian.org/debian/ wheezy-updates main
deb-src http://ftp.it.debian.org/debian/ wheezy-updates main

#deb http://www.bunkus.org/debian/wheezy/ ./
#deb-src http://www.bunkus.org/debian/wheezy/ ./
vimana@debian:~$



----

Codice: Seleziona tutto
vimana@debian:~$ ls /etc/apt/sources.list.d
dropbox.list  google-chrome.list  xfcenext.list
vimana@debian:~$


come possiamo risolvere?
vimana
Newbie
Newbie
 
Messaggi: 7
Iscritto il: 03/10/2013, 9:19

Re: Impossibile installare XFCE - pacchetti danneggiati bloc

Messaggioda TonyB » 03/10/2013, 20:37

Ciao,
cosa c'è in /etc/apt/sources.list.d/xfcenext.list?
Avatar utente
TonyB
Sr. Member
Sr. Member
 
Messaggi: 376
Iscritto il: 15/12/2007, 20:57

Re: Impossibile installare XFCE - pacchetti danneggiati bloc

Messaggioda vimana » 03/10/2013, 20:44

vimana@debian:/etc/apt/sources.list.d$ cat xfcenext.list
deb http://packages.siduction.org/xfcenext unstable main
deb-src http://packages.siduction.org/xfcenext unstable main
vimana
Newbie
Newbie
 
Messaggi: 7
Iscritto il: 03/10/2013, 9:19

Re: Impossibile installare XFCE - pacchetti danneggiati bloc

Messaggioda TonyB » 03/10/2013, 20:49

Ecco trovata la causa dei tuoi problemi, i repo di siduction, compatibili a livello binario con quelli debian, ma evidentemente creano problemi con le dipendenze.
Eliminali e dovresti risolvere, quantomeno dovresti riuscire a installare xfce di wheezy; se poi desideri xfce 4.10 puoi prenderlo da testing con un po' di pinning.
Saluti.
Avatar utente
TonyB
Sr. Member
Sr. Member
 
Messaggi: 376
Iscritto il: 15/12/2007, 20:57

Re: Impossibile installare XFCE - pacchetti danneggiati bloc

Messaggioda vimana » 03/10/2013, 21:10

Ohhh perfetto! era quello il problema grazie a tutti :D
vimana
Newbie
Newbie
 
Messaggi: 7
Iscritto il: 03/10/2013, 9:19

Re: Impossibile installare XFCE - pacchetti danneggiati bloc

Messaggioda metaldaze » 04/10/2013, 7:39

Prego, ma la prossima volta cerca di non usare repository non ufficiali se non sai esattamente cosa stai facendo ;)
metaldaze
Administrator
Administrator
 
Messaggi: 2350
Iscritto il: 13/12/2005, 5:18
Località: Torino


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti