Installazione Ruby 1.9 oltre alla già presente 1.8

Problemi con l'installazione di pacchetti

Installazione Ruby 1.9 oltre alla già presente 1.8

Messaggioda Ismaele » 02/04/2014, 14:00

Salve a tutti,
sto cercando d'installare Ruby 1.9 su di un sistema Debian Wheezy che dispone già della versione 1.8, con l'obbligo di mantenere entrambe le versioni.

Di seguito l'output restituitomi da rvm
--------------------------
root@vps49122:~# rvm install 1.9.3 --autolibs=3
Searching for binary rubies, this might take some time.
No binary rubies available for: debian/jessie_sid/x86_64/ruby-1.9.3-p545.
Continuing with compilation. Please read 'rvm help mount' to get more information on binary rubies.
Checking requirements for debian.
Installing requirements for debian.
Updating system..
Installing required packages: libreadline6-dev, libyaml-dev, sqlite3, autoconf, libgdbm-dev, libncurses5-dev, automake, bison, libffi-dev...
Error running 'requirements_debian_libs_install libreadline6-dev libyaml-dev sqlite3 autoconf libgdbm-dev libncurses5-dev automake bison libffi-dev',
showing last 15 lines of /usr/local/rvm/log/1396436338_ruby-1.9.3-p545/package_install_libreadline6-dev_libyaml-dev_sqlite3_autoconf_libgdbm-dev_libncurses5-dev_automake_bison_libffi-dev.log
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgdbm-dev : Depends: libgdbm3 (= 1.8.3-11) but 1.8.3-12 is to be installed
libncurses5-dev : Depends: libtinfo5 (= 5.9-10) but 5.9+20140118-1 is to be installed
Depends: libncurses5 (= 5.9-10) but 5.9+20140118-1 is to be installed
Depends: libtinfo-dev (= 5.9-10) but it is not going to be installed
Depends: ncurses-bin (= 5.9-10) but 5.9+20140118-1 is to be installed
libreadline6-dev : Depends: libreadline6 (= 6.2+dfsg-0.1) but 6.3-4 is to be installed
Depends: libtinfo-dev but it is not going to be installed
libyaml-dev : Depends: libyaml-0-2 (= 0.1.4-2+deb7u4) but 0.1.4-3.1 is to be installed
E: Unable to correct problems, you have held broken packages.
++ return 100
++ return 100
Requirements installation failed with status: 100.
root@vps49122:~#
----------------------------------------

Secondo voi c'e' un modo di patchare la situazione senza formattare il VPS (su OVH) e ripartire da capo con l'installazione ?
Fondamentalmente sto cercando d'installare RedMine, ma per esigenze di produttività interna mi hanno chiesto di mantenere due versioni di Ruby..

Ora, accedo senza problemi alla cartella /home/redmine/public, ma appunto quando provo ad aggiungere Ruby 1.9 ottengo il messaggio d'errore di cui sopra.


Grazie,
saluti
Ismaele
Jr. Member
Jr. Member
 
Messaggi: 62
Iscritto il: 24/08/2010, 12:53

Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti