Pagina 1 di 1

installare skype

MessaggioInviato: 30/10/2014, 21:09
da hesse
Buonasera a tutti, come da titolo non riesco ad installare skype. Il problema pernso che sia nato quando ho aggiornato lib6 usando il repository deb http://ftp.debian.org/debian experimental main. Ho provato ad eseguire le guide aggiungendo l'architettura i386 aggiornare e installare anche le dipendenze ma niente, non funziona neanche apt-get install -f... ???

Re: installare skype

MessaggioInviato: 31/10/2014, 8:40
da mirko.pagliai
Riporta tutto l'output utile.

Re: installare skype

MessaggioInviato: 31/10/2014, 19:35
da hesse
mirko.pagliai ha scritto:Riporta tutto l'output utile.

si, ecco!!
Codice: Seleziona tutto
Distribuzione
No LSB modules are available.
Distributor ID:   Debian
Description:   Debian GNU/Linux 7.7 (wheezy)
Release:   7.7
Codename:   wheezy
versione kernel: 3.16-0.bpo.2-amd64
**************************************************
 
repository

# deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37]/ wheezy contrib main
#deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37]/ wheezy contrib main

deb http://ftp.it.debian.org/debian/ wheezy main
deb-src http://ftp.it.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main contrib
deb-src http://security.debian.org/ wheezy/updates main contrib

# wheezy-updates, previously known as 'volatile'
deb http://ftp.it.debian.org/debian/ wheezy-updates main contrib non-free
deb-src http://ftp.it.debian.org/debian/ wheezy-updates main contrib non-free

#mozilla
#deb ftp://ftp.debian.org/debian stable main contrib non-free
#telegram
#deb http://ftp.debian.org/debian experimental main
#deb http://ftp.us.debian.org/debian/ testing main contrib non-free

deb http://ftp.debian.org/debian wheezy-backports


posto anche gli errori che ricevo quandp tendo di installare il pacchetto:
Codice: Seleziona tutto
# dpkg -i skype-debian_4.3.0.37-1_i386.deb
Selezionato il pacchetto skype non precedentemente selezionato.
(Lettura del database... 149543 file e directory attualmente installati.)
Estrazione di skype (da skype-debian_4.3.0.37-1_i386.deb)...
dpkg: problemi con le dipendenze impediscono la configurazione di skype:
 skype dipende da libc6 (>= 2.3.6-6~); comunque:
  Il pacchetto libc6:i386 non è installato.
 skype dipende da libc6 (>= 2.7); comunque:
  Il pacchetto libc6:i386 non è installato.
 skype dipende da libgcc1 (>= 1:4.1.1); comunque:
  Il pacchetto libgcc1:i386 non è installato.
 skype dipende da libqt4-dbus (>= 4:4.5.3); comunque:
  Il pacchetto libqt4-dbus non è installato.
 skype dipende da libqt4-network (>= 4:4.8.0); comunque:
  Il pacchetto libqt4-network:i386 non è installato.
 skype dipende da libqt4-xml (>= 4:4.5.3); comunque:
  Il pacchetto libqt4-xml:i386 non è installato.
 skype dipende da libqtcore4 (>= 4:4.7.0~beta1); comunque:
  Il pacchetto libqtcore4:i386 non è installato.
 skype dipende da libqtgui4 (>= 4:4.8.0); comunque:
  Il pacchetto libqtgui4:i386 non è installato.
 skype dipende da libqtwebkit4 (>= 2.1.0~2011week13); comunque:
  Il pacchetto libqtwebkit4:i386 non è installato.
 skype dipende da libstdc++6 (>= 4.2
dpkg: errore nell'elaborare skype (--install):
 problemi con le dipendenze - lasciato non configurato
Elaborazione dei trigger per desktop-file-utils...
Elaborazione dei trigger per gnome-menus...
Elaborazione dei trigger per hicolor-icon-theme...
Si sono verificati degli errori nell'elaborazione:
 skype
root@Host-001:/home/ermanno/Scaricati# apt-get install -f
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti saranno inoltre installati:
  libmozjs24d xulrunner-24.0
I seguenti pacchetti saranno RIMOSSI:
  skype:i386
I seguenti pacchetti saranno aggiornati:
  libmozjs24d xulrunner-24.0
2 aggiornati, 0 installati, 1 da rimuovere e 0 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 19,6 MB di archivi.
Dopo quest'operazione, verranno liberati 44,3 MB di spazio su disco.
Continuare [S/n]? n
Interrotto.

Re: installare skype

MessaggioInviato: 31/10/2014, 19:39
da mirko.pagliai
Non hai aggiunto l'architettura i386, quindi il gestore dei pacchetti non trova quanto gli è necessario per soddisfare le dipendenze di Skype. Segui l'apposita guida e riporta l'output utile anche per questo caso.

Re: installare skype

MessaggioInviato: 01/11/2014, 6:34
da Usmnunter
Ciao,
usa gdebi (che risolve le dipendenze automaticamente), come specificato in questa guida:
http://guide.debianizzati.org/index.php/Skype

Buona giornata.

Re: installare skype

MessaggioInviato: 01/11/2014, 10:50
da hesse
ok!! ho eseguito la guida posto l'output:
Codice: Seleziona tutto
cat /etc/apt/sources.list

# deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37]/ wheezy contrib main
#deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37]/ wheezy contrib main

deb http://ftp.it.debian.org/debian/ wheezy main
deb-src http://ftp.it.debian.org/debian/ wheezy main

deb http://security.debian.org/ wheezy/updates main contrib
deb-src http://security.debian.org/ wheezy/updates main contrib

# wheezy-updates, previously known as 'volatile'
deb [arch=amd64,i386] http://ftp.it.debian.org/debian/ wheezy-updates main contrib non-free
deb-src [arch=amd64,i386] http://ftp.it.debian.org/debian/ wheezy-updates main contrib non-free

#mozilla
#deb ftp://ftp.debian.org/debian stable main contrib non-free
#telegram
#deb http://ftp.debian.org/debian experimental main
#deb http://ftp.us.debian.org/debian/ testing main contrib non-free
deb [arch=amd64,i386] http://ftp.debian.org/debian wheezy-backports main non-free contrib


Codice: Seleziona tutto
# apt-get install links:i386
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 links:i386 : Dipende: libbz2-1.0:i386 ma non sta per essere installato
              Dipende: libc6:i386 (>= 2.4) ma non sta per essere installato
              Dipende: libgpm2:i386 (>= 1.20.4) ma non sta per essere installato
              Dipende: liblzma5:i386 (>= 5.1.1alpha+20120614) ma non sta per essere installato
              Dipende: libssl1.0.0:i386 (>= 1.0.0) ma non sta per essere installato
              Dipende: zlib1g:i386 (>= 1:1.1.4) ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati


Per quanto riguarda gdebi nella guida c'è scritto che è per architettura i386, io sto usando una macchina a 64 bit

Re: installare skype

MessaggioInviato: 01/11/2014, 11:03
da marcomg
Esatto, per questo devi usare il multiarch...

Re: installare skype

MessaggioInviato: 01/12/2014, 21:39
da hesse
si, l'errore che ho postato è venuto a seguito di tale procedura.. ossia https://wiki.debian.org/Multiarch/HOWTO.