PHP5: problema dipendenze

Problemi con l'installazione di pacchetti

PHP5: problema dipendenze

Messaggioda Darso89 » 14/11/2014, 14:16

Ho installato Debian 7.7.0 su VirtualBox (tramite l'ISO debian-7.7.0-amd64-CD-1).
In seguito ho installato apache2 (con comando apt-get install), poi quando tento di
installare php5 (sempre da terminale) mi da il seguente errore:

Codice: Seleziona tutto
alcuni pacchetti non possono essere installati. questo
può voler dire che è stata richiesta una situazione impossibile
oppure, se si sta usando una distribuzione in sviluppo, che alcuni
pacchetti richiesti non sono ancora stati creati o stati rimossi
da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

i seguenti pacchetti hanno dipendenze non soddisfatte:
php5: dipende: libapache2-mod-php5 (>= 5.4.4-14+deb7u14) ma non sta per essere installato oppure
                      libapache2-mod-ph5filter (>=  5.4.4-14+deb7u14) ma non sta per essere installato oppure
php5-cgi ma non sta per essere installato oppure
php5-fpm ma non sta per essere installato
E: impossibile correggere i problemi, ci sono pacchetti danneggiati
bloccati
Ultima modifica di Darso89 il 20/11/2014, 13:54, modificato 1 volta in totale.
Darso89
Newbie
Newbie
 
Messaggi: 2
Iscritto il: 14/11/2014, 13:58

Re: PHP5: problema dipendenze

Messaggioda desperados » 14/11/2014, 14:31

l'immagine io non la vedo
- Potrebbe esser peggio. - E come? - Potrebbe piovere!
desperados
Hero Member
Hero Member
 
Messaggi: 776
Iscritto il: 22/02/2008, 8:55

Re: PHP5: problema dipendenze

Messaggioda marcomg » 15/11/2014, 14:46

Posta il testo dell'errore, no immagini.
Windows is what you open when you want fresh air from outside.
Avatar utente
marcomg
Hero Member
Hero Member
 
Messaggi: 5592
Iscritto il: 22/08/2011, 18:54

Re: PHP5: problema dipendenze

Messaggioda Darso89 » 20/11/2014, 13:54

marcomg ha scritto:Posta il testo dell'errore, no immagini.

Codice: Seleziona tutto
alcuni pacchetti non possono essere installati. questo
può voler dire che è stata richiesta una situazione impossibile
oppure, se si sta usando una distribuzione in sviluppo, che alcuni
pacchetti richiesti non sono ancora stati creati o stati rimossi
da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

i seguenti pacchetti hanno dipendenze non soddisfatte:
php5: dipende: libapache2-mod-php5 (>= 5.4.4-14+deb7u14) ma non sta per essere installato oppure
                      libapache2-mod-ph5filter (>=  5.4.4-14+deb7u14) ma non sta per essere installato oppure
php5-cgi ma non sta per essere installato oppure
php5-fpm ma non sta per essere installato
E: impossibile correggere i problemi, ci sono pacchetti danneggiati
bloccati
Darso89
Newbie
Newbie
 
Messaggi: 2
Iscritto il: 14/11/2014, 13:58

Re: PHP5: problema dipendenze

Messaggioda mirko.pagliai » 20/11/2014, 14:34

Posta tutto il comando.
Magari anche il sources.list.
Prova SSMP: i tuoi file multimediali accessibili da tutti i tuoi dispositivi! [sito | topic sul forum]

www.mirkopagliai.it

Ubuntu è un'antica parola africana che significa "Non so installare Debian" (cit.)
Avatar utente
mirko.pagliai
Administrator
Administrator
 
Messaggi: 4102
Iscritto il: 15/03/2010, 23:46

Re: PHP5: problema dipendenze

Messaggioda desperados » 21/11/2014, 9:37

non è che hai sorgenti apt mischiate tra stable e unstable?
di solito, provando ad installare i pacchetti che ti dice "non sta per essere installato", ti dice che problemi hanno
fai apt-get install libapache2-mod-php5 libapache2-mod-ph5filter e posta il risultato
- Potrebbe esser peggio. - E come? - Potrebbe piovere!
desperados
Hero Member
Hero Member
 
Messaggi: 776
Iscritto il: 22/02/2008, 8:55


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti