[RISOLTO] Problemi per installare NixNote 2

Problemi con l'installazione di pacchetti

[RISOLTO] Problemi per installare NixNote 2

Messaggioda Shiki » 05/05/2015, 10:58

Ciao, avrei un problema con NixNote...

Ho installato la versione 1 senza troppi problemi, installando alcuni pacchetti che mi richiedeva ma ho scoperto che non si sincronizza con EverNote e per me sarebbe utile avere tutte le note sincronizzate tra il mio cellulare, il pc con windows e questo con Debian...
Allora ho provato a installare NixNote 2 ma mi da una lista di pacchetti da installare che non finisce più. Ho provato a installarne alcuni ma ogni tanto compare un nuovo pacchetto che manca...

Ora mi dice che mancano questi:

Codice: Seleziona tutto
# gdebi nixnote2-2.0-beta3_i386.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Building data structures... Done
Building data structures... Done
Questo pacchetto non è installabile
Dependency is not satisfiable: libavformat53|libavformat54|libavformat-extra-53|libavformat-extra-54


Non c'è un modo più veloce per risolvere il problema?

Grazie mille :)
Ultima modifica di Shiki il 05/05/2015, 15:41, modificato 1 volta in totale.
Avatar utente
Shiki
Newbie
Newbie
 
Messaggi: 34
Iscritto il: 22/07/2013, 18:57

Re: Problemi per installare NixNote 2

Messaggioda ferdybassi » 05/05/2015, 11:11

Il mio consiglio è di fare tutto da linea di comando come root.
Prima di tutto installi il pacchetto di nixnote2:
Codice: Seleziona tutto
dpkg -i nixnote2-2.0-beta3_i386.deb

Il gestore dei pacchetti dpkg ti risponderà che mancano delle dipendenze e lascerà il pacchetto installato a metà.
A quel punto basta sistemare le cose con l'opzione -f (credo stia per "fix"):
Codice: Seleziona tutto
apt-get -f install

e vedrai che ti scaricherà le dipendenze, le installerà e concluderà l'installazione di nixnote.
Tutto questo a patto che nella versione di Debian che stai usando siano presenti i pacchetti richiesti dalle dipendenze, ma direi di sì, sono pacchetti abbastanza comuni..

Ciao ciao
Immagine  Immagine
Avatar utente
ferdybassi
Administrator
Administrator
 
Messaggi: 3285
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: Problemi per installare NixNote 2

Messaggioda HAL 9000 » 05/05/2015, 11:26

Non ha specificato la sua versione di Debian, ma credo che il problema sia causato dal fatto che utilizza Debian 8 (Jessie) o una più recente, a partire dalla quale c'è soltanto libavformat56.

Quel pacchetto è probabile sia stato preparato per una versione LTS di Ubuntu, e forse è compatibile solo con Debian 7 (Wheezy).

Forse può provare a scaricare un archivio tar e controllare se funziona (se include già tutte le librerie).
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01

Re: Problemi per installare NixNote 2

Messaggioda Shiki » 05/05/2015, 12:02

Ho Debian 8.

Comunque, seguendo le istruzioni di ferdybassi Nix Note 2 si è installato e sembra funzionare.
Ho sincronizzato l'account e ho tutte le mie note a disposizione...
Quindi sembra tutto ok, grazie mille :D

Solo che adesso ho NixNote e NixNote 2, come posso fare per rimuovere tutto ciò che riguarda solo NixNote?
Avatar utente
Shiki
Newbie
Newbie
 
Messaggi: 34
Iscritto il: 22/07/2013, 18:57

Re: Problemi per installare NixNote 2

Messaggioda HAL 9000 » 05/05/2015, 12:12

Se l'hai installato sempre tramite un pacchetto deb, ti basta rimuovere quello, e saranno rimosse le sole dipendenze non richieste da nixnote2.

Per cercare i pacchetti installati:
Codice: Seleziona tutto
$ dpkg --list "nixnote*"


Comunque controlla anche che non ci siano errori:
Codice: Seleziona tutto
$ dpkg --audit

(in caso si possono correggere creando un metapacchetto con equivs, visto che non serve quella versione specifica)
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01

Re: Problemi per installare NixNote 2

Messaggioda Shiki » 05/05/2015, 14:15

Bene, NixNote l'ho rimosso e NixNote 2 sembra funzionare bene.

Ho solo notato un problema: nel gestore di pacchetti mi dice che il pacchetto nixnote2 è danneggiato. Che significa?
Perché non mi da problemi... quindi posso anche ignorarlo?
Perché se clicco su "installa i pacchetti raccomandati" mi fa rimuovere nixnote2...
Avatar utente
Shiki
Newbie
Newbie
 
Messaggi: 34
Iscritto il: 22/07/2013, 18:57

Re: Problemi per installare NixNote 2

Messaggioda HAL 9000 » 05/05/2015, 14:40

Il problema è causato dal fatto che non ha soddisfatto tutte le sue dipendenze, per quello non te lo lasciava installare con gdebi.
Ora, quelle dipendenze non servono, visto che ti funziona lo stesso, e sono soddisfatte dalle altre librerie più aggiornate.

Per evitare il problema, devi controllare la situazione:
Codice: Seleziona tutto
$ dpkg --audit

(se ti restituisce errori, come i pacchetti mancanti)

E poi installare equivs, che ti permette di creare un metapacchetto (non contenente nulla), solo per soddisfare tali dipendenze:
Codice: Seleziona tutto
# apt-get install equivs


Nel caso di libavformat53, ti basta:
Codice: Seleziona tutto
$ equivs-control libavformat53

Crea un file libavformat53, che apri con un editor di testo qualsiasi, e aggiungi il nome del pacchetto (libavformat53) alla riga:
Codice: Seleziona tutto
Package: <...>

che diventerà:
Codice: Seleziona tutto
Package: libavformat53

(se vuoi puoi anche scrivere nel campo della descrizione che l'hai creato tu)

Poi crei il pacchetto deb:
Codice: Seleziona tutto
$ equivs-build libavformat53


E alla fine lo installi:
Codice: Seleziona tutto
# dpkg -i libavformat53*.deb


Poi ridai "dpkg --audit" e ripeti la procedura per ogni dipendenza mancante, se ce ne fossero altre. :)
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01

Re: Problemi per installare NixNote 2

Messaggioda ferdybassi » 05/05/2015, 14:51

@HAL9000
La guida, vogliamo la guida :)
Immagine  Immagine
Avatar utente
ferdybassi
Administrator
Administrator
 
Messaggi: 3285
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: Problemi per installare NixNote 2

Messaggioda HAL 9000 » 05/05/2015, 15:02

@ferdybassi: cercando tra le guide equivs è già trattato nella gestione dei metapacchetti, e penso di averlo imparato proprio da lì, anche se non l'ho mai usato per "soddisfare" dipendenze. Potrei però verificare la guida e forse aggiungere un paio di paragrafi per questo, una volta ricevuta conferma da Shiki. :)
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01

Re: Problemi per installare NixNote 2

Messaggioda Shiki » 05/05/2015, 15:39

Sembra ora che sia davvero tutto a posto *-*
Non risulta più danneggiato e funziona perfettamente.

Ottimo, grazie mille :)
Avatar utente
Shiki
Newbie
Newbie
 
Messaggi: 34
Iscritto il: 22/07/2013, 18:57


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron