Apache ssl, WARNING: OpenSSL version is to old

Problemi con l'installazione di pacchetti

Apache ssl, WARNING: OpenSSL version is to old

Messaggioda suinfreedom » 14/05/2015, 9:56

Sto compilando da sorgente Apache 2.4 in modo da abilitare il modulo ssl. Il comando:

Codice: Seleziona tutto
./configure --prefix=/usr/local/apache2/ --enable-ssl --enable-so --with-apr=/usr/local/apr/ --with-apr-util=/usr/local/apr-util/


mi da il warning " configure: WARNING: OpenSSL version is too old
no
checking whether to enable mod_ssl... configure: error: mod_ssl has been requested but can not be built due to prerequisite failures"

ma la versione di openssl installata è la 1.0.1. , e non mi compila il pacchetto. Qualche idea per aggirare l'ostacolo ?
Avatar utente
suinfreedom
Newbie
Newbie
 
Messaggi: 4
Iscritto il: 23/03/2015, 7:07

Re: Apache ssl, WARNING: OpenSSL version is to old

Messaggioda ferdybassi » 14/05/2015, 10:11

Se il tuo problema è solo SSL, non starei a ricompilarmi tutto Apache da capo.
Apache pacchettizzato per Debian SSL ce l'ha già, basta abilitarlo e configurarlo:
http://guide.debianizzati.org/index.php ... one_di_SSL

Ciao!
Immagine  Immagine
Avatar utente
ferdybassi
Administrator
Administrator
 
Messaggi: 3285
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: Apache ssl, WARNING: OpenSSL version is to old

Messaggioda suinfreedom » 14/05/2015, 10:17

lo so.. ma devo compilarlo da sorgente e configurarlo, altrimenti non starei a perdere tempo.
Avatar utente
suinfreedom
Newbie
Newbie
 
Messaggi: 4
Iscritto il: 23/03/2015, 7:07

Re: Apache ssl, WARNING: OpenSSL version is to old

Messaggioda ferdybassi » 14/05/2015, 10:35

Ciao,
"devi" nel senso che te l'ha ordinato il dottore o c'è qualche altro motivo che non ci hai descritto?
Di versioni 1.0.1 di OpenSSL ce ne sono diverse, l'ultima mi sembra che sia la 1.0.1f
Devi vedere quale versione di Apache stai cercando di installare (2.4.9?, 2.4.10?, 2.4.12?) e verificare quale versione di OPenSSL è richiesta.

Ciao
Immagine  Immagine
Avatar utente
ferdybassi
Administrator
Administrator
 
Messaggi: 3285
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: Apache ssl, WARNING: OpenSSL version is to old

Messaggioda suinfreedom » 14/05/2015, 14:04

devo perchè sto facendo un training.
la versione di openssl è 1.0.1e, la versione di Apache è la 2.4.12..
Avatar utente
suinfreedom
Newbie
Newbie
 
Messaggi: 4
Iscritto il: 23/03/2015, 7:07

Re: Apache ssl, WARNING: OpenSSL version is to old

Messaggioda ferdybassi » 14/05/2015, 14:16

Mmmh,
temo che l'ultima versione di Apache, che è quella che stai usando, abbia bisogno delle openssl 1.0.2.
L'attuale stabile (Jessie) ha le 1.0.1k
In Sid c'è la 1.0.2a
Tu non ci hai detto quale versione di Debian stai usando, ma suppongo e spero l'attuale stabile.
Quindi sei a un bivio:
- o installi una versione precedente di apache, ad esempio la 2.0.10 che è la stessa che c'è in Jessie e quindi non dovrebbe darti problemi
- oppure ti avventuri in un aggiornamento delle openssl prelevandole dai repository di Sid: non ho idea di quanti altri pacchetti vadano aggiornati a catena, magari nessuno, magari ti si incasina un po' il sistema.

Ciao
Immagine  Immagine
Avatar utente
ferdybassi
Administrator
Administrator
 
Messaggi: 3285
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite