glade e GLib error in synaptic ed iceweasel

Problemi con l'installazione di pacchetti

glade e GLib error in synaptic ed iceweasel

Messaggioda fede73 » 25/06/2015, 9:56

Ho appena installato Jessie, con mate, in un portatile completamente vuoto (Acer Extensa 5635Z); apparentemente tutto bene al primo colpo, come ormai Debian mi ha abituato da molto tempo.
Ma, andando poi ad aggiungere pacchetti con synaptic, questo mi dice:
Codice: Seleziona tutto
(synaptic:2607): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
L'interfaccia gtk ha bisogno di python-gtk2 e python-glade2.
Non è possibile trovare questi moduli; verrà usata pager.
L'errore è: No module named glade

Però l'installazione di pacchetti va a buon fine.
Gli installo i pacchetti python-gtk2 e python-glade2 (mi dice che gli servono) e l'errore si accorcia:
Codice: Seleziona tutto
(synaptic:5547): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed

Però le installazioni vanno sempre a buon fine.
Se uso apt-get non ricevo alcun messaggio d'errore.

Iceweasel è in inglese, se do LANG=it_IT.UTF-8 iceweasel:
Codice: Seleziona tutto
fede@pc2:~$ LANG=it_IT.UTF-8 iceweasel

(process:1816): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

Però, per ora, tutto funziona.
Avatar utente
fede73
Newbie
Newbie
 
Messaggi: 46
Iscritto il: 24/03/2009, 20:23

Re: glade e GLib error in synaptic ed iceweasel

Messaggioda agomonos » 25/06/2015, 10:45

Per il messaggio di synaptic c'è questo bug report:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743995
Anche per il messaggio di iceweasel (che non dipende dall'inglese o dall'italiano) c'è un bug report:
https://bugzilla.mozilla.org/show_bug.cgi?id=833117
Ma per curiosità hai impostato il sistema in inglese? ???

Comunque non c'è da preoccuparsi.. Da quello che ho letto sono messaggi che non provocano crash o altri problemi, sono dovuti ad alcuni cambiamenti nella libreria glib. :)
agomonos
Newbie
Newbie
 
Messaggi: 32
Iscritto il: 05/04/2010, 8:59

Re: glade e GLib error in synaptic ed iceweasel

Messaggioda fede73 » 25/06/2015, 18:16

Se non provoca malfunzionamenti va tutto bene, credo sparirà nelle versioni prossime venture.
Il sistema l'avevo installato in italiano, ma iceweasel era comunque in inglese, perché non era installato il pacchetto
iceweasel-l10n-it, ora è in italiano.
Avatar utente
fede73
Newbie
Newbie
 
Messaggi: 46
Iscritto il: 24/03/2009, 20:23


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron