[RISOLTO] Installazione openjdk-7-jre

Problemi con l'installazione di pacchetti

Re: Installazione openjdk-7-jre

Messaggioda HAL 9000 » 19/10/2015, 11:37

Che versione stai utilizzando?

Codice: Seleziona tutto
cat /etc/debian_version


Con Debian 8.x (Jessie), l'attuale versione stabile, il pacchetto è presente. Inoltre nei backports c'è anche openjdk-8, che è l'ultima versione rilasciata.

Controlla anche i tuoi sources.list:
Codice: Seleziona tutto
cat /etc/apt/sources.list /etc/apt/sources.list.d/*.list


Qui un esempio per /etc/apt/sources.list.

Comunque per sviluppare programmi in Java il pacchetto che ti serve è openjdk-7-jdk oppure openjdk-8-jdk. Infatti openjdk-7-jre/openjdk-8-jre permette solo di eseguire programmi Java.

Come editor di testo hai solo l'imbarazzo della scelta. Se invece vuoi un IDE completo, come Eclipse o Netbeans, ti consiglio di procurarteli dal sito ufficiale, visto che le versioni distribuite con Debian sono quasi sempre obsolete.
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01

Re: Installazione openjdk-7-jre

Messaggioda Selky » 19/10/2015, 14:24

Mattia Campagna ha scritto:La versione è la 6.0.10

Se intendi che stai utilizzando Debian 6, cioè Squeeze, il pacchetto in questione non lo puoi installare perchè è disponibile solo da Wheezy (versione 7) e successivi.
Selky
wiki member
wiki member
 
Messaggi: 1424
Iscritto il: 30/12/2011, 1:00

Re: Installazione openjdk-7-jre

Messaggioda HAL 9000 » 20/10/2015, 12:30

Se hai fatto, ricordati di modificare il primo messaggio di questa discussione per aggiungere "[RISOLTO]" all'inizio del titolo. Può essere fatto solo da chi ha aperto la discussione o da un utente dello staff di debianizzati. :)

Inoltre tieni presente che Debian 6.x (Squeeze) è ormai obsoleta, e perfino il supporto (parziale) via squeeze-lts terminerà a febbraio 2016.
Salvo ci sia un motivo per restare con quella versione, considera di installare Debian 8 (Jessie), procedendo con una nuova installazione (scelta consigliata) oppure procedendo con un duplice avanzamento di versione (Squeeze -> Wheezy e poi Wheezy -> Jessie).
In caso di dubbi su come procedere, puoi chiedere consigli aprendo una nuova discussione. ;)
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite