[RISOLTO] su debian 8 nuova installazione

Problemi con l'installazione di pacchetti

[RISOLTO] su debian 8 nuova installazione

Messaggioda carlang59 » 01/04/2016, 10:33

Ciao
ho installato un nuovo server dove vorrei far girare LAMP come webserver con connessione ssl per maggior sicurezza.
Sto seguendo la guida del link http://guide.debianizzati.org/index.php ... ySQL,_PHP5

Credo di seguire alla lettera quanto indicato, apache2 mi risponde correttamente, quando però installo php ed ho creato il file info.php. Ma quando lo chiamo dal browser mi da errore:

Not Found
The requested URL /test.php was not found on this server.
Apache/2.4.10 (Debian) Server at 192.168.X.XX Port 80

anche se lo chiamo con https mi risponde:

Not Found
The requested URL /test.php was not found on this server.
Apache/2.4.10 (Debian) Server at 192.168.X.XX Port 443

Qualcuno mi aiuta ad andare avanti?
Grazie
Ultima modifica di carlang59 il 12/04/2016, 17:53, modificato 1 volta in totale.
carlang59
Newbie
Newbie
 
Messaggi: 41
Iscritto il: 22/09/2010, 12:29

Re: Lamp su debian 8 nuova installazione

Messaggioda ferdybassi » 01/04/2016, 20:40

Banalmente, non è un problema di nomi del file?
Dici di aver creato il file info.php, ma poi nel messaggio di errore compare il file test.php

Ciao ciao
Immagine  Immagine
Avatar utente
ferdybassi
Administrator
Administrator
 
Messaggi: 3285
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: Lamp su debian 8 nuova installazione

Messaggioda carlang59 » 04/04/2016, 9:21

Ti confermo che il nome del file è test.php, ho sbagliato la trascrizione (ho provato anche info.php). Mi sembrava troppo bello per essere vero...
Carlo
carlang59
Newbie
Newbie
 
Messaggi: 41
Iscritto il: 22/09/2010, 12:29

Re: Lamp su debian 8 nuova installazione

Messaggioda ferdybassi » 04/04/2016, 22:25

Peccato :)
Se non è un problema di nome, allora è un problema di permessi.
Copincolla il risultato del comando:
Codice: Seleziona tutto
ls -la /var/www


Ciao ciao
Immagine  Immagine
Avatar utente
ferdybassi
Administrator
Administrator
 
Messaggi: 3285
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: Lamp su debian 8 nuova installazione

Messaggioda carlang59 » 05/04/2016, 10:50

ferdybassi ha scritto:Peccato :)
Se non è un problema di nome, allora è un problema di permessi.
Copincolla il risultato del comando:
Codice: Seleziona tutto
ls -la /var/www


Ciao ciao


ecco il risltato:
root@debianweb:/home/mecgi# ls -la /var/www
totale 16
drwxr-xr-x 3 root root 4096 apr 1 09:53 .
drwxr-xr-x 12 root root 4096 mar 31 13:27 ..
drwxr-xr-x 2 root root 4096 mar 31 13:27 html
-rw-r--r-- 1 root root 22 apr 1 11:41 test.php
carlang59
Newbie
Newbie
 
Messaggi: 41
Iscritto il: 22/09/2010, 12:29

Re: Lamp su debian 8 nuova installazione

Messaggioda ferdybassi » 05/04/2016, 14:47

Prova un:
Codice: Seleziona tutto
chown www-data:www-data test.php

e vedi se funziona.
Immagine  Immagine
Avatar utente
ferdybassi
Administrator
Administrator
 
Messaggi: 3285
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: Lamp su debian 8 nuova installazione

Messaggioda carlang59 » 06/04/2016, 7:22

ferdybassi ha scritto:Prova un:
Codice: Seleziona tutto
chown www-data:www-data test.php

e vedi se funziona.


Purtroppo no, non cambia nulla.
carlang59
Newbie
Newbie
 
Messaggi: 41
Iscritto il: 22/09/2010, 12:29

Re: Lamp su debian 8 nuova installazione

Messaggioda ferdybassi » 06/04/2016, 7:35

Scusa, sono un pollo.
Stai usando Jessie, la guida non va bene.
La web root di Jessie non è
Codice: Seleziona tutto
/var/www

ma
Codice: Seleziona tutto
/var/www/html

I tuoi file devi metterli qui dentro.

Ciao ciao!
Immagine  Immagine
Avatar utente
ferdybassi
Administrator
Administrator
 
Messaggi: 3285
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: Lamp su debian 8 nuova installazione

Messaggioda carlang59 » 08/04/2016, 7:50

ciao
ok modificando il percorso ora funziona. E' questo è ok
Grazie.

Non so se posso continuare qua o aprire altro...
Ora andando avanti ho configurato mysql, phpmyadmin. Ho creato dei virtual hosts su directory home/pippo di fatto seguendo la guida come avevo fatto qualche anno con la configurazione per debian 6.
L'unica cosa modificata è l'aggiunta del .conf sul file site available.
Ora il problema che mi da è che mi dice che:
You don't have permission to access /www.mecgi.it on this server.

ho temporalmente cambiato tutti i permessi di file e cartelle a www-data 777 ma non cambia nulla
Carlo
carlang59
Newbie
Newbie
 
Messaggi: 41
Iscritto il: 22/09/2010, 12:29

Re: Lamp su debian 8 nuova installazione

Messaggioda ferdybassi » 08/04/2016, 9:38

Il virtual host per il sito www.mecgi.it l'hai configurato?
Immagine  Immagine
Avatar utente
ferdybassi
Administrator
Administrator
 
Messaggi: 3285
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: Lamp su debian 8 nuova installazione

Messaggioda carlang59 » 08/04/2016, 10:00

ferdybassi ha scritto:Il virtual host per il sito http://www.mecgi.it l'hai configurato?

Se intendi se ho attivato da apache2 con a2ensite il file di configurato per puntare alla directory creata la risposta è SÌ
Pensi sia utili che ti posti il contenuto del file ?

Per la precisione ora vedo che chiamando localhost mi da la stessa risposta di " non avere i permessi di accesso a questo server, ho provato sia sulla posta 80 che 443.
Mentre se chiamo localhost/phpmyadmin mi risponde correttamente.
Idem se dalla rete interna chiamo l'IP del server.
carlang59
Newbie
Newbie
 
Messaggi: 41
Iscritto il: 22/09/2010, 12:29

Re: Lamp su debian 8 nuova installazione

Messaggioda carlang59 » 11/04/2016, 12:02

mi rivolgo a ferdybassi, ringraziandoti per avermi risposto precedentemente. MA anche a chi mi può aiutare
Sono purtroppo ancora in panne.
Ho reinstallato tutto da 0.
Ora apache mi risponde come pure phpmyadmin.
Ho configurato i virtualhost come da guida http://guide.debianizzati.org/index.php ... spitare_più_siti_web
come avevo già fatto qualche anno fa.
ho ricopiato pari pari il file ma nulla.
quando lo chiamo mi da errore di
You don't have permission to access /www.xxxx.it on this server.
Apache/2.4.10 (Debian) Server at 192.168.1.75 Port 80.

Sembra proprio un problema di permessi.
Ho provato a modificare la porta 80 con la 443 visto che avevo installato il certificato come da guida su installazione lamp ma sono ancora in panne. Non so più dove sbattere la testa.
carlang59
Newbie
Newbie
 
Messaggi: 41
Iscritto il: 22/09/2010, 12:29

Re: Lamp su debian 8 nuova installazione

Messaggioda ferdybassi » 11/04/2016, 12:53

Posta il file di configurazione del virtual host.
Immagine  Immagine
Avatar utente
ferdybassi
Administrator
Administrator
 
Messaggi: 3285
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: Lamp su debian 8 nuova installazione

Messaggioda carlang59 » 11/04/2016, 15:40

ferdybassi ha scritto:Posta il file di configurazione del virtual host.


# www.mecgi.it

<VirtualHost *:80>
ServerName www.mecgi.it
ServerAlias mecgi.it
ServerAdmin carlol@mecgi.it
# webmaster@localhost

#Indexes + Directory Root.
DirectoryIndex index.html index.htm index.php
DocumentRoot /home/mecgi/www/www.mecgi.it/sitopubblico

Alias /phpmyadmin /usr/share/phpmyadmin

# CGI directory
ScriptAlias /cgi-bin/ /home/www/www.mecgi.it/cgi-bin/
<Location /cgi-bin>
Options +ExecCGI
</Location>

#logfiles
ErrorLog /home/mecgi/www/www.mecgi.it/log/error.log
CustomLog /home/mecgi/www/www.mecgi.it/log/access.log combined

</VirtualHost>

Grazie
Carlo
carlang59
Newbie
Newbie
 
Messaggi: 41
Iscritto il: 22/09/2010, 12:29

Re: Lamp su debian 8 nuova installazione

Messaggioda carlang59 » 11/04/2016, 16:10

aggiornamento.
Ho provato a modificare il path, portando le directory del futuro sito sotto /var e ...risponde! (/var/www/www.mecgi.it/sitopubblico)

Io avrei bisogno di metterlo su "/home/mecgi/www/www.mecgi.it/sitopubblico" cosa sbagliato?

Altra domanda: per accedere alla parte amministrativa solo in modalità protetta come devo fare? è preferibile far si che tutti arrivino con https ?
Grazie
Carlo
carlang59
Newbie
Newbie
 
Messaggi: 41
Iscritto il: 22/09/2010, 12:29

Prossimo

Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron