[RISOLTO] problema con zlib e gdm3

Problemi con l'installazione di pacchetti

[RISOLTO] problema con zlib e gdm3

Messaggioda kamui » 30/07/2019, 22:11

Salve,
su buster dopo aver installato zlib e aver riavviato non si avvia più il desktop manager gdm3.
ho installato zlib seguendo la procedura indicata qui
https://svn.oss.deltares.nl/repos/delft ... 4LT.readme

# Install zlib
v=1.2.8
wget ftp://ftp.unidata.ucar.edu/pub/netcdf/netcdf-4/zlib-${v}.tar.gz
tar -xf zlib-${v}.tar.gz && cd zlib-${v}
./configure --prefix=/usr/local
#sudo make check install
sudo make install

solo che dopo aver riavviato tutto, non si avvia più il desktop manager e non appare più la finestra con la richiesta per mettere username e password, rimane solo lo schermo nero e _
la stessa procedura usata con stretch e prima ancora con jessie non aveva dato problemi.

c'è maniera di saltare l'avvio di gdm3?
Ultima modifica di kamui il 09/08/2019, 10:30, modificato 1 volta in totale.
kamui
Newbie
Newbie
 
Messaggi: 13
Iscritto il: 30/07/2019, 21:33

Re: problema con zlib e gdm3

Messaggioda kamui » 01/08/2019, 8:43

Aggiornamento, ho notato che all'avvio appare l'indicazione 'resume from hibernation'.
kamui
Newbie
Newbie
 
Messaggi: 13
Iscritto il: 30/07/2019, 21:33

Re: problema con zlib e gdm3

Messaggioda Aki » 01/08/2019, 15:41

Perché hai compilato ed installato la libreria usando una fonte di terze parti (peraltro seguendo una riferita procedura non accessibile liberamente) piuttosto che usare la versione distribuita con Debian ? Perché hai scelto di non installare la versione della libreria distribuita con Debian [0] ?

[0] https://packages.debian.org/buster/zlib1g
Aki
Global Moderator
Global Moderator
 
Messaggi: 8806
Iscritto il: 27/12/2007, 16:59

Re: problema con zlib e gdm3

Messaggioda kamui » 01/08/2019, 17:11

Perché di Linux so pochissimo, ho un programma (delft3D) da installare e ho seguito le istruzioni presenti nella guida. Le stesse istruzioni che nelle precedenti due distribuzioni di Debian non avevano dato problemi. Basta?
kamui
Newbie
Newbie
 
Messaggi: 13
Iscritto il: 30/07/2019, 21:33

Re: problema con zlib e gdm3

Messaggioda Aki » 01/08/2019, 22:22

kamui ha scritto:ho un programma (delft3D) da installare e ho seguito le istruzioni presenti nella guida. Le stesse istruzioni che nelle precedenti due distribuzioni di Debian non avevano dato problemi.

La libreria zlib è largamente utilizzata dal sistema operativo e se la versione da te installata manualmente (compilandola da un sito di terze parti) è per qualche motivo incompatibile con quella con cui è stato installato il sistema operativo può determinare il malfunzionamento di tutti i programmi che la utilizzano. In particolare, la versione che hai installato manualmente (1.2.8 ) è diversa da quella installata in Debian Buster (1.2.11).

Prova a reinstallare la libreria fornita da Debian in tal modo sostituendo quella che hai installato manualmente: in tal caso, per cortesia, se possibile fornisci un log (registrazione) completa dei comandi impartiti e dei relativi output.

Seguendo le "istruzioni presenti nella guida" hai installato altre librerie / programmi secondo analoghe modalità ?

EDIT:
per avere un elenco dei pacchetti di programmi installati che utilizzano questa libreria, ad esempio, in /usr/bin puoi usare il seguente script:
Codice: Seleziona tutto
(for f in /usr/bin/* ; do ldd $f | grep libz.so.1; printf "%s %d\n" $f $?; done) | grep " 0"

per contare più rapidamente, puoi utilizzare il comando:
Codice: Seleziona tutto
ldd /usr/bin/* | grep libz.so.1 | wc -l

Nel caso della mia installazione di Debian Buster, se non erro, risultano complessivamente 1143 eseguibili, ad esempio, in /usr/bin/ che sono collegati a questa libreria.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8806
Iscritto il: 27/12/2007, 16:59

Re: problema con zlib e gdm3

Messaggioda kamui » 02/08/2019, 10:58

Grazie. Faccio una prova, ma sono propenso alla reinstallazione di tutto. Comunque controllo se il programma gira comunque anche utilizzando la versione 1.2.11 invece che della 1.2.8.
kamui
Newbie
Newbie
 
Messaggi: 13
Iscritto il: 30/07/2019, 21:33

Re: problema con zlib e gdm3

Messaggioda kamui » 02/08/2019, 13:55

In effetti risultano 1146 programmi collegati. Un bel casino. Salvo i dati e reinstallo.
kamui
Newbie
Newbie
 
Messaggi: 13
Iscritto il: 30/07/2019, 21:33

Re: problema con zlib e gdm3

Messaggioda kamui » 04/08/2019, 18:09

Ho reinstallato tutto. Però all'avvio continua a comparire la scritta " resuming from hibernation" ? a quanto ho capito è legato al fatto che ho un dual boot. Ora non so se sia un problema ed eventualmente come eliminarlo.
kamui
Newbie
Newbie
 
Messaggi: 13
Iscritto il: 30/07/2019, 21:33

Re: problema con zlib e gdm3

Messaggioda Aki » 04/08/2019, 19:50

kamui ha scritto:Ho reinstallato tutto. Però all'avvio continua a comparire la scritta " resuming from hibernation" ? a quanto ho capito è legato al fatto che ho un dual boot. Ora non so se sia un problema ed eventualmente come eliminarlo.

Non credo sia legato al dual boot. Puoi fornire almeno una fotografia di cosa appare a schermo ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8806
Iscritto il: 27/12/2007, 16:59

Re: problema con zlib e gdm3

Messaggioda kamui » 06/08/2019, 15:42

questo appare all'avvio.
In cima: Resuming from hibernation
Allegati
Screenshot_2019-08-04-23-08-14-1-165.png
Screenshot_2019-08-04-23-08-14-1-165.png (219.01 KiB) Osservato 1262 volte
kamui
Newbie
Newbie
 
Messaggi: 13
Iscritto il: 30/07/2019, 21:33

Re: problema con zlib e gdm3

Messaggioda Aki » 07/08/2019, 10:39

Puoi avviare il sistema operativo cancellando in grub (prima dell'avvio) l'opzione "quiet" e fornire la foto (di tutto lo schermo) di quanto il computer interrompe l'avvio ?

Edit: vedi https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=916696
Per ulteriori dettagli la patch è https://salsa.debian.org/kernel-team/in ... 2796b470c8
Aki
Global Moderator
Global Moderator
 
Messaggi: 8806
Iscritto il: 27/12/2007, 16:59

Re: problema con zlib e gdm3

Messaggioda kamui » 07/08/2019, 15:53

grazie Aki. Tolto quiet dal grub e tutto è partito normalmente.
kamui
Newbie
Newbie
 
Messaggi: 13
Iscritto il: 30/07/2019, 21:33

Re: problema con zlib e gdm3

Messaggioda Aki » 08/08/2019, 12:32

kamui ha scritto:grazie Aki. Tolto quiet dal grub e tutto è partito normalmente.

Felice di esserti stato d'aiuto. Strano che la semplice rimozione dell'opzione "quiet" sulla riga del kernel abbia dato risultati favorevoli. In ogni caso, se hai risolto, ricordati di contrassegnare la discussione come risolta anteponendo il tag [RISOLTO] al titolo del primo messaggio delle disscusione.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8806
Iscritto il: 27/12/2007, 16:59

Re: problema con zlib e gdm3

Messaggioda kamui » 09/08/2019, 10:23

Aki ha scritto:Puoi avviare il sistema operativo cancellando in grub (prima dell'avvio) l'opzione "quiet" e fornire la foto (di tutto lo schermo) di quanto il computer interrompe l'avvio ?
Allegati
Screenshot_01.png
Screenshot_01.png (159.27 KiB) Osservato 948 volte
kamui
Newbie
Newbie
 
Messaggi: 13
Iscritto il: 30/07/2019, 21:33

Re: problema con zlib e gdm3

Messaggioda kamui » 09/08/2019, 10:24

secondo screenshot
Allegati
Screenshot_02.png
Screenshot_02.png (220.06 KiB) Osservato 947 volte
kamui
Newbie
Newbie
 
Messaggi: 13
Iscritto il: 30/07/2019, 21:33

Prossimo

Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron