Pagina 1 di 1

Problema con pacchetto systemd su RaspberryPI3 con OSMC

MessaggioInviato: 09/05/2017, 10:49
da etilico
Ciao a tutti, stamane ho lanciato il mio consueto:

Codice: Seleziona tutto
apt-get update && apt-get dist-upgrade


Per aggiornare la mia versione di testing di OSMC, il risultato è questo:

Codice: Seleziona tutto
Preconfiguring packages ...
Selecting previously unselected package systemd.
(Reading database ... 20179 files and directories currently installed.)
Preparing to unpack .../systemd_215-17+deb8u7_armhf.deb ...
dpkg: error processing archive /var/cache/apt/archives/systemd_215-17+deb8u7_armhf.deb (--unpack):
 triggers ci file contains unknown directive `i~terest-noawait'



Qualcuno ha idea di come risolvere?

Re: Problema con pacchetto systemd su RaspberryPI3 con OSMC

MessaggioInviato: 09/05/2017, 14:46
da s3v
Ciao e benvenuto.

Supponendo che "i~terest-noawait" sia un tuo errore di battitura (dovrebbe essere "interest-noawait"), da qui si legge che:
The "-noawait" variants are only supported since dpkg 1.16.1, and will lead to errors if used with an older dpkg. It is thus recommended to add a "Pre-Depends: dpkg (>= 1.16.1)" to any package that wish to use those directives.

Quindi sul tuo sistema risulta installata una versione di "dpkg" precedente alla 1.16.1. Puoi accertartene con:
Codice: Seleziona tutto
$ dpkg --version

Re: Problema con pacchetto systemd su RaspberryPI3 con OSMC

MessaggioInviato: 09/05/2017, 14:49
da etilico
Ciao, grazie!

Non è un errore di battitura, secondo me è quello il problema perché la mia versione di dpkg è:

Codice: Seleziona tutto
Debian `dpkg' package management program version 1.17.27 (armhf).
This is free software; see the GNU General Public License version 2 or
later for copying conditions. There is NO warranty.


Che si sia corrotta la SD??

Re: Problema con pacchetto systemd su RaspberryPI3 con OSMC

MessaggioInviato: 09/05/2017, 15:03
da s3v
Puoi confrontare il checksum che calcoli per il pacchetto "/var/cache/apt/archives/systemd_215-17+deb8u7_armhf.deb" con quelli che trovi alla fine di questa pagina?
Per il calcolo del checksum puoi usare i comandi "sha1", "sha256 o "md5" (meglio un triplice confronto).

Re: Problema con pacchetto systemd su RaspberryPI3 con OSMC

MessaggioInviato: 09/05/2017, 15:17
da s3v
s3v ha scritto:...
Per il calcolo del checksum puoi usare i comandi "sha1", "sha256 o "md5" (meglio un triplice confronto).

Errore mio, i comandi sono "sha1sum", "sha256sum" e "md5sum".
Scusa.

Re: Problema con pacchetto systemd su RaspberryPI3 con OSMC

MessaggioInviato: 09/05/2017, 15:18
da etilico
Corrispondono tutti e 3...

Re: Problema con pacchetto systemd su RaspberryPI3 con OSMC

MessaggioInviato: 09/05/2017, 15:53
da s3v
Parecchio strano.
Stasera controllo il pacchetto .deb per verificare che non sia un errore di battitura dei manutentori (anche se mi sembra impossibile e i commit effettuati dalla precedente versione sembrano confermarlo).
Intanto di consiglio un backup dei dati importanti e un controllo con "debsums" (inizierei dal pacchetto "dpkg").
Altra prova è un nuovo tentativo di aggiornamento dopo la pulizia della cache:
Codice: Seleziona tutto
# apt-get clean

Re: Problema con pacchetto systemd su RaspberryPI3 con OSMC

MessaggioInviato: 09/05/2017, 16:01
da etilico
Ti ringrazio ma non impazzire, ho pochissime configurazioni che faccio prima a backuppare e reinstallare, se era una cosa veloce bene altrimenti reinstallo ( e magari per sicurezza cambio SD ).
Grazie mille!!!

Re: Problema con pacchetto systemd su RaspberryPI3 con OSMC

MessaggioInviato: 09/05/2017, 20:26
da s3v
Controllato il .deb e non c'è alcun errore :-\