Pagina 1 di 1

Dipendenze mancanti: pyqt4? [hplip-3.20]

MessaggioInviato: 08/06/2020, 22:54
da Kowa92
Ciao a tutti,

ho qualche problema con l'installazione di hplip-3.20.5.
Praticamente, il programma di installazione non riconosce le seguenti dipendenze (sia se scelgo di evitare l'installazione della GUI con l'uso di qt4 in modalità custom che in modalità predefinita automatica):

- pyqt4-dbus
- pyqt4

Come sistema operativo uso Debian. Ho appena installato i seguenti pacchetti qt4 richiesti (che dovrebbero essere corretti):

Codice: Seleziona tutto
python-qt4 is already the newest version (4.12.1+dfsg-2+b1).
python-qt4-dbus is already the newest version (4.12.1+dfsg-2+b1).


E questi pacchetti qt5 richiesti (che dovrebbero essere corretti):

Codice: Seleziona tutto
python-pyqt5 is already the newest version (5.11.3+dfsg-1+b3).
gtk2-engines-pixbuf is already the newest version (2.24.32-3+rpt1).
python-dbus.mainloop.pyqt5 is already the newest version (5.11.3+dfsg-1+b3).


Ma il problema persiste.

-> Dove sbaglio?
-> Perché se scelgo di evitare l'installazione della GUI di qt4 in modalità custom, hp-lip mi continua a chiedere le dipendenze dei pacchetti qt4?

******************************************************************************

Metto di seguito il log dell'instllazione in modalità predefinita automatica:

<vedi
log1.txt
(9.17 KiB) Scaricato 54 volte
allegato al post>

******************************************************************************

E qui metto i log dell'installazione della modalità custom (evitando di installare il qt4):

<vedi
log2.txt
(10.01 KiB) Scaricato 48 volte
allegato al post>

******************************************************************************

Secondo me c'è qualche bug nell'installer perché alla fine chiede sempre le dipendenze di qt4 (quando in teria dovrebbe chiedermi solo quelle del qt5) ..

Grazie a tutti.

Saluti

Re: Dipendenze mancanti: pyqt4? [hplip-3.20]

MessaggioInviato: 09/06/2020, 11:46
da mark
innanzi tutto dovresti usare il pacchetto debian piuttosto che un pacchetto .run
poi dal primo log che hai mandato
Codice: Seleziona tutto
error: debian-10.4 version is not supported, so all dependencies may not be installed. However trying to install using debian-10.3 version packages.

la versione per debian 10 dovrebbe essere
Codice: Seleziona tutto
hplip (3.18.12+dfsg0-2)

https://packages.debian.org/buster/hplip

Re: Dipendenze mancanti: pyqt4? [hplip-3.20]

MessaggioInviato: 09/06/2020, 20:57
da Kowa92
mark ha scritto:innanzi tutto dovresti usare il pacchetto debian piuttosto che un pacchetto .run
poi dal primo log che hai mandato
Codice: Seleziona tutto
error: debian-10.4 version is not supported, so all dependencies may not be installed. However trying to install using debian-10.3 version packages.

la versione per debian 10 dovrebbe essere
Codice: Seleziona tutto
hplip (3.18.12+dfsg0-2)

https://packages.debian.org/buster/hplip


La mia stampante è supportata da una versione di hplip >= 3.19.12. Quello che è attualmente 'stabile' di Debian è inutile per me. Quello di Debian 'unstable' (sid) (che l'ultima versione di hplip) sarebbe utile ma contamina la mia versione stabile installata con oltre 350 pacchetti instabili. Voglio mantenere solo quelli stabili.. O al massimo solo quelli strettamente necessari (ovvero hplip e le sue dipendenze).

Re: Dipendenze mancanti: pyqt4? [hplip-3.20]

MessaggioInviato: 09/06/2020, 23:30
da mark
probabilmente devi aspettare un aggiornamento del produttore o un backport di debian