Installare driver per ubuntu su debian

Discussioni relative alle distribuzioni derivate da Debian: Ubuntu, Mint, Kanotix, Knoppix, Clonezilla, etc.

Installare driver per ubuntu su debian

Messaggioda ironshadow » 02/09/2017, 13:40

Ho installato deepin e ho una scheda grafica sapphire RX 550.
Posso usare questi driver
http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Driver-for-Linux-Release-Notes.aspx
per ubuntu sulla mia debian?
Visitate il mio sito:
[url][/url]
W il software libero
Avatar utente
ironshadow
Newbie
Newbie
 
Messaggi: 49
Iscritto il: 16/06/2011, 11:17

Re: Installare driver per ubuntu su debian

Messaggioda _Alex_ » 03/09/2017, 11:00

Risposta facile e veloce: no

Risposta completa:
anzitutto Debian ed Ubuntu non sono compatibili in termini di file binari, quindi non e' possibile prendere un .deb dai repository di una distro ed installarli nell'altra.
Poi c'e' da considerare altre due cose:
il grosso del codice dei driver open e' derivato da quelli per Win ma, cosa molto piu' importante, Amd, dopo molta insistenza della comunita' opensource, ha deciso di rilasciare i codici in forma open (tranne una piccola parte di base, che fa la differenza tra il driver standard, o free, e quello pro), bisogna solo attendere che la propria scheda sia supportata.
Avevo questo problema anche con XUbuntu (ho una Sapphire Toxic Ati Radeon R9 270x).

Quello che dobbiamo fare e' abilitare i software proprietari (puoi farlo sia da Syanptic che editando il file /etc/apt/sources.list), installare il driver open ed attendere che Ati supporti ufficialmente il nostro chip.
Se e quando lo fara' decideremo se passare a quello ufficiale o restare con il nostro.

Un'altra cosa che possiamo fare e' pubblicizzare Ati, visto che nVidia ha fatto orecchie da mercante....
_Alex_
Newbie
Newbie
 
Messaggi: 18
Iscritto il: 02/09/2017, 8:32
Località: Genova

Re: Installare driver per ubuntu su debian

Messaggioda Spoon » 04/09/2017, 13:11

Facendo una ricerca veloce su Wikipedia la tua scheda dovrebbe essere della famiglia Polaris, serie Volcanic Islands. Stando alla documentazione ufficiale di Xorg pressoche' tutte le funzioni della scheda sono supportate dal driver open amdgpu. Riscontri problemi con questo driver?
Ultima modifica di Spoon il 11/09/2017, 18:31, modificato 1 volta in totale.
Spoon
wiki member
wiki member
 
Messaggi: 288
Iscritto il: 23/11/2013, 14:37

Re: Installare driver per ubuntu su debian

Messaggioda _Alex_ » 04/09/2017, 17:52

Nessuno, va che è un babbà....
_Alex_
Newbie
Newbie
 
Messaggi: 18
Iscritto il: 02/09/2017, 8:32
Località: Genova

Re: Installare driver per ubuntu su debian

Messaggioda Spoon » 04/09/2017, 17:58

In realtà mi riferivo ad ironshadow ma tanto meglio! ;D
Le due schede in realtà differiscono leggermente, la RX 550 è una Volcanic Islands mentre la R9 270X è una Southern Islands, un po' meno recente. E sì, anche io penso che mischiare varie denominazioni diverse per le schede video da parte del produttore faccia solo una gran confusione.
Spoon
wiki member
wiki member
 
Messaggi: 288
Iscritto il: 23/11/2013, 14:37

Re: Installare driver per ubuntu su debian

Messaggioda ironshadow » 09/09/2017, 9:42

_Alex_ ha scritto:Risposta facile e veloce: no
Avevo questo problema anche con XUbuntu (ho una Sapphire Toxic Ati Radeon R9 270x).


Con ubuntu 16.04 la mia scheda non da problemi, l'audio HDMI funziona e il video è buono. Basta installare i driver amdgpu-pro.

I driver open che installo su debian testing per quanto riguarda il video non ci sono molti problemi ma l'audio HDMI non vuole funzionare.
Codice: Seleziona tutto
cisco@cisco-PC:~$ lspci | grep -E 'VGA|Display'
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Polaris12 (rev c7)


Codice: Seleziona tutto
cisco@cisco-PC:~$ glxinfo | grep render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.9, 256 bits)
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil,
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_fog_distance,
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,


Codice: Seleziona tutto
cisco@cisco-PC:~$ glxinfo | grep "OpenGL version"
OpenGL version string: 3.0 Mesa 13.0.6
Visitate il mio sito:
[url][/url]
W il software libero
Avatar utente
ironshadow
Newbie
Newbie
 
Messaggi: 49
Iscritto il: 16/06/2011, 11:17

Re: Installare driver per ubuntu su debian

Messaggioda s3v » 11/09/2017, 11:33

Il driver che stai cercando di installare non è open.
Farei un tentativo con:
https://packages.debian.org/sid/firmware-amd-graphics

Se sei fortunato, la funzionalità che cerchi è in corso di implementazione con i driver open ma nel frattempo viene fornita tramite firmware chiuso.

Ti consiglio anche di analizzare il log creato tramite questo script:
http://guide.debianizzati.org/index.php ... i_al_forum
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5424
Iscritto il: 31/12/2008, 11:54

Re: Installare driver per ubuntu su debian

Messaggioda Spoon » 11/09/2017, 18:53

Senza un log della tua installazione a questo punto è difficile dire qualcosa più di congetture, per esempio sarebbe utile sapere che versione di Debian hai, quale driver ti sta dando problemi e altre cose. Ci provo comunque.

Come già scritto, il driver amdgpu supporta quasi tutte le funzionalità della tua scheda, e in particolare puoi vedere dalla pagina che ho linkato in precedenza che l'uscita audio HDMI è segnata come Done (DAL). Il driver presente in Debian Buster e Sid supporta le schede fino alla famiglia Stoney, cioè quella precedente alla famiglia Polaris a cui la tua scheda appartiene, per cui mi sembrerebbe normale trovare ancora qualche problemino, ma visto che dici che tutto il resto funziona (e non sapendo esattamente che versione di Debian e che driver ti diano il problema) ho indagato oltre. Ho trovato questa segnalazione di bug che sembra pertinente
https://bugs.freedesktop.org/show_bug.cgi?id=97258
In particolare il secondo messaggio dice esplicitamente
Audio is only supported with the new DAL display code which is not upstream yet. You can use this branch in the interim:
https://cgit.freedesktop.org/~agd5f/lin ... taging-4.6

Questo sembra anche coerente con la segnalazione DAL nella feature matrix di Xorg. Non so dire se questo sia o meno il tuo problema, in tal caso puoi tentare come spiegato nella discussione linkata oppure aspettare che le modifiche arrivino nei pacchetti Debian.
Spoon
wiki member
wiki member
 
Messaggi: 288
Iscritto il: 23/11/2013, 14:37


Torna a Derivate da Debian

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti