MBR e nuova installazione [RISOLTO]

Discussioni relative alle distribuzioni derivate da Debian: Ubuntu, Mint, Kanotix, Knoppix, Clonezilla, etc.

MBR e nuova installazione [RISOLTO]

Messaggioda starkdeb » 02/02/2020, 19:30

Buonasera, ho la necessità di installare una nuova Ubuntu sul PC di mia mamma, su cui è presente anche Windows 7 oltre a Ubuntu 19.10 (64 bit). Procedendo con l'installazione arrivo al punto in cui il programma mi chiede se voglio mantenere la vecchia distro oppure no, ma non fa alcun riferimento a Windows. Perciò ritengo, nella mia ignoranza, di dover riesumare il vecchio MBR con l'utilizzo di ms-sys e successivamente procedere a installare la nuova Ubuntu sovrascrivendo quella vecchia.
Desidero una conferma da parte vostra sul fatto che tale computer sia ancora provvisto del vecchio Bios e non di Uefi, e che quindi posso procedere con il ripristino del MBR utilizzando ms-sys da una distro live.Allego allo scopo alcune immagini che secondo me sono inequivocabili riguardo alla presenza del Bios.
Se l'idea secondo cui intendo procedere fosse sbagliata, accetto i consigli che vorrete eventualmente darmi, anche attraverso la segnalazione di link a documentazione adatta al caso.
Grazie dell'attenzione.

https://ibb.co/KzxstPN

https://ibb.co/LzjJ5R9

https://ibb.co/0mNbbwT
Ultima modifica di starkdeb il 25/02/2020, 13:55, modificato 2 volte in totale.
starkdeb
Full Member
Full Member
 
Messaggi: 187
Iscritto il: 01/08/2010, 21:14

Re: MBR e nuova installazione

Messaggioda starkdeb » 02/02/2020, 21:12

Grazie per aver spostato la discussione nella sezione corretta, mi scuso.
Tornando sull'argomento, nei miei appunti di qualche anno fa ho riportato questa procedura (ammesso che mi confermiate che i presupposti per utilizzare ms-sys siano corretti):

sudo fdisk -l > determina la partizione in cui si trova il MBR
sudo ms-sys -m /dev/sdx > è il comando per ripristinare il tutto (inserendo la partizione corretta al posto di sdx), anche se in una guida di Ubuntu ho appena trovato come opzione -w invece di -m...
starkdeb
Full Member
Full Member
 
Messaggi: 187
Iscritto il: 01/08/2010, 21:14

Re: MBR e nuova installazione

Messaggioda starkdeb » 10/02/2020, 15:49

Buongiorno, pur cercando in rete non essendo riuscito a raccapezzarmi alla fine ho tentato il ripristino di Win 7 con ms-sys ed è riuscito. Purtroppo installando la nuova Ubuntu che mi serviva, il sistema non ha riconosciuto Windows per cui ho proceduto all'installazione del nuovo non facendogli considerare le partizioni NTFS. Attualmente quindi Ubuntu è funzionante e Windows è "confinato e silente". Pazienza.
starkdeb
Full Member
Full Member
 
Messaggi: 187
Iscritto il: 01/08/2010, 21:14

Re: MBR e nuova installazione [NON RISOLTO]

Messaggioda mark » 11/02/2020, 11:15

non so come ti trovi a modificare manualmente la configurazione di grub, dovrebbe bastare questo codice
Codice: Seleziona tutto
menuentry 'Windows 7' {
set root='(hd0,1)'
chainloader +1
}

se vuoi qui trovi una spiega più estesa How do I add Windows 7 to GRUB 2?
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 735
Iscritto il: 10/01/2007, 16:53

Re: MBR e nuova installazione [NON RISOLTO]

Messaggioda starkdeb » 18/02/2020, 12:17

Ti ringrazio, farò un tentativo :D
starkdeb
Full Member
Full Member
 
Messaggi: 187
Iscritto il: 01/08/2010, 21:14

Re: MBR e nuova installazione [NON RISOLTO]

Messaggioda starkdeb » 18/02/2020, 14:28

dunque, ho inserito quanto suggeritomi ma al riavvio mi compare un mdi grub (presumo)che recita:

errore: impossibile trovare il comando "hwmatch"
errore: invalid EFI file path

Premere un tasto per continuare
Caricamento delle voci predefinite e di ripiego non riuscito
premere un tasto per continuare


Dopodichè premendo un tasto compare il menu di scelta in cui la voce Windows risulta invalida e la voce Ubuntu consente l'avvio del sistema.
Mediante fdisk -l vedo che la partizione da 105 MB per l'avvio di Windows è /dev/sda1
Ricapitolando: ho ripristinato MBR con ms-sys (e Windows si avviava), successivamente ho installato Ubuntu 18.04 LTS sulla precedente Ubuntu 17.10 (e giustamente Windows non si avvia più). Può essere che ora ripristinando nuovamente MBR "riabilito" Windows e successivamente effettuo il ripristino di Grub? L'altra volta c'era di mezzo una nuova installazione, stavolta solo un ripristino Grub con un MBR resuscitato.
starkdeb
Full Member
Full Member
 
Messaggi: 187
Iscritto il: 01/08/2010, 21:14

Re: MBR e nuova installazione [NON RISOLTO]

Messaggioda starkdeb » 18/02/2020, 17:30

Nella seguente guida si riporta:

https://help.ubuntu.com/community/Grub2/CustomMenus

menuentry "Windows 7" {

insmod ntfs

set root='(hd0,1)'

search --no-floppy --fs-uuid --set a3f1ea41fc67a3f1

chainloader +1

}


la cosa mi disorienta... :o


edit: e dà lo stesso risultato di prima...
starkdeb
Full Member
Full Member
 
Messaggi: 187
Iscritto il: 01/08/2010, 21:14

Re: MBR e nuova installazione [NON RISOLTO]

Messaggioda mark » 19/02/2020, 10:05

a quanto pare c'è qualche inghippo, come da guida
Guida a GRUB 2
potresti postare il risultato di questo comando?
Codice: Seleziona tutto
grub-mkconfig -o ~/nome_file_a_scelta

non andrà a riscrivere il tuo file di configurazione ma ti troverai il file nella tua home
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 735
Iscritto il: 10/01/2007, 16:53

Re: MBR e nuova installazione [NON RISOLTO]

Messaggioda starkdeb » 19/02/2020, 15:12

Lo ho compresso e allegato
Allegati
prova.tar.xz
(1.89 KiB) Scaricato 15 volte
starkdeb
Full Member
Full Member
 
Messaggi: 187
Iscritto il: 01/08/2010, 21:14

Re: MBR e nuova installazione [NON RISOLTO]

Messaggioda mark » 19/02/2020, 17:38

in effetti non vede nulla ;D
Codice: Seleziona tutto
### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

dubbio: il pacchetto "os-prober" è installato?
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 735
Iscritto il: 10/01/2007, 16:53

Re: MBR e nuova installazione [NON RISOLTO]

Messaggioda starkdeb » 19/02/2020, 21:15

Affermativo
starkdeb
Full Member
Full Member
 
Messaggi: 187
Iscritto il: 01/08/2010, 21:14


Re: MBR e nuova installazione [NON RISOLTO]

Messaggioda starkdeb » 20/02/2020, 15:41

Ciao, ho avviato super grub2 disk da live CD, riesco a vedere Win Vista ma se provo a farglielo avviare mi restituisce:

Sorry, but we are booted via UEFI and can not load this OS.
Please try booting SG2D via Bios Compatibility Mode.
Press escape to return to the menu
starkdeb
Full Member
Full Member
 
Messaggi: 187
Iscritto il: 01/08/2010, 21:14

Re: MBR e nuova installazione [NON RISOLTO]

Messaggioda caturen » 22/02/2020, 7:23

in quello che hai postato è scritto chiaramente quello che devi fare
https://docs.microsoft.com/en-us/window ... -bios-mode
caturen
Sr. Member
Sr. Member
 
Messaggi: 316
Iscritto il: 02/04/2013, 20:00

Re: MBR e nuova installazione [RISOLTO]

Messaggioda starkdeb » 25/02/2020, 13:54

Come indicato nell'ultimo link che hai postato, premendo F12 all'accensione si avvia automaticamente Windows. Non appare alcun menù di scelta dei sistemi operativi installati, si avvia e basta. Però non mi è ben chiaro il meccanismo, cosa succede in pratica? Intanto metto "risolto" in cima al topic, grazie degli aiuti.
starkdeb
Full Member
Full Member
 
Messaggi: 187
Iscritto il: 01/08/2010, 21:14


Torna a Derivate da Debian

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti