Pagina 1 di 1

Problema con Pelican - creazione blog

MessaggioInviato: 11/03/2018, 18:13
da l3o
Ciao a tutti,
sto facendo delle prove per la creazione di un blog personale.
Vorrei utilizzare Pelican come strumento per la generazione delle pagine. Ho fatto delle prove in locale e tutto sembra funzionare.
Scrivo i contenuti e poi do i seguenti comandi:
Codice: Seleziona tutto
$ pelican content -o output -s pelicanconf.py

Codice: Seleziona tutto
$ python -m pelican.server


Accedo sul mio browser a localhost:8000 e vedo il blog nel modo corretto:)

Se ora provo a fare l'upload della mia pagina su un webserver vedo i contenuti ma "non mi prende la formattazione".

Qui potete vedere il risultato (contenuti ok, ma senza formattazione).
http://www.autistici.org/leo

Sul webserver ho caricato il contenuto della cartella output.

Mi sapete dire dove sbaglio?

Grazie mille:)
ciao ciao leo

Re: Problema con Pelican - creazione blog

MessaggioInviato: 11/03/2018, 19:09
da s3v
Nel sorgente pagina c'è questo:
Codice: Seleziona tutto
<link rel="stylesheet" href="/theme/css/bootstrap.min.css">
<link rel="stylesheet" href="/theme/css/font-awesome.min.css">
<link rel="stylesheet" href="/theme/css/pygments/default.min.css">
<link rel="stylesheet" href="/theme/css/style.css">

Forse quei css non esistono sul server o non sono in quel percorso?

Prova ad utilizzare gli URL online, ad esempio bootstrap da CDN:
Codice: Seleziona tutto
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css" integrity="sha384-BVYiiSIFeK1dGmJRAkycuHAHRg32OmUcww7on3RYdg4Va+PmSTsz/K68vbdEjh4u" crossorigin="anonymous">

Re: Problema con Pelican - creazione blog

MessaggioInviato: 14/03/2018, 9:47
da cyberl3o
Grazie mille s3v per la risposta.
Ho provato e purtroppo non funge.
Non riesco a capire perché. Il path ai css è corretto. Ho provato a caricare su github.io e funziona perfettamente. Solo su quel webserver non va. Però lì ho già caricato altre cose ed è sempre andato tutto a buon fine.