Installare Debian su Lenovo G50-45

Come installare Debian sui Portatili... campo in cui spesso si trovano scogli che sembrano insormontabili

Installare Debian su Lenovo G50-45

Messaggioda Atreiu85 » 08/11/2016, 17:04

Buon pomeriggio a tutte e a tutti.

Ho appena installato Debian 8.6 sul mio Lenovo G50-45. Provengo da Windows 10 che ho dovuto disinstallare perché troppo lento - sebbene il SO era preinstallato sul PC. Ho riscontrato due problemi, purtroppo.

1. Il segnale wireless è instabile. Dopo aver configurato il Wi-Fi, il computer si disconnette da sé senza che io possa far qualcosa - e sono costretto a riavviare il SO. La mia scheda di rete è una Realtek RTL8723BE. A quanto pare è un problema del kernel Linux con quel driver specifico.

2. All'avvio del PC il sistema mi informa che ci sono problemi con i driver grafici e che il SO è in modalità "emulatore". La mia scheda grafica è una Amd Ati radeon r2.

Sarei davvero riconoscente se qualcuno sappia aiutarmi: allo stato dei fatti il computer è inutilizzabile. Vi prego tuttavia di essere chiari e semplici: per me è tutto nuovo.

Grazie mille.
Fabio
Atreiu85
Newbie
Newbie
 
Messaggi: 1
Iscritto il: 08/11/2016, 16:47

Re: Installare Debian su Lenovo G50-45

Messaggioda Selky » 08/11/2016, 17:27

Ciao e benvenuto :)

Ti consiglio come prima cosa di utilizzare lo script come indicato in questa guida Creazione automatica di un file di log per inviare quesiti al forum
Per allegarlo dovrai inviarlo come file compresso.
Selky
wiki member
wiki member
 
Messaggi: 1401
Iscritto il: 30/12/2011, 1:00

Re: Installare Debian su Lenovo G50-45

Messaggioda lablinux » 09/11/2016, 14:05

Ciao, hai aggiunto in repositori contrib e non-free?
Li dovresti trovare i driver per la scheda di rete. Per la scheda grafica non saprei
Ti consigli di installare anche synaptic.
Linux counter home page #501787
Linux machine #5389505
Avatar utente
lablinux
Hero Member
Hero Member
 
Messaggi: 598
Iscritto il: 03/11/2009, 11:32

Re: Installare Debian su Lenovo G50-45

Messaggioda dring » 10/11/2016, 11:48

Pare che il problema sia nel risparmio energetico della scheda che la disconnette, anche con win 8.1, ma non con win 10.
http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_web/intermittent-wifi-driver-for-realtek-rtl8723be/1ca4c140-0969-4090-b827-88d647b6cc26?page=3
pare che la soluzione su Linux sia questa:
http://askubuntu.com/questions/590414/wifi-problems-with-rtl8723be-in-ubuntu-14-04
"I was having these problem with rtl8723be on linux mint 17, and mint17.1. The same procedure should work on ubuntu 14.04 and derivates.
I had to install new module for realtek wifi cards where they solved the constant disconnects:
install required packages
Codice: Seleziona tutto
sudo apt-get install build-essential git

git clone new realtek wifi modules
Codice: Seleziona tutto
git clone https://github.com/lwfinger/rtlwifi_new/

enter the directory
Codice: Seleziona tutto
cd rtlwifi_new

build it
Codice: Seleziona tutto
make

install
Codice: Seleziona tutto
sudo make install

Now you can reboot or unload/load modules
unload modules
Codice: Seleziona tutto
sudo modprobe -r rtl8723be

load new module
Codice: Seleziona tutto
sudo modprobe rtl8723be

if it still doesn't work, try the solution from this post
http://askubuntu.com/questions/632719/my-wifi-drops-the-connection-after-a-few-minutes-realtek8723be
Codice: Seleziona tutto
echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

Note: After each kernel update, you need to rebuild the modules.
That is,
After every kernel update:
Codice: Seleziona tutto
cd rtlwifi_new

Clean previous builds
Codice: Seleziona tutto
make clean

Update git repository
Codice: Seleziona tutto
git pull

Compile
Codice: Seleziona tutto
make clean && make

Install
Codice: Seleziona tutto
sudo make install

reboot or unload/load modules.

Poi ho trovato quest'altra soluzione che pare più semplice:
http://www.dedoimedo.com/computers/ubuntu-trusty-realtek.html
In sostanza, è necessario fornire le opzioni non predefinite per il modulo del kernel che governa la scheda wireless
Apri il file
Codice: Seleziona tutto
/etc/modprobe.d/rtl8723be.conf

ad es. con gedit con i permessi di root, e aggiungi il seguente testo:
Codice: Seleziona tutto
options rtl8723be fwlps=N ips=N

Immagine
ora perché le modifiche abbiano effetto riavvia.
Se non funziona prova la seconda soluzione più complicata
http://www.dedoimedo.com/computers/ubuntu-trusty-realtek.html
feed your head
linuxuser # 2011188
Avatar utente
dring
Hero Member
Hero Member
 
Messaggi: 982
Iscritto il: 27/12/2010, 9:54
Località: Brescia


Torna a Laptop

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite