[RISOLTO] Dipendenze pacchetti (Skype)

Problemi con l'installazione di pacchetti

[RISOLTO] Dipendenze pacchetti (Skype)

Messaggioda g0Re » 22/07/2014, 20:42

Salve brava gente,
immagino che vi siate annoiati solo a leggere il titolo pensando fosse la solita richiesta da nabbo, ed infatti è proprio così.
Premetto però, ho già usate la barra di ricerca e ho spulciato diversi topic vecchi che non mi sono, purtroppo, stati d'aiuto.
Ho inoltre cercato in lungo e in largo per il web, tipo: https://wiki.debian.org/skype ed anche su pagine meno specifiche.
Proprio oggi ho installato Debian, arrivando da Ubuntu, e non sono ancora riuscito ad installare nulla ;D e speravo che facendo luce in questo caso particolare, sarei riuscito poi a non avere problemi con altri pacchetti. Allora:

Ho inizialmente abilitato il multiarch:

Codice: Seleziona tutto
# dpkg --add-architecture i386
         # apt-get update


Poi ho installato la versione di skype precedentemente scaricata:

Codice: Seleziona tutto
 # dpkg -i <indirizzo pacchetto skype>


Ricevendo il seguento output:

Codice: Seleziona tutto
(Lettura del database... 105748 file e directory attualmente installati.)
Preparativi per sostituire skype v.4.3.0.37-1 (utilizzando skype-install.deb)...
Estrazione del sostituto di skype...
dpkg: problemi con le dipendenze impediscono la configurazione di skype:
 skype dipende da libc6 (>= 2.3.6-6~).
 skype dipende da libc6 (>= 2.7).
 skype dipende da libgcc1 (>= 1:4.1.1).
 skype dipende da libqt4-dbus (>= 4:4.5.3).
 skype dipende da libqt4-network (>= 4:4.8.0).
 skype dipende da libqt4-xml (>= 4:4.5.3).
 skype dipende da libqtcore4 (>= 4:4.7.0~beta1).
 skype dipende da libqtgui4 (>= 4:4.8.0).
 skype dipende da libqtwebkit4 (>= 2.1.0~2011week13).
 skype dipende da libstdc++6 (>= 4.2.1).
 skype dipende da libx11-6.
 skype dipende da libxext6.
 skype dipende da libxss1.
 skype dipende da libxv1.
 skype dipende da libssl1.0.0.
 skype dipende da libpulse0.
 skype dipende da libasound2-plugins.

dpkg: errore nell'elaborare skype (--install):
 problemi con le dipendenze - lasciato non configurato
Elaborazione dei trigger per desktop-file-utils...
Elaborazione dei trigger per hicolor-icon-theme...
Si sono verificati degli errori nell'elaborazione:
 skype


Oltre all'alto numero di dipendenze, mi stupisce anche il fatto che dando:

Codice: Seleziona tutto
# apt-get install -f


mi parte la rimozione di Skype.


Ho avuto un problema simile anche installando Transmission.
Please, aiutate questo povero nabbo :'(
Ultima modifica di g0Re il 29/07/2014, 18:38, modificato 1 volta in totale.
Avatar utente
g0Re
Newbie
Newbie
 
Messaggi: 7
Iscritto il: 22/07/2014, 20:11

Re: Dipendenze pacchetti (Skype)

Messaggioda marcomg » 23/07/2014, 10:27

Prova ad installare con gdebi :D
Windows is what you open when you want fresh air from outside.
Avatar utente
marcomg
Hero Member
Hero Member
 
Messaggi: 5605
Iscritto il: 22/08/2011, 18:54

Re: Dipendenze pacchetti (Skype)

Messaggioda g0Re » 23/07/2014, 17:16

marcomg ha scritto:Prova ad installare con gdebi :D


Purtroppo mi si verifica sempre lo stesso problema, anche provando ad installare GDebi :-\
Avatar utente
g0Re
Newbie
Newbie
 
Messaggi: 7
Iscritto il: 22/07/2014, 20:11

Re: Dipendenze pacchetti (Skype)

Messaggioda marcomg » 24/07/2014, 8:33

Prima procedi con la rimozione di skype e prova a reinstallarlo con gdebi.
Windows is what you open when you want fresh air from outside.
Avatar utente
marcomg
Hero Member
Hero Member
 
Messaggi: 5605
Iscritto il: 22/08/2011, 18:54

Re: Dipendenze pacchetti (Skype)

Messaggioda g0Re » 24/07/2014, 15:53

Immagine



:(
Avatar utente
g0Re
Newbie
Newbie
 
Messaggi: 7
Iscritto il: 22/07/2014, 20:11

Re: Dipendenze pacchetti (Skype)

Messaggioda HAL 9000 » 24/07/2014, 16:36

Che versione stai usando di Debian? Io vedo la 1:4.7.2 della libreria libgcc1 su Wheezy.
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 10 "buster" (PC): installazione, aggiornamento da versione 9.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1496
Iscritto il: 10/08/2009, 10:01

Re: Dipendenze pacchetti (Skype)

Messaggioda g0Re » 24/07/2014, 18:06

Codice: Seleziona tutto
# Linux debian 3.2.0-4-amd64 #1 SMP Debian 3.2.57-3 x86_64 GNU/Linux
Avatar utente
g0Re
Newbie
Newbie
 
Messaggi: 7
Iscritto il: 22/07/2014, 20:11

Re: Dipendenze pacchetti (Skype)

Messaggioda HAL 9000 » 25/07/2014, 11:50

Aggiorna tutto il sistema per sicurezza, poi usi gdebi da terminale, così si vedono i suoi messaggi di errore, sperando siano più verbosi di quello da interfaccia grafica:

Codice: Seleziona tutto
# apt-get update
# apt-get dist-upgrade
# gdebi posizione-pacchetto-skype.deb
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 10 "buster" (PC): installazione, aggiornamento da versione 9.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1496
Iscritto il: 10/08/2009, 10:01

Re: Dipendenze pacchetti (Skype)

Messaggioda g0Re » 29/07/2014, 18:37

Risolto (non ho ben capito ancora come).

Grazie a chi mi ha aiutato ;D
Avatar utente
g0Re
Newbie
Newbie
 
Messaggi: 7
Iscritto il: 22/07/2014, 20:11


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

cron