[COMPLETATO] Guide marcate compatibili per tutte le versioni

Discussioni relative alla Gestione del wiki Guide@Debianizzati.Org

Re: [COMPLETATO] Guide marcate compatibili per tutte le vers

Messaggioda Selky » 06/06/2015, 15:33

HAL 9000 ha scritto:I cambiamenti apportati sono stati già discussi e non hanno avuto obiezioni
da persone che negli ultimi due anni hanno cagato di striscio il wiki se non ignorato, mentre gli unici ad obiettare siamo stati io e s3v.

Nel template versioni compatibili è possibile che i "titoli" assegnati alle guide riportino una cosa del genere?:
  • versioni compatibili: "Tutte le versioni supportate di Debian " per tutte come già stato spiegato e attuato.
  • versione compatibile: indicando il codename della release che la supporta e può essere anche Jessie.
  • versione testata: da utilizzare d'ora in avanti man mano che le guide vengono verificate a dovere.
In sostanza così una guida non visualizzerà il titolo "testata" sino a quando non sarà fatto, visto che ora Jessie è l'attuale stable. Ma la medesima guida risulterà comunque compatibile per una determinata release che può essere Jessie ma non se ne assicura la procedura descritta nella guida.
Se una guida riporta anche Wheezy ci si può regolare con le date di modifica e relativi commenti presenti nella cronologia.

Per tutto il resto del template versioni compatibili, compresa l'incompatibilità esplicita e "soltanto", nulla da obiettare.

HAL 9000 ha scritto:(S3v aveva proposto un'unificazione di "Guida da adottare", "Stub" e "Guida da controllare" sotto il primo gruppo), poi se occorrerà un nuovo template (il che significherebbe che quelli attuali sono comunque provvisori), e nel frattempo come utilizzare le revisioni. :)
Questo lo trovo giusto, troppa carne al fuoco crea confusione. Basta un template per indicare che la guida è da controllare, revisionare, verificare, ecc...

Edit
mi dimentico sempre di usare le faccine e ci tengo a precisare che quando vi scrivo lo faccio in tranquillità ;)
Selky
wiki member
wiki member
 
Messaggi: 1424
Iscritto il: 30/12/2011, 1:00

Re: [COMPLETATO] Guide marcate compatibili per tutte le vers

Messaggioda HAL 9000 » 06/06/2015, 15:37

L'idea mi piace, ma non ho idea se è possibile con questa versione di MediaWiki. Posso provare nel template di prova. ;)

EDIT:

Qualcosa del genere ci va abbastanza vicino:
{{
#switch: {{#time: Y}}
| 2015 | 2016 | 2017 = Versioni testate
| = Versioni compatibili
}}


Tutte le guide modificate l'ultima volta negli anni 2015-2017 sono "Versioni testate", le altre "Versioni compatibili".

Non so se si può fare di meglio con MediaWiki: http://www.mediawiki.org/wiki/Help:Exte ... ns#.23time

EDIT2:

{{
#switch: {{#time: Y | now - 5 months}}
| 2015 | 2016 | 2017 = Versioni testate
| = Versioni compatibili
}}


Tutte le guide modificate l'ultima volta a partire da giugno (now - 5 months) 2015 fino a giugno 2018 sono "Versioni testate", le altre "Versioni compatibili".

EDIT3:

Provato a metterlo, ma non sembra funzionare. Credo che rigenerando la pagina a ogni cambiamento di template, il "now" diventi uguale per tutte le pagine che includono il template, ed è quindi inutile inserito in un template. E non ho trovato nessun modo per leggere la data di ultima modifica che mostra in basso. :-\
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01

Re: [COMPLETATO] Guide marcate compatibili per tutte le vers

Messaggioda Selky » 06/06/2015, 16:19

Infatti, l'ho provato anche in locale ma niente. Che peccato mi piaceva :-\

Ho anche provato l'esempio di quella guida:
Codice: Seleziona tutto
    {{#time: Y | January 1 }}
inserendo June ma niente.
Selky
wiki member
wiki member
 
Messaggi: 1424
Iscritto il: 30/12/2011, 1:00

Re: [COMPLETATO] Guide marcate compatibili per tutte le vers

Messaggioda HAL 9000 » 06/06/2015, 16:23

Comunque, e visto che "testate" servirebbe soprattutto per il dopo-Jessie, mentre il "compatibili" è per Wheezy e precedenti e qualche "Jessie" verificata quando era in stato di testing, direi che basta posticiparne l'adozione. Ho quindi ripristinato, almeno per la durata di Jessie, quello precedente. :)
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01

Re: [COMPLETATO] Guide marcate compatibili per tutte le vers

Messaggioda s3v » 06/06/2015, 16:27

Questa diatriba sulla semantica delle parole sta sconfinando nel campo della filosofia.
Ma una persona che naviga nel Wiki può mai leggere "Versioni compatibili" su una guida e "Versioni testate" su quella dopo? Che deve pensare?
a) E la differenza dove è?
b) La guida è testata ma non compatibile?
c) La guida è compatibile ma non testata?
d) Non ci ho capito niente.

Si metta una dicitura *univoca* e basta. Si scelga quello che di vuole:
1) Versioni testate
2) Versioni compatibili
3) Guida scritta e verificata per ...
4) Guida scritta e poi verificata per...
5) Guida scritta e testata per ...
6) Guida scritta e poi testata per...
7) Ciao mamma
8) Forza qualcosa
9) Un saluto a tutti quelli che mi conoscono
10) ...
Ma che sia una frase unica su tutte le guide. Dai su.

Poi, per evitare di discutere per settimane sulle parole, non si potrebbe usare "Jessie (stable)" e "Jessie (testing)" anziché solo "jessie" e fare lo stesso per Stretch, Buster e via dicendo?
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5674
Iscritto il: 31/12/2008, 11:54

Re: [COMPLETATO] Guide marcate compatibili per tutte le vers

Messaggioda gausss » 07/06/2015, 19:14

forse ve ne siete già accorti, volevo segnalarvi la guida su pulseadio che è veramente legacy e senza utilità per testing e sid.

su stretch l'utente della mia home non è nel gruppo pulseaudio e non esiste neppure il gruppo pulseaudio-access.
eppure funziona, malgrado mi ritrovo un paio di messaggi nei logs
Codice: Seleziona tutto
[pulseaudio] module-alsa-card.c: Card '1' doesn't exist: File o directory non esistente
 [pulseaudio] module.c: Failed to load module "module-alsa-card" (argument: "device_id="1" name="pci-0000_01_00.1" card_name="alsa_card.pci-0000_01_00.1" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes card_properties="module-udev-detect.discovered=1""): initialization failed.

e un consumo complessivo di cpu che arriva al 5% che per me è una enormità per un server sonoro.


dato che non trovo online altre informazioni su questa versione più recente di pulseaudio tornerebbe molto utile aggiornare la guida.
gausss
Full Member
Full Member
 
Messaggi: 168
Iscritto il: 15/06/2014, 14:56

Re: [COMPLETATO] Guide marcate compatibili per tutte le vers

Messaggioda Ombra » 07/06/2015, 22:54

@ gausss:
volevo segnalarvi la guida su pulseadio che è veramente legacy e senza utilità per testing e sid

in effetti a una rapida occhiata molte procedure desritte non dovrebbero servire più, almeno dalla stable in avanti.
Al momento non so se pulse sia "default" o no su Debian, ma cmq le sue librerie sono bene incastonate nel sistema (non è possibile rimuoverle) e dovrebbe funzionare "out of the box".
su stretch l'utente della mia home non è nel gruppo pulseaudio e non esiste neppure il gruppo pulseaudio-access

per quanto sono riuscito a capire, con l'arrivo di policykit, settare i gruppi non è più necessario, almeno per le applicazioni che srfuttano questa possibilità ( sono tante, e pulse è tra queste). La prova del 9 l'ho avuta quando ho rimosso policykit e mi sono trovato il pc muto di colpo..
e un consumo complessivo di cpu che arriva al 5% che per me è una enormità per un server sonoro

puoi provare con jack, io lo trovo molto leggero e ha una ottima latenza, a me assorbe l'1% scarso di cpu, però ovviamente dipende dal processore che hai, io ne ho uno del 2008.

@ tutti
http://guide.debianizzati.org/index.php/Pulseaudio:_installazione_e_configurazione
sarei daccordo nel marcarla come da adottare, l'ultima modifica è del 2012 ma è marcomg che ha aggiunto un template: oppure è da valutare se compatibile con la oldstable.
Ombra
wiki member
wiki member
 
Messaggi: 472
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: [COMPLETATO] Guide marcate compatibili per tutte le vers

Messaggioda HAL 9000 » 08/06/2015, 8:49

Marcata come "da adottare" e rimosso il template Autori. Può farlo chiunque: basta registrarsi al Wiki, modificare la pagina e scrivere in cima {{Guida da adottare}}. Ogni contributo è ben accetto. ;)
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 9 "Stretch" (amd64): installazione, aggiornamento da Debian 8.
Avatar utente
HAL 9000
wiki member
wiki member
 
Messaggi: 1483
Iscritto il: 10/08/2009, 10:01

Re: [IN CORSO] Guide marcate compatibili per tutte le versio

Messaggioda Spoon » 08/06/2015, 14:33

Premessa: sono tutte opinioni personali dette con la massima tranquillità ;D

Sono d'accordo su questo punto:
s3v ha scritto:Ma una persona che naviga nel Wiki può mai leggere "Versioni compatibili" su una guida e "Versioni testate" su quella dopo? Che deve pensare?
...
Si metta una dicitura *univoca* e basta.

e pure su quest'ultimo:
s3v ha scritto:Poi, per evitare di discutere per settimane sulle parole, non si potrebbe usare "Jessie (stable)" e "Jessie (testing)" anziché solo "jessie" e fare lo stesso per Stretch, Buster e via dicendo?


Sulle guide da adottare/controllare/altro, mi piace l'idea di non creare troppa dispersione, è vero che su diverse guide sono necessari lavori di tipo diverso ma non starei a fare una microregolazione delle categorie. Direi che due/tre siano sufficienti (da adottare/controllare, da scrivere=stub, vecchie/obsolete=old).

Cerchiamo di non complicare troppo la vita a chi scrive, revisiona, eccetera le guide e di non creare confusione per chi le legge.
Spoon
wiki member
wiki member
 
Messaggi: 343
Iscritto il: 23/11/2013, 14:37

Re: [COMPLETATO] Guide marcate compatibili per tutte le vers

Messaggioda Danielsan » 08/06/2015, 20:10

Secondo me le guide si posso distingure ASD e PSD: ante-systemd e post-systemd. Non trovate sia piu' corretto? :D
Debian Testing/Sid amd64
systemd ha reso GNU/Linux più brutto...
Avatar utente
Danielsan
Hero Member
Hero Member
 
Messaggi: 1430
Iscritto il: 10/07/2009, 19:23
Località: Roma

Re: [COMPLETATO] Guide marcate compatibili per tutte le vers

Messaggioda ferdybassi » 08/06/2015, 22:31

E' innegabile che systemd stia rappresentando un bello spartiacque, ma non mi sembra corretto. Apriresti la strada a diatribe infinite.
Io la penso come s3v: più semplice si fa, meglio è.
Per me andrebbe bene un:

- Guida testata con: etch, wheezy, jessie

Se la tua versione manca, la testi e ne provi la validità o meno.

KISS.
Immagine  Immagine
Avatar utente
ferdybassi
Administrator
Administrator
 
Messaggi: 3285
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: [COMPLETATO] Guide marcate compatibili per tutte le vers

Messaggioda Danielsan » 08/06/2015, 22:54

Scherzi a parte sono d'accordo con te.
Debian Testing/Sid amd64
systemd ha reso GNU/Linux più brutto...
Avatar utente
Danielsan
Hero Member
Hero Member
 
Messaggi: 1430
Iscritto il: 10/07/2009, 19:23
Località: Roma

Precedente

Torna a Guide@Debianizzati.Org

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti