[RISOLTO] Skype in conflitto su Debian Stretch

Problemi con l'installazione di pacchetti

[RISOLTO] Skype in conflitto su Debian Stretch

Messaggioda El Niño » 10/06/2015, 21:31

Buonasera a tutti,

Volevo chiedere se oltre a me, anche a qualcun altro è capitato che Skype non sia installabile su Debian Stretch, o meglio, sia impossibile risolvere le sue dipendenze. Dopo aver smanettato un (bel) pò con i vari programmi installati, mi sono accorto che Skype va in conflitto con VLC, Kodi e Cheese; in particolare, sono le librerie "libasound2-plugins:i386" e "libavcodec-extra-56:i386" a dare problemi. Mi sono accorto del problema dopo che ho provato ad installare skype con gdebi, e mi è uscito il messaggio "Cannot resolve dependencies : libasound2-plugins:i386". Allora ho pensato, dov'è il problema: installo da terminale --> apt-get install libasound2-plugins:i386". La risposta è stata:
Codice: Seleziona tutto
"Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libasound2-plugins:i386 : Depends: libavcodec56:i386 (>= 6:11~beta1) but it is not going to be installed or
                                    libavcodec-extra-56:i386 (>= 6:11~beta1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages"


Al che ho dato il comando apt-get install -f, seguito da un apt-get autoremove

Codice: Seleziona tutto
root@debian:/home/devid# apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libavresample2 libfftw3-single3 libpulsedsp libwebrtc-audio-processing-0 pulseaudio-utils rtkit
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@debian:/home/devid# apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libavresample2 libfftw3-single3 libpulsedsp libwebrtc-audio-processing-0 pulseaudio-utils rtkit
0 upgraded, 0 newly installed, 6 to remove and 0 not upgraded.
After this operation, 3,300 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 164535 files and directories currently installed.)
Removing libavresample2:amd64 (10:2.6.2-dmo1) ...
Removing libfftw3-single3:amd64 (3.3.4-2) ...
Removing pulseaudio-utils (6.0-2) ...
Removing libpulsedsp:amd64 (6.0-2) ...
Removing libwebrtc-audio-processing-0:amd64 (0.1-3) ...
Removing rtkit (0.11-2) ...
Processing triggers for libc-bin (2.19-18) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for dbus (1.8.18-1) ...


continua sotto
Ultima modifica di El Niño il 12/06/2015, 13:39, modificato 1 volta in totale.
El Niño
 

Re: Skype in conflitto su Debian Stretch

Messaggioda El Niño » 10/06/2015, 21:37

Codice: Seleziona tutto
root@debian:/home/devid# apt-get install libavcodec56:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libavcodec56:i386 : Depends: libvpx1:i386 (>= 1.3.0) but it is not installable
E: Unable to correct problems, you have held broken packages.


Codice: Seleziona tutto
root@debian:/home/devid# apt-get install libavcodec-extra-56:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  i965-va-driver:i386 libavcodec-extra-56 libavresample2 libavresample2:i386 libavutil54:i386 libgsm1:i386 libmp3lame0:i386 libnuma1
  libnuma1:i386 libopencore-amrnb0:i386 libopencore-amrwb0:i386 libopenjpeg5:i386 libopus0:i386 libschroedinger-1.0-0:i386
  libspeex1:i386 libva1:i386 libvdpau1:i386 libvo-aacenc0:i386 libvo-amrwbenc0:i386 libvpx2:i386 libx264-146:i386 libx265-59
  libx265-59:i386 libxvidcore4:i386 mesa-vdpau-drivers:i386 va-driver-all:i386 vdpau-va-driver:i386
Suggested packages:
  opus-tools:i386 speex:i386 nvidia-vdpau-driver:i386 vdpau-driver:i386 libx265-59-dbg libx265-59-dbg:i386 xvba-va-driver:i386
The following packages will be REMOVED:
  gstreamer1.0-plugins-bad libavcodec56 libavformat56 libchromaprint0 libopencv-calib3d2.4 libopencv-contrib2.4
  libopencv-features2d2.4 libopencv-highgui2.4 libopencv-legacy2.4 libopencv-objdetect2.4 vlc-nox
The following NEW packages will be installed:
  i965-va-driver:i386 libavcodec-extra-56 libavcodec-extra-56:i386 libavresample2 libavresample2:i386 libavutil54:i386 libgsm1:i386
  libmp3lame0:i386 libnuma1 libnuma1:i386 libopencore-amrnb0:i386 libopencore-amrwb0:i386 libopenjpeg5:i386 libopus0:i386
  libschroedinger-1.0-0:i386 libspeex1:i386 libva1:i386 libvdpau1:i386 libvo-aacenc0:i386 libvo-amrwbenc0:i386 libvpx2:i386
  libx264-146:i386 libx265-59 libx265-59:i386 libxvidcore4:i386 mesa-vdpau-drivers:i386 va-driver-all:i386 vdpau-va-driver:i386
0 upgraded, 28 newly installed, 11 to remove and 0 not upgraded.
Need to get 1,775 kB/15.2 MB of archives.
After this operation, 11.5 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.it.debian.org/debian/ stretch/main i965-va-driver i386 1.5.1-2 [249 kB]

/* Installazione delle varie librerie */

Setting up va-driver-all:i386 (1.5.1-2) ...
Processing triggers for libc-bin (2.19-18) ...


Codice: Seleziona tutto
root@debian:/home/devid# apt-get install libasound2-plugins:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
i965-va-driver libaacplus2 libass5 libavcodec-extra-56 libavresample2 libavutil54 libbasicusageenvironment0 libcddb2 libcrystalhd3
  libdc1394-22 libdvbpsi9 libebml4 libfdk-aac1 libgme0 libgroupsock4 libgsm1 libgstreamer-plugins-bad1.0-0 libgtkglext1 libiso9660-8 [...]
  libvdpau1 libvlc5 libvlccore8 libvo-aacenc0 libvo-amrwbenc0 libwildmidi-config libwildmidi1 libx265-51 libx265-59 libzbar0
  libzvbi-common libzvbi0 mesa-vdpau-drivers va-driver-all vdpau-va-driver vlc-data
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libasyncns0:i386 libcap2:i386 libflac8:i386 libgcrypt20:i386 libgpg-error0:i386 libjack-jackd2-0:i386 libjson-c2:i386
  libpulse0:i386 libsamplerate0:i386 libsndfile1:i386 libspeexdsp1:i386 libsystemd0:i386 libwrap0:i386 libxi6:i386 libxtst6:i386
Suggested packages:
  rng-tools:i386 jackd2:i386 pulseaudio:i386
The following NEW packages will be installed:
  libasound2-plugins:i386 libasyncns0:i386 libcap2:i386 libflac8:i386 libgcrypt20:i386 libgpg-error0:i386 libjack-jackd2-0:i386
  libjson-c2:i386 libpulse0:i386 libsamplerate0:i386 libsndfile1:i386 libspeexdsp1:i386 libsystemd0:i386 libwrap0:i386 libxi6:i386
  libxtst6:i386
0 upgraded, 16 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/2,731 kB of archives.
After this operation, 6,654 kB of additional disk space will be used.
Do you want to continue? [Y/n] y


Dopo questo skype effettivamente funziona, ma se provo a reinstallare VLC, Kodi mi esce :
Codice: Seleziona tutto
......
  firmware-crystalhd nvidia-vdpau-driver vdpau-driver xvba-va-driver
The following packages will be REMOVED:
  libasound2-plugins:i386 libavcodec-extra-56:i386 skype:i386
The following NEW packages will be installed:
----


Quindi, alla fine, o tengo skype oppure VLC.

So di aver esagerato con la lunghezza del post.......L'unica soluzione quindi per ora, è aspettare che skype "si metta in pari con le librerie" a VLC e Kodi?
El Niño
 

Re: Skype in conflitto su Debian Stretch

Messaggioda Danielsan » 10/06/2015, 21:52

Se usi Debian AMD64 devi abilitare il multiarch per usare Skype.

https://wiki.debian.org/Multiarch/HOWTO
Debian Testing/Sid amd64
systemd ha reso GNU/Linux più brutto...
Avatar utente
Danielsan
Hero Member
Hero Member
 
Messaggi: 1430
Iscritto il: 10/07/2009, 19:23
Località: Roma

Re: Skype in conflitto su Debian Stretch

Messaggioda El Niño » 11/06/2015, 7:43

Già fatto.
#dpkg --add-architecture i386. Il problema é che installando vlc mi cancella le librerie di Skype, nonché Skype stesso.
El Niño
 

Re: Skype in conflitto su Debian Stretch

Messaggioda marcomg » 11/06/2015, 8:00

Boh, io ho debian stretch/sid, tengo installati sia vlc che skype (ahimè). Che versione di skype hai? Io la 4.3.0.37-1, ciao!
Windows is what you open when you want fresh air from outside.
Avatar utente
marcomg
Hero Member
Hero Member
 
Messaggi: 5599
Iscritto il: 22/08/2011, 18:54

Re: Skype in conflitto su Debian Stretch

Messaggioda El Niño » 11/06/2015, 10:43

Skype 4.3.0.37. Ma la cosa strana é che di solito andava; ieri ho formattato, e andando a reinstallare i programmi mi é saltato fuori questo problema
El Niño
 

Re: Skype in conflitto su Debian Stretch

Messaggioda mig » 11/06/2015, 12:17

Io con Debian Stretch su AMD64 (multiarch abilitato) non ho problemi di conflitti tra VLC e Skype 4.3.0.37-1.
mig
Newbie
Newbie
 
Messaggi: 2
Iscritto il: 01/12/2008, 14:37

Re: Skype in conflitto su Debian Stretch

Messaggioda El Niño » 11/06/2015, 12:54

Non ho idea di cosa possa essere accaduto di strano.....Stasera in caso provo, e se ho altre notizie vi farò sapere
El Niño
 

Re: Skype in conflitto su Debian Stretch

Messaggioda BubuXP » 11/06/2015, 15:15

Che per caso usi i repo di deb-multimedia o qualche pacchetto non ufficiale?
Avatar utente
BubuXP
Hero Member
Hero Member
 
Messaggi: 753
Iscritto il: 17/12/2011, 4:20
Località: Sicilia orientale

Re: Skype in conflitto su Debian Stretch

Messaggioda El Niño » 11/06/2015, 17:58

Sì, ho i repo deb-multimedia attivi. Pensi che possa essere quello il problema?

Edit: non se possa fare la differenza ma sono abilitati per il ramo "jessie"
Ultima modifica di El Niño il 11/06/2015, 18:03, modificato 1 volta in totale.
El Niño
 

Re: Skype in conflitto su Debian Stretch

Messaggioda Danielsan » 11/06/2015, 17:59

Dring ha colto nel segno, si quello puo' essere il problema non puoi usare Debian Multimedia senza dargli una regola chiara altrimenti crea conflitti di dipendenze perche' generalmente i pacchetti di Debian Multimedia Testing/Unstable sono piu' aggiornati delle rispettive controparti nei repo ufficiali di Debian.
Debian Testing/Sid amd64
systemd ha reso GNU/Linux più brutto...
Avatar utente
Danielsan
Hero Member
Hero Member
 
Messaggi: 1430
Iscritto il: 10/07/2009, 19:23
Località: Roma

Re: Skype in conflitto su Debian Stretch

Messaggioda El Niño » 11/06/2015, 19:22

Rieccomi qua:
Disinstallato Skype, per sicurezza, ho provveduto a disabilitare i repo deb-multimedia; dopo un rapido apt-get update, ho reinstallato skype, e quando ho fatto per installare vlc.....Funziona! Ora posso utilizzare entrambi i programmi senza conflitti fra librerie.
Grazie mille a BubuXP e a tutti gli altri per avermi aiutato a risolvere questo piccolo (ma fastidioso) errore !!!!!
El Niño
 

Re: Skype in conflitto su Debian Stretch

Messaggioda marcomg » 12/06/2015, 9:19

Bravo BubuXP :D
@El Nino, ricordati di contrassegnare la discussione come risolta ;D
Windows is what you open when you want fresh air from outside.
Avatar utente
marcomg
Hero Member
Hero Member
 
Messaggi: 5599
Iscritto il: 22/08/2011, 18:54


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti

cron