Guida Installare Adobe Flash Player

Discussioni relative alla Gestione del wiki Guide@Debianizzati.Org

Re: Guida Installare Adobe Flash Player

Messaggioda reaction845 » 08/09/2014, 20:00

ciao a tutti ho letto la guida dice di scaricare il file dal sito adobe ed estrarre il file libflashplayer.so in /usr/lib/mozilla/plugins però io ho un problema..evidentemente non eseguo il procedimento corretto ho il programma ark per decomprimere il file
reaction845
Jr. Member
Jr. Member
 
Messaggi: 82
Iscritto il: 05/09/2014, 21:37

Re: Guida Installare Adobe Flash Player

Messaggioda reaction845 » 08/09/2014, 20:15

non devo creare questa cartellla install_flash_player_11_linux.x86_64 dentro plugin vero?
reaction845
Jr. Member
Jr. Member
 
Messaggi: 82
Iscritto il: 05/09/2014, 21:37

Re: Guida Installare Adobe Flash Player

Messaggioda reaction845 » 08/09/2014, 20:22

avevo già provato i comandi ma non funzionava ho riprovato # apt-get install flashplugin-nonfree
e mi ha installato il tutto
reaction845
Jr. Member
Jr. Member
 
Messaggi: 82
Iscritto il: 05/09/2014, 21:37

Re: Guida Installare Adobe Flash Player

Messaggioda Selky » 08/09/2014, 22:28

Ciao reaction845,
hai risolto con l'installazione standard ;)
Per l'installazione manuale non ho capito quale sia stato il problema riscontrato.
Non sei riuscito a copiare il file libflashplayer.so nella directory usr?
Questa operazione la devi compiere come utente root e non come utente normale.
Selky
wiki member
wiki member
 
Messaggi: 1358
Iscritto il: 30/12/2011, 1:00

Re: Guida Installare Adobe Flash Player

Messaggioda reaction845 » 09/09/2014, 13:09

ciao selki avevo difficoltà a copiare il file in usr ecc non sò dove sbagliavo e con i comandi apt ecc non mi eseguiva l'installazione..poi ho risolto però non sapreidirti come prima ho copiato ilfile in usr poi con apt-get install son riuscito a installare adobe flash player
reaction845
Jr. Member
Jr. Member
 
Messaggi: 82
Iscritto il: 05/09/2014, 21:37

Re: Guida Installare Adobe Flash Player

Messaggioda Selky » 01/01/2017, 21:58

Nei giorni scorsi ho aggiornato la guida riguardante Flash e affini.

C'è un problema per quanto riguarda il pacchetto pepperflash disponibile nei repo Debian:
Chrome dalla v.54 non include più il plugin e pertanto al termine dello scaricamento del browser (che è anche pesantino con internet key a giga limitati) si ottiene l'errore, o meglio specifica che il plugin non è disponibile. Questo su Jessie l'ho potuto constatare.
Codice: Seleziona tutto
mv: impossibile eseguire stat di "unpackchrome/opt/google/chrome/PepperFlash/libpepflashplayer.so": File o directory non esistente

Chiedo cortesemente un favore a chi ha una testing Stretch di testare il pacchetto che hanno reintrodotto 29 dicembre 2016. Non ho modo di provarlo e per quello che ho appurato spulciando il deb, il pacchetto prevede ancora la medesima procedura nonostante le segnalazioni di bug, ossia scaricare il browser Chrome ed estrarre il plugin da questo anzichè utilizzare il sito di Adobe che tra le altre cose ha anche il plugin per il 32 bit e non solo 64.

Mi basterebbe una conferma, grazie.
Selky
wiki member
wiki member
 
Messaggi: 1358
Iscritto il: 30/12/2011, 1:00

Re: Guida Installare Adobe Flash Player

Messaggioda byte64 » 08/01/2017, 14:46

Ho debian testing e Chrome v.55, ho fatto un reinstall del pacchetto pepperflash ed ottengo lo stesso messaggio di errore tuo.
Ciao
byte64
Sr. Member
Sr. Member
 
Messaggi: 285
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: Guida Installare Adobe Flash Player

Messaggioda caturen » 08/01/2017, 18:15

Selky ha scritto:Nei giorni scorsi ho aggiornato la guida riguardante Flash e affini.

C'è un problema per quanto riguarda il pacchetto pepperflash disponibile nei repo Debian:
Chrome dalla v.54 non include più il plugin e pertanto al termine dello scaricamento del browser (che è anche pesantino con internet key a giga limitati) si ottiene l'errore, o meglio specifica che il plugin non è disponibile. Questo su Jessie l'ho potuto constatare.
Codice: Seleziona tutto
mv: impossibile eseguire stat di "unpackchrome/opt/google/chrome/PepperFlash/libpepflashplayer.so": File o directory non esistente


quell'errore è ininfluente: pepperflash viene installato tranquillamente in chromium. Io su sid ho lo stesso errore
Codice: Seleziona tutto
mv: impossibile eseguire stat di 'unpackchrome/opt/google/chrome/PepperFlash/libpepflashplayer.so': File o directory non esistente
ma pepper viene installato/aggiornato
il pacchetto prevede ancora la medesima procedura nonostante le segnalazioni di bug, ossia scaricare il browser Chrome ed estrarre il plugin da questo anzichè utilizzare il sito di Adobe che tra le altre cose ha anche il plugin per il 32 bit e non solo 64.
si può aggiornare senza problemi pepper anche scaricandolo dal sito di adobe ed andando a cambiare il vecchio libpepflashplayer.so presente in /usr/lib/pepperflashplugin-nonfree
byte64 ha scritto:Ho debian testing e Chrome v.55, ho fatto un reinstall del pacchetto pepperflash ed ottengo lo stesso messaggio di errore tuo.
Ciao
mi spieghi a che ti serve pepperflash, quando in chrome è già inglobato nel browser?
caturen
Full Member
Full Member
 
Messaggi: 240
Iscritto il: 02/04/2013, 20:00

Re: Guida Installare Adobe Flash Player

Messaggioda byte64 » 08/01/2017, 18:38

mi spieghi a che ti serve pepperflash, quando in chrome è già inglobato nel browser?

Siccome uso anche altri browser, ho installato anche il pacchetto che permette di usarlo con firefox.
Ciao
byte64
Sr. Member
Sr. Member
 
Messaggi: 285
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: Guida Installare Adobe Flash Player

Messaggioda Selky » 08/01/2017, 22:00

Grazie per essere intervenuti.

La situazione dopo vari test: sia il pacchetto del repo Jessie che quello di Stretch non permettono di avere pepperflash. Si crea la direcotry /usr/lib/pepperflashplugin-nonfree/ con solo il seguente file: pubkey-google.txt

Questo al di là che sia una nuova installazione o con un file da aggiornare.
L'installazione manuale prelevando da Adobe non mi interessa, l'abbiamo documentata da parecchio e aggiornata varie volte.
Questa la guida sul wiki debianizzati http://guide.debianizzati.org/index.php ... ash_Player

I bug segnalati cui accennavo sono questi: https://bugs.debian.org/cgi-bin/bugrepo ... bug=841373
https://bugs.debian.org/cgi-bin/bugrepo ... bug=833741
Selky
wiki member
wiki member
 
Messaggi: 1358
Iscritto il: 30/12/2011, 1:00

Re: Guida Installare Adobe Flash Player

Messaggioda caturen » 10/01/2017, 4:40

byte64 ha scritto:
mi spieghi a che ti serve pepperflash, quando in chrome è già inglobato nel browser?

Siccome uso anche altri browser, ho installato anche il pacchetto che permette di usarlo con firefox.
Ciao
non ti serve a nulla: per firefox ti serve solo browser-plugin-fresplayer-pepperflash. In questo modo ff prende flash direttamente da chrome.
La situazione dopo vari test: sia il pacchetto del repo Jessie che quello di Stretch non permettono di avere pepperflash. Si crea la direcotry /usr/lib/pepperflashplugin-nonfree/ con solo il seguente file: pubkey-google.txt
hai ragione: o appena controllato ed è proprio così. Probabilmente io il libpepflashplayer.so lo avevo messo a mano, ma non me lo ricordavo proprio.
caturen
Full Member
Full Member
 
Messaggi: 240
Iscritto il: 02/04/2013, 20:00

Re: Guida Installare Adobe Flash Player

Messaggioda byte64 » 10/01/2017, 8:39

caturen ha scritto:
byte64 ha scritto:
mi spieghi a che ti serve pepperflash, quando in chrome è già inglobato nel browser?

Siccome uso anche altri browser, ho installato anche il pacchetto che permette di usarlo con firefox.
Ciao
non ti serve a nulla: per firefox ti serve solo browser-plugin-fresplayer-pepperflash. In questo modo ff prende flash direttamente da chrome.

Il pacchetto pepperflasplugin-nonfree è richiesto da browser-plugin-fresplayer-pepperflash ed anche bypassando la dipendenza o rimuovendo il solo pepperflashplugin-nonfree il solo pacchetto browser-plugin-freshplayer-pepperflash + chrome non sono sufficienti a far funzionare flash su firefox.
Funziona se si copia a mano libpepflashplayer.so in /opt/google/chrome/PepperFlash/ anche se poi in realtà quando il pacchetto si installava correttamente veniva creato un link a /usr/lib/pepflashplugin-installer/libpepflashplayer.so.
Ho verificato su debian testing con chrome v.55 e firefox esr 45.6.
byte64
Sr. Member
Sr. Member
 
Messaggi: 285
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: Guida Installare Adobe Flash Player

Messaggioda Selky » 10/01/2017, 20:11

State facendo confusione e forse non avete notato ciò che ho scritto sia qua che nella guida.
caturen ha scritto:mi spieghi a che ti serve pepperflash, quando in chrome è già inglobato nel browser?

Il pacchetto pepperflash funziona così: scarica Chrome ed estrae solo il plugin necessario. Il punto è che da Chrome versione 54 questo plugin non è più incluso in Chrome pertanto la procedura è inutile e bisogna agire per forza manualmente.
Per questo motivo mi ha stupito la reintegrazione del pacchetto in stretch avvenuto a fine dicembre.

byte64 ha scritto:Funziona se si copia a mano libpepflashplayer.so in /opt/google/chrome/PepperFlash/ anche se poi in realtà quando il pacchetto si installava correttamente veniva creato un link a /usr/lib/pepflashplugin-installer/libpepflashplayer.so.
Ho verificato su debian testing con chrome v.55 e firefox esr 45.6.

Non è esatto.
/opt/google/chrome/PepperFlash/ serve esclusivamente a Google Chrome
senza di questo la versione presente in "chrome://plugins" non risulta esatta e manca il percorso. Se nella barra degli indirizzi si digita "chrome://components/" e si aggiorna il plugin, solo qua risulterà la giusta versione.
Una volta aggiornato, chiudere il browser Chrome e riavviarlo, anche in "chrome://plugins" risulterà la giusta versione. In questo caso il percorso è /home/nome_utente/.config/google-chrome/PepperFlash/ i file sono contenuti nella cartella riportante il numero di versione, ora è la 24.0.0.186

Per tutti gli altri (Chromium, Opera e Firefox tramite browser-plugin-freshplayer-pepperflash) il percorso è /usr/lib/pepperflashplugin-nonfree/ e funziona egregiamente.
Il percorso "/usr/lib/pepflashplugin-installer/" su Debian non esiste.

Non confondete Debian con Ubuntu e la loro pacchettizzazione che è differente.

In questa discussione viewtopic.php?f=17&t=51832&start=60 abbiamo ampiamente dimostrato la procedura che poi ho trasferito nella guida.
Selky
wiki member
wiki member
 
Messaggi: 1358
Iscritto il: 30/12/2011, 1:00

Re: Guida Installare Adobe Flash Player

Messaggioda byte64 » 10/01/2017, 20:46

Ti garantisco che sul sistema che ho indicato nel post precedente se in /opt/google/chrome/PepperFlash/ non ci copi la libreria flash, in firefox flash non funziona con installato il wrapper NPAPI per firefox e chrome (non chromium).
Probabilmente si è un po' incasinato il mio sistema dopo aver fatto un rienstall del pepperflashplugin-nonfree (per verificare la tua richiesta iniziale), era installato da ben prima del 29 dicembre, quando utilizzavo chromium. Sono poi passato a Chrome. (Appena ho un po' di tempo magari approfondisco anche)
Riguardo la /usr/lib/pepflashplugin-installer/ dovrei verificare meglio, dato che era la destinazione del link alla libreria da /opt/google/chrome/PepperFlash. Poi ho purgato e reinstallato, quindi adesso effettivamente non c'è più.
Comunque il tutto funziona egregiamente.....
byte64
Sr. Member
Sr. Member
 
Messaggi: 285
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: Guida Installare Adobe Flash Player

Messaggioda Selky » 10/01/2017, 20:50

Nel frattempo ho editato il mio precedente intervento perchè ho dimenticato un pezzo.
Se fai come indicato ti funziona.

Per il resto penso che sia solo un tuo problema perchè a me e ad altri funziona come indicato. Anche perchè Chrome non lo installo assolutamente e quando lo faccio è solo 5 minuti per i test come ora. Poi lo elimino in fretta compreso tutte le sue tracce.
Mentre per il percorso sono sicura /usr/lib/pepflashplugin-installer/ non riguarda Debian.

Edit
Oggi c'è stato un nuovo aggiornamento del plugin https://helpx.adobe.com/security/produc ... 17-02.html io non ho ancora proceduto all'aggiornamento per quello è segnalata la versione precedente.
Con Google avevo provato tre giorni fa.
Selky
wiki member
wiki member
 
Messaggi: 1358
Iscritto il: 30/12/2011, 1:00

PrecedenteProssimo

Torna a Guide@Debianizzati.Org

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti