pacchetti ubuntu

Audio, Video, Grafica...

Re: pacchetti ubuntu

Messaggioda Ombra » 02/02/2017, 9:25

mi sa che ti mancano delle dipendenze che non sono segnalate nel pacchetto deb;
prova a installare libstdc++6; inoltre la versione di dbus che hai sul sistema è inferiore a quella usata per compilare il programma (non ci puoi fare nulla visto che non ti danno i sorgenti), cmq verifica che non ci sia qualche aggiornamento per dbus.
Codice: Seleziona tutto
apt-get update

Codice: Seleziona tutto
apt-get install libstdc++6 libdbus-1-3


poi prova di nuovo
Codice: Seleziona tutto
$ /usr/bin/booktab


e posta il risultato

se non ce la faccio ad installare, potrò ripulire il computer di tutta questa roba scompattata inutilmente??


hai già installato solo che il .deb non segnala tutte le dipendenze come dovrebbe; per rimuovere tutto ti basta un
Codice: Seleziona tutto
dpkg --Purge BooktabZSetup-15.10


se invece ti stai riferendo a
apri il deb, all'interno c'è un file "data.tar.xz", apri anche quello..
qualle roba la puoi cestinare.

per maggiori dettagli su come gestire i pacchetti in debian potresti dare una occhiata alle nostre guide
Ombra
wiki member
wiki member
 
Messaggi: 474
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: pacchetti ubuntu

Messaggioda zypepox » 02/02/2017, 9:43

Codice: Seleziona tutto
# apt-get install libstdc++6 libdbus-1-3
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
libdbus-1-3 è già alla versione più recente.
È stato impostato libdbus-1-3 per l'installazione manuale.
libstdc++6 è già alla versione più recente.
0 aggiornati, 0 installati, 0 da rimuovere e 13 non aggiornati.


Codice: Seleziona tutto
# /usr/bin/booktab
/usr/share/duDat/BooktabZ/btb: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/share/duDat/BooktabZ/btb)
/usr/share/duDat/BooktabZ/btb: /lib/x86_64-linux-gnu/libdbus-1.so.3: no version information available (required by /usr/share/duDat/BooktabZ/libQt5WebEngineCore.so.5)
/usr/share/duDat/BooktabZ/btb: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/share/duDat/BooktabZ/libQt5WebEngineCore.so.5)
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Re: pacchetti ubuntu

Messaggioda Ombra » 02/02/2017, 11:14

disinstalla quella versione di booktab e prova con la precedente (la 15.04)
Ombra
wiki member
wiki member
 
Messaggi: 474
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: pacchetti ubuntu

Messaggioda zypepox » 02/02/2017, 14:01

ecco la risposta al mio tentativo di disinstallazione:

Codice: Seleziona tutto
# dpkg --Purge BooktabZSetup-15.10
dpkg: errore: opzione --Purge sconosciuta

Usare dpkg --help per un aiuto sull'installazione e la rimozione dei pacchetti [*].
Usare "apt" o "aptitude" per un'interfaccia alla gestione dei pacchetti.
Usare dpkg -Dhelp per l'elenco delle opzioni di debug per dpkg.
Usare dpkg --force-help per l'elenco delle opzioni di forzatura.
Usare dpkg-deb --help per un aiuto sulla manipolazione dei file *.deb.

Le opzioni indicate con [*] producono output prolisso - creare una pipe con "less" o "more".
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Re: pacchetti ubuntu

Messaggioda byte64 » 02/02/2017, 14:11

dpkg -P nomeoacchetto
oppure
dpkg --purge nomepacchetto

dpkg --help (vedi le opzioni disponibili e la sintassi)
man dpkg (vedi le istruzioni dettagliate per l'uso del comando)

Ciao
byte64
Sr. Member
Sr. Member
 
Messaggi: 380
Iscritto il: 07/01/2017, 19:02
Località: Bergamo

Re: pacchetti ubuntu

Messaggioda zypepox » 02/02/2017, 14:58

Codice: Seleziona tutto
# dpkg --purge BooktabZSetup-15.10
dpkg: attenzione: viene ignorata la richiesta di rimuovere booktabzsetup-15.10 poiché non è installato


Codice: Seleziona tutto
# dpkg --purge BooktabZSetup-15.10.deb
dpkg: errore: è necessario specificare i pacchetti con il loro nome, non riportando il nome dei file che li contengono

Usare dpkg --help per un aiuto sull'installazione e la rimozione dei pacchetti [*].
Usare "apt" o "aptitude" per un'interfaccia alla gestione dei pacchetti.
Usare dpkg -Dhelp per l'elenco delle opzioni di debug per dpkg.
Usare dpkg --force-help per l'elenco delle opzioni di forzatura.
Usare dpkg-deb --help per un aiuto sulla manipolazione dei file *.deb.

Le opzioni indicate con [*] producono output prolisso - creare una pipe con "less" o "more".
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Re: pacchetti ubuntu

Messaggioda Ombra » 02/02/2017, 15:09

dpkg: errore: opzione --Purge sconosciuta

scusa errore mio

per vedere esattamente come si chiama il pacchetto fai così

Codice: Seleziona tutto
dpkg -l | grep booktab

provando anche a inserire delle maiuscole tipo "Booktab" o "BookTab" se dalla prima ricerca non ti esce nulla
Ombra
wiki member
wiki member
 
Messaggi: 474
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: pacchetti ubuntu

Messaggioda zypepox » 02/02/2017, 15:32

Codice: Seleziona tutto
# dpkg -l | grep booktab
ii  booktab                               1.8-1                                amd64        Booktab demo
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Re: pacchetti ubuntu

Messaggioda Ombra » 02/02/2017, 16:11

quindi se usi quel nome te lo disinstalla?
Codice: Seleziona tutto
dpkg --purge booktab
Ombra
wiki member
wiki member
 
Messaggi: 474
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: pacchetti ubuntu

Messaggioda zypepox » 02/02/2017, 20:48

Ombra ha scritto:disinstalla quella versione di booktab e prova con la precedente (la 15.04)


purtroppo non va nemmeno la 15.04
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Re: pacchetti ubuntu

Messaggioda Ombra » 03/02/2017, 10:41

Codice: Seleziona tutto
purtroppo non va nemmeno la 15.04

Devi chiedere all'autore di compilare una versione adatta a Debian Stable, o alternativamente puoi provare a vedere se va su una testing (ma non è garantito).
Ombra
wiki member
wiki member
 
Messaggi: 474
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: pacchetti ubuntu

Messaggioda zypepox » 03/02/2017, 14:33

Ombra ha scritto:Devi chiedere all'autore di compilare una versione adatta a Debian Stable, o alternativamente puoi provare a vedere se va su una testing (ma non è garantito).


ho già chiesto con esito negativo. :(
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Re: pacchetti ubuntu

Messaggioda Ombra » 03/02/2017, 15:24

Pensavo avessi chiesto di avere i sorgenti. Comunque questo è uno dei problemi dei programmi non opensource, mi spiace ma a sto punto non so come aiutarti.
Ombra
wiki member
wiki member
 
Messaggi: 474
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: pacchetti ubuntu

Messaggioda zypepox » 04/02/2017, 11:26

sì, avevo chiesto sia i sorgenti che la compilazione per debian. comunque, a limitare i danni, della stessa applicazione ne hanno sviluppato una che gira su browser https://booktab.it/

grazie, ciao
Avatar utente
zypepox
Full Member
Full Member
 
Messaggi: 230
Iscritto il: 28/06/2007, 20:41

Precedente

Torna a Multimedia

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite