Problema collegamento con hdmi a TV

Discussioni relative a Debian e Linux

Problema collegamento con hdmi a TV

Messaggioda carloberd » 16/05/2017, 18:30

Salve a tutti!
Ho dei problemi a collegare il mio pc portatile con installato Debian alla mia TV. Purtroppo quando inserirsco il cavo lo schermo diventa tutto nero, sia su tv,sia su pc. Quando poi vado a staccare il cavo hdmi lo schermo del pc non torna più attivo, anche se il pc è acceso.
Se può essere d'aiuto, la versione di Debian è l'ultima uscita (8.8.0) con GNOME.

Scusate, mi sento un po' noob.. ma in effetti lo sono :-\ :-\

Grazie mille a tutti quelli che risponderanno!
PS. spero di averlo messo nella sezione giusta ;D
carloberd
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 16/05/2017, 18:23

Re: Problema collegamento con hdmi a TV

Messaggioda AS » 16/05/2017, 20:25

Che scheda hai?
Se la casa del tuo vicino brucia, la cosa ti riguarda, e parecchio.


Immagine
Avatar utente
AS
Hero Member
Hero Member
 
Messaggi: 1150
Iscritto il: 01/05/2010, 10:22

Re: Problema collegamento con hdmi a TV

Messaggioda carloberd » 16/05/2017, 21:33

Nvidia GeForce Gt 630M da 2 GB
carloberd
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 16/05/2017, 18:23

Re: Problema collegamento con hdmi a TV

Messaggioda AS » 16/05/2017, 23:29

Usi i driver Nvidia o i Nouveau? Devi dare più informazioni per poter essere aiutato.
Se la casa del tuo vicino brucia, la cosa ti riguarda, e parecchio.


Immagine
Avatar utente
AS
Hero Member
Hero Member
 
Messaggi: 1150
Iscritto il: 01/05/2010, 10:22

Re: Problema collegamento con hdmi a TV

Messaggioda carloberd » 16/05/2017, 23:50

Ecco, proprio per questo sono qui. Non so come installare i driver (se questi non sono già installati, come faccio a vederlo?)
carloberd
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 16/05/2017, 18:23

Re: Problema collegamento con hdmi a TV

Messaggioda Selky » 16/05/2017, 23:56

Ciao e benvenuto :)

Segui questa guida Creazione automatica di un file di log per inviare quesiti al forum
Allega il file compresso al forum (non .txt perché non lo accetta)

In questo modo fornirai parecchie informazioni che torneranno utili a chi potrà aiutarti. ;)
Selky
wiki member
wiki member
 
Messaggi: 1322
Iscritto il: 30/12/2011, 1:00

Re: Problema collegamento con hdmi a TV

Messaggioda carloberd » 17/05/2017, 0:30

Ciao Selky, grazie mille :)
Ecco qua, ho fatto un upgrade e ho seguito la guida.
Allego il file compresso
Allegati
log_17mag_012634.xz
(61.39 KiB) Scaricato 15 volte
carloberd
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 16/05/2017, 18:23

Re: Problema collegamento con hdmi a TV

Messaggioda Selky » 18/05/2017, 22:01

Purtroppo non sono in grado di aiutarti. Spero passi di qua qualcuno che riesca a darti qualche indicazione.
Selky
wiki member
wiki member
 
Messaggi: 1322
Iscritto il: 30/12/2011, 1:00

Re: Problema collegamento con hdmi a TV

Messaggioda carloberd » 20/05/2017, 19:17

Tranquillo,se può servire in questi due giorni ho fatto un po' di ricerche e forse il motivo è che non ho i driver della mia scheda video (nvidia GeForce GT 630M) installati. Quindi ho provato a installarli seguendo diverse guide, tra cui questa della wiki:

https://wiki.debian.org/NvidiaGraphicsD ... tification

ma il risultato è stato che ogni volta, dopo il riavvio, lo schermo rimaneva nero e debian non partiva. Quindi ogni volta dovevo passare dalla recovery, disinstallare i driver appena installati e facendo ciò si riaccendeva. Ho letto anche che molti altri hanno avuto questo problema e che i driver Nvidia sono rognosi da installare. Cosa posso fare per ovviare il problema?
carloberd
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 16/05/2017, 18:23

Re: Problema collegamento con hdmi a TV

Messaggioda Spoon » 21/05/2017, 20:02

Ciao e benvenuto, non sono un esperto ma ho litigato un po' con alcune schede grafiche e provo a condividere le mie conoscenze nella speranza che possano metterti sulla strada giusta :)

Una cosa ho capito: se i driver liberi supportano tutte le funzioni di cui hai bisogno, molto meglio rimanere con questi che andare con i driver proprietari. Aldilà di preferenze "ideologiche" di solito funzionano in maniera più straightforward e sono più facilmente configurabili. Detto questo, il driver libero (xserver-xorg-video-nouveau) supporta la tua scheda. Le feature disponibili si possono leggere qui, la tua scheda è nella famiglia con codice NVC0. L'uscita audio in HDMI è segnata funzionante, mentre "TV out" è segnato N/A, non so perchè. Credo che valga la pena fare una prova, e nel caso non funzionasse passare a quelli proprietari (o direttamente con questi ultimi se preferisci).

In ogni caso prima di fare delle prove ti vorrei segnalare che hai due schede a bordo, c'è anche una Intel integrata. Questa configurazione hardware è pensata per usare la scheda integrata per operazioni standard e quella più potente per il resto. Non so come si configuri il sistema per sfruttarla al meglio, ma mi viene il dubbio che il tuo sistema possa usare di base la scheda Intel (che probabilmente non supporta l'uscita HDMI). Non ho le competenze per capire quale scheda sia in uso dal log che hai allegato, ma per fugare ogni dubbio proverei a installare solo xserver-xorg-video-nouveau (o il driver proprietario) avendo la cura di non avere nessun altro pacchetto xserver-xorg-video-*, cosicchè venga usata sicuramente la scheda nVidia.
Spoon
wiki member
wiki member
 
Messaggi: 263
Iscritto il: 23/11/2013, 14:37

Re: Problema collegamento con hdmi a TV

Messaggioda carloberd » 21/05/2017, 20:38

Grazie mille, proverò a installare quei driver e ti farò sapere se funzionano! :D
carloberd
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 16/05/2017, 18:23


Torna a Generale

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron