debian systemd[1]: Failed to start Load Kernel Modules.

Questioni legate al Kernel Linux: configurazione, installazione, ottimizzazione, patch

debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda MarcoC » 16/02/2018, 12:52

Ciao a tutti,
mi chiamo Marco e sono nuovo del sito. Il mio SO è Debian 8 "Jessie". Per installare Salome, un programma che fa uso della grafica 3D, ho dovuto installare i driver proprietari nvida per GeForce.

Quando avvio la macchina compare un errore:

Failed to start Load Kernel Modules

se poi indago:

marco@debian:/etc/nvidia/current$ sudo systemctl status systemd-modules-load.service | grep Err*
feb 16 10:13:47 debian systemd-modules-load[168]: Error running install command for nvidia_drm

Come posso fare ?

Grazie a tutti.
MarcoC
Newbie
Newbie
 
Messaggi: 11
Iscritto il: 16/02/2018, 12:40

Re: debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda s3v » 16/02/2018, 13:19

Benvenuto.
MarcoC ha scritto:...ho dovuto installare i driver proprietari nvida per GeForce.

Come hai installato questi driver? E da dove li hai presi?
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5573
Iscritto il: 31/12/2008, 11:54

Re: debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda MarcoC » 16/02/2018, 15:42

il driver è NVIDIA-Linux-x86_64-390.25.run scaricato dal sito ufficiale nvidia. Precedentemente avevo installato mesa dal repository debian, ma per la grafica 3D nouveau non va bene.
MarcoC
Newbie
Newbie
 
Messaggi: 11
Iscritto il: 16/02/2018, 12:40

Re: debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda s3v » 16/02/2018, 16:48

Stai provando ad installare l'ultimissima serie Nvidia (390, in Debian experimental) su una Jessie.
Utilizza i driver Nvidia già pachettizzati in Debian e che non danno problemi di questo tipo (a meno che tu non stia utilizzando una nuovissima scheda grafica non supportata da questi driver).
https://packages.debian.org/jessie/nvidia-driver (serie 340 nei repository ufficiali), oppure
https://packages.debian.org/jessie-back ... dia-driver (serie 375 nei backports).
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5573
Iscritto il: 31/12/2008, 11:54

Re: debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda MarcoC » 16/02/2018, 20:54

La mia scheda è Nvidia GeForce GT 740M dove trovo il driver ?

Grazie.

Marco
MarcoC
Newbie
Newbie
 
Messaggi: 11
Iscritto il: 16/02/2018, 12:40

Re: debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda s3v » 17/02/2018, 14:52

MarcoC ha scritto:dove trovo il driver ?

Nei repository ufficiali:
Codice: Seleziona tutto
# apt-get install nvidia-driver

Oppure nei backports:
Codice: Seleziona tutto
# apt-get install -t jessie-backports nvidia-driver

Disinstalla prima i driver che hai installato con l'installer nvidia:
Codice: Seleziona tutto
# sh nomeinstaller.run --uninstall

(non conosco il nome del file .run che hai utilizzato, adatta il comando con il nome giusto).
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5573
Iscritto il: 31/12/2008, 11:54

Re: debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda MarcoC » 17/02/2018, 17:53

In realtà mi dice che NVIDIA-Linux-x86_64-390.25.run --uninstall non è installato e che nvidia è già installato all'ultima versione:


~/Scaricati$ sudo ./NVIDIA-Linux-x86_64-390.25.run --uninstall
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 390.25.........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
marco@debian:~/Scaricati$ sudo apt-get install nvidia-driver
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
nvidia-driver è già alla versione più recente.
0 aggiornati, 0 installati, 0 da rimuovere e 34 non aggiornati.

marco@debian:~/Scaricati$ sudo ./NVIDIA-Linux-x86_64-390.25.run --uninstall
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 390.25.........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
marco@debian:~/Scaricati$ sudo apt-get install nvidia-driver
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
nvidia-driver è già alla versione più recente.
0 aggiornati, 0 installati, 0 da rimuovere e 34 non aggiornati.

Che devo fare ?

Grazie
MarcoC
Newbie
Newbie
 
Messaggi: 11
Iscritto il: 16/02/2018, 12:40

Re: debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda s3v » 18/02/2018, 10:53

Non capisco allora il problema dove possa essere... sembra tu abbia installato sia i driver dai repository che dal pacchetto prelevato dal sito.
Gentilmente fornisci il file compresso generato da questo script (scegli l'opzione "Problemi video").
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5573
Iscritto il: 31/12/2008, 11:54

Re: debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda MarcoC » 19/02/2018, 15:38

marco@debian:~$ sudo ./scriptlog-debianizzati.org --tipo=video
[sudo] password for marco:
./scriptlog-debianizzati.org: riga 1245: errore di sintassi: EOF non atteso

Purtroppo lo script nel mio caso non gira correttamente.

Dove sbaglio ?
MarcoC
Newbie
Newbie
 
Messaggi: 11
Iscritto il: 16/02/2018, 12:40

Re: debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda s3v » 19/02/2018, 18:48

Controllato di aver effettuato correttamente il copia/incolla?
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5573
Iscritto il: 31/12/2008, 11:54

Re: debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda MarcoC » 20/02/2018, 16:54

Si avevi ragione, c'è stato un qualche problema di copia/incolla. Lo script ha girato ed allego il risultato.

Grazie,

Marco
Allegati
log_20feb_162710.xz
ecco l'allegato
(36.04 KiB) Scaricato 91 volte
MarcoC
Newbie
Newbie
 
Messaggi: 11
Iscritto il: 16/02/2018, 12:40

Re: debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda s3v » 21/02/2018, 11:46

Pare che il tuo portatile sia equipaggiato con due schede video, una Intel integrata e una Nvidia. Confermi?
In tal caso potresti provare a:
1) Disabilitare la Intel se il BIOS te lo consente
2) Creare un file xorg.conf per usare i driver nvidia (presumo che vengano usati gli Intel i915 in questo momento).
3) Usare bumblebee
Ma queste sono supposizioni, cioè tentativi che farei io se mi trovassi al tuo posto.

Nel caso di questa particolare configurazione (due schede video) non sono purtroppo in grado di darti supporto se non cercando in rete casi simili al tuo con possibili soluzioni.
Spero ci sia qualcuno che possa aiutarti meglio di me.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5573
Iscritto il: 31/12/2008, 11:54

Re: debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda MarcoC » 21/02/2018, 18:24

Si ho due schede, come si deduce dalla schermata qui sotto:

marco@debian:~$ lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.1 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 2 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader (rev 01)
08:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter (rev 01)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 08)
0a:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)


La prima:

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)

La seconda:

0a:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)

Come posso fare per attuare i tuoi punti 1 e 2 ?

Grazie,

Marco
MarcoC
Newbie
Newbie
 
Messaggi: 11
Iscritto il: 16/02/2018, 12:40

Re: debian systemd[1]: Failed to start Load Kernel Modules.

Messaggioda s3v » 24/02/2018, 13:45

Ma il messaggio che compare nel titolo di questa discussione è ancora presente?
Perché dal log non risulta:
Codice: Seleziona tutto
-- La fase di avvio è done.
feb 20 14:58:35 debian kernel: nvidia: module license 'NVIDIA' taints kernel.
feb 20 14:58:35 debian kernel: Disabling lock debugging due to kernel taint
feb 20 14:58:35 debian kernel: nvidia 0000:0a:00.0: enabling device (0006 -> 0007)
feb 20 14:58:35 debian kernel: nvidia-nvlink: Nvlink Core is being initialized, major device number 250
feb 20 14:58:35 debian kernel: NVRM: loading NVIDIA UNIX x86_64 Kernel Module  375.82  Wed Jul 19 21:16:49 PDT 2017 (using threaded interrupts)
feb 20 14:58:35 debian kernel: nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  375.82  Wed Jul 19 20:35:11 PDT 2017
feb 20 14:58:35 debian kernel: [drm] Initialized drm 1.1.0 20060810
feb 20 14:58:35 debian systemd-modules-load[168]: Inserted module 'nvidia_drm'
feb 20 14:58:35 debian systemd[1]: Started Load Kernel Modules.
-- Subject: L'unità systemd-modules-load.service termina la fase di avvio
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- L'unità systemd-modules-load.service ha terminato la fase di avvio.

e sembra che da quel lato sia tutto ok.

Per il punto 1, direi di lasciar perdere per ora evitando di combinare casini.
Per il punto 2, crea come root il file "/etc/X11/xorg.conf" con questo contenuto:
Codice: Seleziona tutto
Section "Device"
        Identifier  "Card1"
        Driver      "nvidia"
EndSection

e riavvia il server grafico o l'intera macchina.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5573
Iscritto il: 31/12/2008, 11:54


Torna a Kernel

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti