Acer 4810tg: blocco di KDE (era: regolazione luminosità)

Discussioni relative all'ambiente grafico X (Xfree e XOrg)

Re: regolazione luminosità

Messaggioda s3v » 19/11/2018, 21:37

mlibero ha scritto:volevo rimuovere xserver-xorg-video-ati ma apt mi fa rimuovere anche
apt-get -s remove xserver-xorg-video-ati
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno RIMOSSI:
xserver-xorg-video-all xserver-xorg-video-ati

va bene e continuo?

Sì, il pacchetto "xserver-xorg-video-all" è in realtà un metapacchetto per cui serve solo per richiamare tutte le sue dipendenze.
L'unica accortezza è quella di marcare come "manual" i pacchetti che ti verranno proposti per la disinstallazione automatica (autoremove) da apt; nella guida è comunque spiegato come fare.

Visto che anche questa strada è un buco nell'acqua, rimuovi le modifiche fatte a "/etc/default/grub" (e consueto "update-grub").
Nei log di sistema (quelli che si trovano in "/var/log") che appare quando si verifica il blocco del sistema alla pressione dei tasti per la regolazione della luminosità?
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5867
Iscritto il: 31/12/2008, 11:54

Re: regolazione luminosità

Messaggioda mlibero » 20/11/2018, 17:35

ciao,
non so da dove cominciare, una domanda
Nei log di sistema (quelli che si trovano in "/var/log") che appare quando si verifica il blocco del sistema alla pressione dei tasti per la regolazione della luminosità?

a quali log presenti in /var/log ti riferisci, i log che crea sono quelli che ti ho inviato nel primo post, xorg.0.log e xorg.1.log, ce ne sono altri come messages e messages.1, forse ti riferisci a quelli?
nel frattempo ho installato il kernel 4.18 preso da backports, nella speranza di qualche miglioramento, invece accade quello che accadeva anche nelle prove fatte con kalilinux con kernel 4.18
kernel 4.18

cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS-Audio: DynOff:0000:01:00.1
1:IGD:+:Pwr:0000:00:02.0
2:DIS: DynOff:0000:01:00.0

lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710/M92 [Mobility Radeon HD 4330/4350/4550]

cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS-Audio: DynOff:0000:01:00.1
1:IGD:+:Pwr:0000:00:02.0
2:DIS: DynPwr:0000:01:00.0

echo OFF > cat /sys/kernel/debug/vgaswitcheroo/switch

cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS-Audio: DynOff:0000:01:00.1
1:IGD:+:Pwr:0000:00:02.0
2:DIS: DynOff:0000:01:00.0

il comando lspci riattiva la scheda ati,

ho riprovato a regolare la luminosità col tasto fn sempre col kernel 4.18 e il problema è lo stesso.
ho provato una serie di comandi alt+rsist+r e poi anche ctrl+f5, dopo tanto tempo e una serie di avvertimenti si ferma su utente ma non mi da la possibilità di loggarmi come amministratore, comando su, poi password, ma appeno digito la prima lettera mi dice password incorrect, dopo più tentativi provo con startx, dopo vari messaggi di errore mi dice di aver generato dei log in /home/utente/.local/share/xorg che ti invio, e dopo tanto tempo ancora sembra che si avvii kde, ma c'è solo la freccetta del mouse e schermo nero, per riavviare ho usato la combinazione altgr+rsist+le varie lettere reisub.
scusami se scrivo tanto, vorrei essere più conciso, ma non ci riesco.

mlibero
Allegati
Xorg.2.zip
(6.13 KiB) Scaricato 156 volte
Xorg.1.zip
(6.22 KiB) Scaricato 150 volte
mlibero
Sr. Member
Sr. Member
 
Messaggi: 441
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda mlibero » 20/11/2018, 19:03

altra prova, ho trovato questo post https://ubuntuforums.org/showthread.php?t=2192471 , ho provato a creare il file
/usr/share/X11/xorg.conf.d/20-intel.conf come suggerisce nel kernel 4.14
Section "Device"
Identifier "card0"
Driver "intel"
Option "Backlight" "intel_backlight"
BusID "PCI:0:2:0"
EndSection

al riavvio la regolazione della luminosità non blocca più il sistema, ma il mouse non apre più nè file nè cartelle, però almeno il blocco non è totale e con ctrl+alt+f5 riesco ad uscire da xorg e riavviare.

mlibero
mlibero
Sr. Member
Sr. Member
 
Messaggi: 441
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda s3v » 26/11/2018, 18:27

mlibero ha scritto:a quali log presenti in /var/log ti riferisci, i log che crea sono quelli che ti ho inviato nel primo post, xorg.0.log e xorg.1.log, ce ne sono altri come messages e messages.1, forse ti riferisci a quelli?

Sì, a quelli.
Quando accade il problema, ci dovrebbe essere traccia in uno di questi log.
mlibero ha scritto:nel frattempo ho installato il kernel 4.18 preso da backports, nella speranza di qualche miglioramento, invece accade quello che accadeva anche nelle prove fatte con kalilinux con kernel 4.18

Se il problema non è mai stato segnalato in precedenza e non lo è tuttora, più vai avanti con le versioni del kernel e più scendono le probabilità che qualcosa si sblocchi.
Ciò è dovuto al fatto che la modifica che ha dato origine al tutto, se non corretta, è poi diventata la base per altre modifiche successive. Questo sempre nel caso che il problema non sia stato segnalato da qualche parte; io, dopo numerose ricerche, non ne ho trovato traccia.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5867
Iscritto il: 31/12/2008, 11:54

Re: regolazione luminosità

Messaggioda mlibero » 30/11/2018, 12:21

faccio ancora delle prove con kalilinux-live su usb con una partizione persistence che mantiene tutte le modifiche fatte.
non ci capisco più niente.
intanto ho scoperto che il kernel si avvia di default con la scheda intel attivata e quella discreta disattivata.
il comando lspci | grep -i vga non modifica più niente su tutti e due i sistemi ma...?
i comandi
Per attivare la GPU che è scollegata (ma non le uscite di commutazione):
echo ON > /sys/kernel/debug/vgaswitcheroo/switch

Per connettere la scheda grafica integrata con le uscite:
echo IGD > /sys/kernel/debug/vgaswitcheroo/switch

Per connettere la scheda grafica dedicata con le uscite:
echo DIS > /sys/kernel/debug/vgaswitcheroo/switch

Per disattivare la scheda grafica che è attualmente scollegata:
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

non modificano niente.
poi, al primo avvio kalilinux sembra funzionare bene, ma ai successivi riavvii i problemi si ripresentano.
a differenza di stretch che la regolazione della luminosità blocca completamente il sistema, su kalilinux semplicemente lo rallenta, di molto è vero, ma aspettando un po si riesce a lavorarci.
aprendo i file log messages e messages.1 su terminale, non mi fa vedere tutto il file, ma solo una parte, te li mando lo stesso, ti mando anche i file log di kalilinux, magari può servire.
sono convinto che tutto dipenda da vgaswitcheroo che non spegne o disattiva completamente la scheda discreta, e questo crea un conflitto, tra l'altro, relativamente a quei comandi di vgaswitcheroo, non capisco cosa vuol dire disattivare e scollegare, se dal bios imposto l'avvio con la scheda discreta, per il sistema la scheda intel semplicemente non esiste, è scollegata, lspci non la vede.
intanto, in attesa di una possibile soluzione, sto usando la scheda discreta, per il momento la temperatura è accettabile e tutto il resto funziona bene.

mlibero
Allegati
kalilinux-Xorg.0.zip
(9.16 KiB) Scaricato 130 volte
messages.1.zip
(21.57 KiB) Scaricato 139 volte
messages.zip
(4.98 KiB) Scaricato 156 volte
mlibero
Sr. Member
Sr. Member
 
Messaggi: 441
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda mlibero » 30/11/2018, 12:31

non mi sono accorto di non poter mandare più di tre allegati, ti mando adesso il log messages di kalilinux.

mlibero
Allegati
kalilinux-messages.zip
(97.7 KiB) Scaricato 152 volte
mlibero
Sr. Member
Sr. Member
 
Messaggi: 441
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda mlibero » 06/02/2020, 20:27

riapro questa discussione, rimasta in sospeso sicuramente per mia mancanza, perchè dopo tanto lavoro ho scelto la soluzione più facile, ma non potevo continuare con continui riavvii e cambi di impostazioni del bios.
bene, ho installato buster con kde, il problema rimane.
però, mi è venuto in mente di provare alcune debianlive su usb, una con kde e l'altra con cinnamon, avviate entrambe in modalità switchable, mentre con debianlive+cinnamon la regolazione della luminosità col tasto Fn funziona benissimo senza problemi, con debianlive+kde il sistema si blocca completamente e si riavvia solamente con altgr+rsist+reisub, altra opzione non mi è permessa.
aggiungo che in ambedue non è presente alcuna configurazione di vgaswitcheroo,
cat: /sys/kernel/debug/vgaswitcheroo/switch: File o directory non esistente

quindi il problema non dipende da debian ma da kde.

mlibero
mlibero
Sr. Member
Sr. Member
 
Messaggi: 441
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda Aki » 07/02/2020, 8:29

mlibero ha scritto:[..] ho installato buster con kde, il problema rimane [.] con debianlive+cinnamon la regolazione della luminosità col tasto Fn funziona benissimo senza problemi, con debianlive+kde il sistema si blocca completamente [..]
aggiungo che in ambedue non è presente alcuna configurazione di vgaswitcheroo, [..] quindi il problema non dipende da debian ma da kde.

Ho l'impressione che stai mettendo insieme anomalie diverse: il blocco del sistema grafico ne è una, la regolazione della luminosità un altra. In entrambi i casi, comunque, le anomalie (nei test che riferisci aver effettuato con le live di Debian) sono probabilmente riconducibile alla scheda grafica intel ed alla sua configurazione.
Aki
Global Moderator
Global Moderator
 
Messaggi: 9348
Iscritto il: 27/12/2007, 16:59

Re: regolazione luminosità

Messaggioda mlibero » 07/02/2020, 13:11

scusami ma non capisco, il sistema si blocca solo quando uso il tasto Fn per regolare la luminosità, altre anomalie per il momento non ne riscontro, se il blocco avvenisse solo nella nuova installazione di buster con kde, potrei anche capire, ma parlando di due live con lo stesso sistema, anzi tre perchè ho provato una debianlive con gnome e anche li non c'è alcun blocco, e quando utilizzo il tasto Fn si blocca solo quella con kde, qualche dubbio su kde mi viene.
mlibero
Sr. Member
Sr. Member
 
Messaggi: 441
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda Aki » 07/02/2020, 21:11

mlibero ha scritto:[..]quando utilizzo il tasto Fn si blocca solo quella con kde, qualche dubbio su kde mi viene.

Perdonami, ma nel precedente messaggio avevi indicato che si bloccava quando usavi kde (e non che si bloccava quando usavi kde e simultaneamente provavi a modificare la luminosità). In ogni caso, in Debian Buster, se lo desideri, puoi installare - ad esempio - xfce come ambiente grafico ed avviarlo al posto di kde.
Aki
Global Moderator
Global Moderator
 
Messaggi: 9348
Iscritto il: 27/12/2007, 16:59

Re: regolazione luminosità

Messaggioda mlibero » 08/02/2020, 9:14

si hai ragione, non ho riletto bene tutta la discussione, avevo effettivamente indicato due problemi, ma poichè erano spariti utlilizzando la modalità "discrete" e cioè solo la scheda ati, lo avevo dimenticato.
uno dei due era proprio questo, e cioè che, in modalità "switchable", utilizzando il tasto Fn + tasto sin. o dex. per regolare la luminosità. il sistema si bloccava completamente.
e con le prove fatte con queste live ho scoperto che il problema si verifica solo con kde.
ho pensato di cambiare DE, il fatto è che da quando utilizzo linux come sistema operativo ho sempre utilizzato kde come DE, ha delle funzioni comode che altri non hanno, anche se nel passaggio da stretch a buster ci sono alcune configurazioni che non riesco ancora a fare, in passato ne ho provato altri, mate, xfce4, ma poi sono sempre ritornato a kde, pochi giorni fa ho provato la live con gnome3, ma mi sono perso senza il classico menù laterale.
mi sono iscritto a questo forum https://forum.kde.org/viewforum.php?f=140 per una difficoltà nella configurazione, che poi ho risolto da solo, ma sono passati giorni senza alcuna risposta, e il mio pessimo inglese non aiuta.
intanto continuo ad usare la modalità "discrete" che va bene, anche se mi piacerebbe risolverlo questo problema.
così, ad intuito, non avendo la possibilità di verificarlo, credo che anche l'altro problema segnalato nel post sia da attribuire a kde.
nota positiva: da quando ho questo portatile, ormai datato, ho sempre dovuto usare accorgimenti particolari per convivere con queste due schede, adesso tutto fila liscio, avviata debialive con cinnamon o gnome e penso anche con altri DE, tutto va come dovrebbe andare, tranne che con kde :) .
mlibero
Sr. Member
Sr. Member
 
Messaggi: 441
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda Aki » 08/02/2020, 23:52

mlibero ha scritto:[..] mi piacerebbe risolverlo questo problema [..]

Sei hai ancora kde installato, puoi provare a raccogliere qualche indizio in assenza del quale si possono fare solo supposizioni.

Come tentativo, ad esempio, puoi aprire una finestra di terminale e cercare di catturare i log di eventuali anomalie, con i seguenti comandi impartiti come utente root:
Codice: Seleziona tutto
script log.txt
journalctl -f

Quindi, prova a modificare la luminosità dello schermo e verifica se all'eventuale verificarsi del blocco dello schermo, compaiono messaggi nei log di sistema.

Se il computer si blocca, esegui la sequenza REISUB in modo da effettuare uno shutdown controllato e poter al successivo riavvio verificare il contenuto del file log.txt
Aki
Global Moderator
Global Moderator
 
Messaggi: 9348
Iscritto il: 27/12/2007, 16:59

Re: regolazione luminosità

Messaggioda mlibero » 09/02/2020, 11:28

da impazzire, ti dico passo passo quello che ho fatto.
avvio in modalità switchable
apro il terminale e da root
script log.txt
journalctl -f

mi da una serie di informazioni che però non ho salvato su un file di testo
regolo la luminosità col tasto Fn e il sistema si blocca
riavvio con altgr+rsist reisub
al riavvio apro il terminale
e ripeto le stesse operazioni, questa volta però, prima di regolare la luminosità, provo a cercare il file log.txt, che è vuoto, e a fare una serie di operazioni e il sistema va, poi provo a regolare la luminosità e tutto va bene, il sistema non si blocca.
riavvio e questa volta regolo la luminosità dopo aver fatto una serie di operazioni, senza però aprire il terminale e dare i comandi precedenti, il sistema non si blocca ??? .
che dire?
ti mando un file su cui ho salvato le risposte del comando journalctl -f al primo ed al secondo riavvio.
nel dubbio ho controllato le schede
root@debian:~# lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710/M92 [Mobility Radeon HD 4330/4350/4550]

una cosa che non ho controllato è l'avvio con alimentazione di rete, spero che vada tutto bene, per adesso mi fermo quì.
Allegati
journalctl.tar.gz
(809 Bytes) Scaricato 38 volte
mlibero
Sr. Member
Sr. Member
 
Messaggi: 441
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda mlibero » 09/02/2020, 11:54

scusami, adesso ricontrollando il file di log, mi sono accorto che questo non è vuoto e te lo mando.
Allegati
log.txt
(2.53 KiB) Scaricato 39 volte
mlibero
Sr. Member
Sr. Member
 
Messaggi: 441
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda Aki » 09/02/2020, 17:19

Ciao, I dati che hai raccolto finora purtroppo non sono particolarmente utili. Mi sembra, da quello che descrivi, che il comportamento del computer sia erratico, generalmente indicativo di un malfunzionamento hardware. Potrebbe essere utile raccogliere informazioni tramite il log di sistema, rendendone persistente la registrazione tra un avvio ed il successivo (di default dopo un riavvio il precedente è perso). Questo si può ottenere configurando il file /etc/systemd/journald.conf ponendo (senza # iniziale):
Codice: Seleziona tutto
Storage=persistent
ed impartendo il comando:
Codice: Seleziona tutto
systemctl restart systemd-journald.service
.

In questo modo, dal successivo riavvio del computer, il comando journalctl dovrebbe mostrare ogni volta i log boot precedenti fino allo spegnimento e, quindi, dopo uno spegnimento controllato il contenuto del log di sistema dovrebbe essere preservato.

Quindi, dopo aver fatto questa configurazione, riprovoca un crash e dopo successivo shutdown controllato con REISUB, al riavvio impartirci i seguenti comando come utente root:
Codice: Seleziona tutto
script log.txt
journalctl --no-pager
exit

Il file log.txt dovrebbe contenere il log di sistema del boot corrente e dei precedenti, con gli eventuali errori.
Aki
Global Moderator
Global Moderator
 
Messaggi: 9348
Iscritto il: 27/12/2007, 16:59

PrecedenteProssimo

Torna a X

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti

cron