[RISOLTO] Debian 9.5 bloccato in avvio

Problemi con l'installazione di Debian...

[RISOLTO] Debian 9.5 bloccato in avvio

Messaggioda blackpanther » 11/11/2018, 13:27

Ciao, come anticipato da qualche altra parte qui dentro, sto installando debian 9.5 sul mio pc fisso. Ho optato per KDE e sto reinstallando una distribuzione al posto di un'altra (kubuntu). L'installazione fila liscia, come sempre. Una volta riavviato il sistema però, mi viene richiesto il login ma non va oltre la schermata nera con logo KDE che carica. E rimane così potenzialmente per sempre.

KDE funziona benissimo sul mio fisso, anche se è vecchiotto (quad core intel, 8 gb di ram, gpu nvidia da 2 gb di memoria ddr5), con kubuntu mai avuto nessun tipo di problema (nel limiti di linux :P) e neanche con Debian 8 che ho provato a installare dopo aver constatato che 9.5 non va.

Consigli?
blackpanther
Newbie
Newbie
 
Messaggi: 44
Iscritto il: 04/11/2018, 11:40

Re: dEBIAN 9.5 bloccato in avvio

Messaggioda lablinux » 12/11/2018, 11:43

quad core? Nella precedente discussione parlavi di un "celeron da 2.0 ghz, 4 gb ram".
Su quale pc hai problemi. Riesci, con una live, ad entrare nel sistema e vedere i log? Potresti installare (io di solito lo faccio) un WM leggero (scegli quello che preferisci, ce ne sono tanti xfce, lxde, flwm,...)
Io di solito uso la testing e avere un WM leggero mi permette, in caso di anomalie del DE, di accedre sempre in modalità grafica al sistema.
Linux counter home page #501787
Linux machine #5389505
Avatar utente
lablinux
Hero Member
Hero Member
 
Messaggi: 615
Iscritto il: 03/11/2009, 11:32

Re: dEBIAN 9.5 bloccato in avvio

Messaggioda blackpanther » 18/11/2018, 15:43

lablinux ha scritto:quad core? Nella precedente discussione parlavi di un "celeron da 2.0 ghz, 4 gb ram".
Su quale pc hai problemi. Riesci, con una live, ad entrare nel sistema e vedere i log? Potresti installare (io di solito lo faccio) un WM leggero (scegli quello che preferisci, ce ne sono tanti xfce, lxde, flwm,...)
Io di solito uso la testing e avere un WM leggero mi permette, in caso di anomalie del DE, di accedre sempre in modalità grafica al sistema.


Eh, ho più di un computer. I problemi li ho sul PC fisso, col Q9400 della intel. Sul celeron funziona bene, lo sto usando.

Mi stai dunque chiedendo di pubblicare il log? da live riesco ad accedere. se mi dici dove trovo il log, lo posto qui
blackpanther
Newbie
Newbie
 
Messaggi: 44
Iscritto il: 04/11/2018, 11:40

Re: dEBIAN 9.5 bloccato in avvio

Messaggioda blackpanther » 04/12/2018, 19:12

blackpanther ha scritto:
lablinux ha scritto:quad core? Nella precedente discussione parlavi di un "celeron da 2.0 ghz, 4 gb ram".
Su quale pc hai problemi. Riesci, con una live, ad entrare nel sistema e vedere i log? Potresti installare (io di solito lo faccio) un WM leggero (scegli quello che preferisci, ce ne sono tanti xfce, lxde, flwm,...)
Io di solito uso la testing e avere un WM leggero mi permette, in caso di anomalie del DE, di accedre sempre in modalità grafica al sistema.


Eh, ho più di un computer. I problemi li ho sul PC fisso, col Q9400 della intel. Sul celeron funziona bene, lo sto usando.

Mi stai dunque chiedendo di pubblicare il log? da live riesco ad accedere. se mi dici dove trovo il log, lo posto qui


Devo aggiornare il messaggio; ho provato a installare l'ultima versione di kubuntu e anche questa qua non parte alla stessa maniera. Logo kde o di kubuntu piantato per sempre... Ricordo che Jessie e kubuntu 14 LTS partono senza problemi

Quale log posso postare?
blackpanther
Newbie
Newbie
 
Messaggi: 44
Iscritto il: 04/11/2018, 11:40

Re: Debian 9.5 bloccato in avvio

Messaggioda Aki » 08/12/2018, 3:24

La causa sembra essere la sezione video del server X o del moduli del kernel per il supporto grafico. Ti suggerirei di avviare il sistema in modalità single user, quindi di seguire le istruzioni della guida http://guide.debianizzati.org/index.php/Forzare_il_driver_VESA per configurare di default il driver VESA per il server X. Quindi, installa un altro desktop manager, ad esempio, xfce4. A questo punto, il sistema si dovrebbe avviare con xfce4 senza blocchi e puoi cominciare ad analizzare la situazione con maggiore dettaglio.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8812
Iscritto il: 27/12/2007, 16:59

Re: Debian 9.5 bloccato in avvio

Messaggioda Aki » 02/01/2019, 9:58

@blackpanther: hai aggiornamenti su questa discussione ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8812
Iscritto il: 27/12/2007, 16:59

Re: Debian 9.5 bloccato in avvio

Messaggioda blackpanther » 09/01/2019, 19:30

Ciao, sì li ho. Stavo risolvendo gli altri problemi esposti in altre discussioni.

Purtroppo pare che ci siano problemi che quando ho aperto questo topic non avevo inteso.

In sostanza, non riesco a far partire una distribuzione che sia una. Sia installandola che avviandola da live. Ho provato diversi ambienti (kde, gnome e xfce) ma tutte si piantano poco tempo dopo l'avvio del sistema, che io metta la password utente o meno, si blocca lì.
blackpanther
Newbie
Newbie
 
Messaggi: 44
Iscritto il: 04/11/2018, 11:40

Re: Debian 9.5 bloccato in avvio

Messaggioda Aki » 10/01/2019, 5:12

Prova a consultare quest'altra discussione al fine di poter acquisire log utili ad analizzare il funzionamento del computer. Comunque, quanto riferisci, orienta verso l'ipotesi di un malfunzionamento hardware con blocco di quale componente fondamentale del sistema operativo (ad esempio, a livello di kernel).
Aki
Global Moderator
Global Moderator
 
Messaggi: 8812
Iscritto il: 27/12/2007, 16:59

Re: Debian 9.5 bloccato in avvio

Messaggioda blackpanther » 13/01/2019, 16:57

Grazie. Il problema è che non riesco ad avere nessun accesso utile a qualsivoglia distribuzione linux, installata o live. Potrei aver modificato qualche parametro tra le impostazioni bios e questo crea problemi?

Segnalo che l'unica cosa che ho fatto da quando funzionava debian a quando nessuna distro parte, è stata la sostituzione della vecchia gpu ati con una nvidia nuova.
blackpanther
Newbie
Newbie
 
Messaggi: 44
Iscritto il: 04/11/2018, 11:40

Re: Debian 9.5 bloccato in avvio

Messaggioda Aki » 13/01/2019, 18:02

blackpanther ha scritto:Grazie. Il problema è che non riesco ad avere nessun accesso utile a qualsivoglia distribuzione linux, installata o live. Potrei aver modificato qualche parametro tra le impostazioni bios e questo crea problemi?

Potresti aver attivato il "secure boot" ? Riesci ad arrivare alla schermata del boot loader (grub2) ?

blackpanther ha scritto:Segnalo che l'unica cosa che ho fatto da quando funzionava debian a quando nessuna distro parte, è stata la sostituzione della vecchia gpu ati con una nvidia nuova.

Prova ad avviare in modalità single user (è tra le opzioni del menù di grub2) ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8812
Iscritto il: 27/12/2007, 16:59

Re: Debian bloccato in avvio

Messaggioda blackpanther » 13/01/2019, 18:41

secure boot non ce l'ho, ho bios vero e proprio, non uefi. E neanche single user è tra le opzioni :-\

Comunque ora ho fatto una prova: ho messo la live di kubuntu 14.04 e avviandola ho impostato alcune cose come acpi=off, nomodeset e un'altra che non ricordo e la live si è avviata e funziona.

sta installando la distro, dopodiché lo avvierò e vediamo che succede. proverò a disabilitare le stesse cose ma all'avvio del sistema. Se risolvo la questione, riprovo con debian e a quel punto vi posterò i log.

Ricordami quali log devo caricare qui

EDIT: kubuntu 14.04 si è installato e funziona :o Ma avviando la live con quelle opzioni che ho detto, e avviando l'installazione del sistema da quella stessa live, l'installazione sarà soggetta a questi parametri modificati? o valgono solo per l'utilizzo della sessione live?
blackpanther
Newbie
Newbie
 
Messaggi: 44
Iscritto il: 04/11/2018, 11:40

Re: Debian bloccato in avvio

Messaggioda Aki » 13/01/2019, 21:04

blackpanther ha scritto:secure boot non ce l'ho, ho bios vero e proprio, non uefi. E neanche single user è tra le opzioni :-\

La modalità "single user" nel menù di grub è indicata come "recovery mode" (vedi allegato).

blackpanther ha scritto:EDIT: kubuntu 14.04 si è installato e funziona :o Ma avviando la live con quelle opzioni che ho detto, e avviando l'installazione del sistema da quella stessa live, l'installazione sarà soggetta a questi parametri modificati? o valgono solo per l'utilizzo della sessione live?

Solo per il singolo avvio.
Allegati
grub.png
grub.png (9.4 KiB) Osservato 2900 volte
Aki
Global Moderator
Global Moderator
 
Messaggi: 8812
Iscritto il: 27/12/2007, 16:59

Re: Debian 9.5 bloccato in avvio

Messaggioda blackpanther » 13/01/2019, 22:37

Ah ok allora c'è XD Provato ora e si è piantato lì dove vedi nell'immagine che ho postato

Comunque ora ho reinstallato debian 9.6 e non si avvia; riavviato e impostato nomodeset si è avviato.

che dici di fare?

https://i.imgur.com/yG7JsiR.jpg
Ultima modifica di blackpanther il 13/01/2019, 22:52, modificato 1 volta in totale.
blackpanther
Newbie
Newbie
 
Messaggi: 44
Iscritto il: 04/11/2018, 11:40

Re: Debian 9.5 bloccato in avvio

Messaggioda Aki » 13/01/2019, 22:50

blackpanther ha scritto:Comunque ora ho reinstallato debian 9.6 e non si avvia; riavviato e impostato nomodeset si è avviato.
che dici di fare?

Imposta nomodeset tra i parametri del kernel in grub
Aki
Global Moderator
Global Moderator
 
Messaggi: 8812
Iscritto il: 27/12/2007, 16:59

Re: Debian 9.5 bloccato in avvio

Messaggioda blackpanther » 13/01/2019, 22:53

Aki ha scritto:
blackpanther ha scritto:Comunque ora ho reinstallato debian 9.6 e non si avvia; riavviato e impostato nomodeset si è avviato.
che dici di fare?

Imposta nomodeset tra i parametri del kernel in grub


Sì ma tenerlo in nomodeset? non c'è altro modo per arrivare al nòcciolo del problema?
blackpanther
Newbie
Newbie
 
Messaggi: 44
Iscritto il: 04/11/2018, 11:40

Prossimo

Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti

cron