[RISOLTO] Errore Clamav ExecStartPre /bin/mkdir

La rete, Internet, configurazione di Servizi e tutto ciò che permette la comunicazione tra macchine

[RISOLTO] Errore Clamav ExecStartPre /bin/mkdir

Messaggioda danjde » 23/02/2019, 21:14

Salve amici,
ho da poco installato Clamav 0.100.2+dfsg-0+deb9u1 su Debian 9 e se verifico lo status del servizio mi segnala il servizio attivo ma un processo è in status "exited/Failure"

Codice: Seleziona tutto
Process: 21320 ExecStartPre=/bin/mkdir /run/clamav (code=exited, status=1/FAILURE)


Ho verificato e la directory /run/clamav esiste e al suo interno:

Codice: Seleziona tutto
ls -l /run/clamav/
total 0
srw-rw-rw- 1 clamav clamav 0 feb 22 19:27 clamd.ctl


la directory:

Codice: Seleziona tutto
drwxr-xr-x  2 clamav  root      60 feb 22 19:27 clamav


che si debba portare la directory a proprietario e gruppo root o viceversa a proprietario e gruppo clamav?

apro una segnalazione di bug?

Grazie infinite

Davide
Ultima modifica di danjde il 01/03/2019, 11:00, modificato 1 volta in totale.
cosmogoniA
n o p r o v a r e n o f a r e o n o n f a r e n o n c e p r o v a r e
Avatar utente
danjde
Jr. Member
Jr. Member
 
Messaggi: 64
Iscritto il: 06/09/2016, 11:59
Località: Verona

Re: Errore Clamav ExecStartPre /bin/mkdir

Messaggioda Aki » 24/02/2019, 8:50

Puoi fornire un log completo (dall’avvio del computer) contenente il messaggio di errore che hai sopra riportato ? Non credo sia un bug.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8519
Iscritto il: 27/12/2007, 16:59

Re: Errore Clamav ExecStartPre /bin/mkdir

Messaggioda danjde » 28/02/2019, 18:12

Mi hai dato una buona idea, ossia che potrebbe trattarsi di qualche servizio non allineato in fase di avvio, così ho riavviato la VPS e ora tutto è perfetto:

Codice: Seleziona tutto
● clamav-daemon.service - Clam AntiVirus userspace daemon
   Loaded: loaded (/lib/systemd/system/clamav-daemon.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/clamav-daemon.service.d
           └─extend.conf
   Active: active (running) since Thu 2019-02-28 08:05:49 CET; 9h ago
     Docs: man:clamd(8)
           man:clamd.conf(5)
           https://www.clamav.net/documents/
  Process: 652 ExecStartPre=/bin/chown clamav /run/clamav (code=exited, status=0/SUCCESS)
  Process: 649 ExecStartPre=/bin/mkdir /run/clamav (code=exited, status=0/SUCCESS)
 Main PID: 659 (clamd)
    Tasks: 2 (limit: 4915)
   Memory: 729.0M
      CPU: 1min 21.245s
   CGroup: /system.slice/clamav-daemon.service
           └─659 /usr/sbin/clamd --foreground=true


Ti ringrazio di cuore ;-)

Davide
cosmogoniA
n o p r o v a r e n o f a r e o n o n f a r e n o n c e p r o v a r e
Avatar utente
danjde
Jr. Member
Jr. Member
 
Messaggi: 64
Iscritto il: 06/09/2016, 11:59
Località: Verona

Re: Errore Clamav ExecStartPre /bin/mkdir

Messaggioda Aki » 28/02/2019, 20:14

Felice di esserti stato d'aiuto. Ricordati di contrassegnare la discussione come risolta. Happy Debian & happy hacking.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8519
Iscritto il: 27/12/2007, 16:59


Torna a Network

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti