[RISOLTO] montare partizioni in automatico all'avvio

Problemi con l'installazione di Debian...

[RISOLTO] montare partizioni in automatico all'avvio

Messaggioda boozta » 02/04/2012, 19:16

ciao,

Codice: Seleziona tutto
root@debian:/home/daniele# fdisk -l

Disk /dev/sda: 82.0 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00048b8b

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        9964    80035798+   7  HPFS/NTFS

Disk /dev/sdb: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0002cb45

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1       20429   164089856    7  HPFS/NTFS
/dev/sdb2           20429       23468    24414062+  83  Linux
/dev/sdb3           23468       38914   124065793    5  Extended
/dev/sdb5           23468       29547    48828416   83  Linux
/dev/sdb6           38792       38914      975872   82  Linux swap / Solaris
/dev/sdb7           29547       38792    74254336   83  Linux

Partition table entries are not in disk order

Disk /dev/sdc: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0005fa36

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1      121601   976760001    7  HPFS/NTFS

Disk /dev/sdd: 513 MB, 513802240 bytes
16 heads, 32 sectors/track, 1960 cylinders
Units = cylinders of 512 * 512 = 262144 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2c49c2eb

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1   *           1        1960      501744    6  FAT16
root@debian:/home/daniele#


seguendo una guida per montare in automatico le partizioni all'avvio senza dover inserire la psw ho modificato fstab aggiungendo le ultime 2 righe

Codice: Seleziona tutto
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sdb2 during installation
UUID=fbac0c76-b7e0-424f-993b-6c4a566b64f8 /               ext3    errors=remount-ro 0       1
# /home was on /dev/sdb5 during installation
UUID=1dcc128e-bd6e-4a68-8cb1-362bfee0eb77 /home           ext3    defaults        0       2
# swap was on /dev/sdb6 during installation
UUID=88460d87-49b0-49ee-a18d-4d02d2d56b11 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/scd1       /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/sda1       /media/Win XP   ntfs,user,rw                0       0
/dev/sdc1       /media/Dati     ext3,user,rw                0       0


e poi

Codice: Seleziona tutto
sudo chmod 777 /media/'Win XP'
sudo chmod 777 /media/Dati


ma non le monta, mi dice che solo root può montarle ma se vado in nautilus vado in computer e sull'icona di Dati clicco apri come amministratore restituisce questo errore:

L'elemento selezionato non può essere aperto con i privilegi di amministratore perché non può essere determinata l'applicazione corretta.


che faccio?
Ultima modifica di boozta il 05/04/2012, 8:15, modificato 1 volta in totale.
boozta
Jr. Member
Jr. Member
 
Messaggi: 66
Iscritto il: 25/03/2012, 14:14

Re: montare partizioni in automatico all'avvio

Messaggioda Ombra » 02/04/2012, 20:50

ciao
Codice: Seleziona tutto
/dev/sda1       /media/Win XP   ntfs,user,rw                0       0
/dev/sdc1       /media/Dati     ext3,user,rw                0       0

c'è un errore su tutte e due le righe, il tipo di filesystem va separato rispetto alle opzioni di mount, quindi ad esempio
Codice: Seleziona tutto
/dev/sdc1       /media/Dati     ext3           user,rw                0       0

così dovrebbe funzionare ;)
Ombra
wiki member
wiki member
 
Messaggi: 475
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: montare partizioni in automatico all'avvio

Messaggioda boozta » 02/04/2012, 21:21

purtroppo no.
Codice: Seleziona tutto
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sdb2 during installation
UUID=fbac0c76-b7e0-424f-993b-6c4a566b64f8 /               ext3    errors=remount-ro 0       1
# /home was on /dev/sdb5 during installation
UUID=1dcc128e-bd6e-4a68-8cb1-362bfee0eb77 /home           ext3    defaults        0       2
# swap was on /dev/sdb6 during installation
UUID=88460d87-49b0-49ee-a18d-4d02d2d56b11 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/scd1       /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/sdc1       /media/Dati     ext3           user,rw                0       0


riavvio e...

Codice: Seleziona tutto
Error mounting: mount exited with exit code 1: helper failed with:
mount: mount point /media/Dati does not exist
boozta
Jr. Member
Jr. Member
 
Messaggi: 66
Iscritto il: 25/03/2012, 14:14

Re: montare partizioni in automatico all'avvio

Messaggioda AS » 02/04/2012, 21:27

Prima devi creare la cartella /media/Dati, tu l'hai fatto vero? ;)
Procedura
Codice: Seleziona tutto
# mkdir -v /media/Dati

poi dai
Codice: Seleziona tutto
# blkid

per individuare il tuo disco o partizione, e lo inserisci in /etc/fstab
alla fine dai
Codice: Seleziona tutto
# mount -a -v

e controlli che tutto sia ok.
Se la casa del tuo vicino brucia, la cosa ti riguarda, e parecchio.
Avatar utente
AS
Hero Member
Hero Member
 
Messaggi: 1169
Iscritto il: 01/05/2010, 10:22

Re: montare partizioni in automatico all'avvio

Messaggioda boozta » 02/04/2012, 22:05

AS ha scritto:Prima devi creare la cartella /media/Dati, tu l'hai fatto vero? ;)
Procedura
Codice: Seleziona tutto
# mkdir -v /media/Dati

fatto ma senza -v. fa differenza? la cartella cmq l'ha creata
blkid non è installato e non lo trova nei repo
boozta
Jr. Member
Jr. Member
 
Messaggi: 66
Iscritto il: 25/03/2012, 14:14

Re: montare partizioni in automatico all'avvio

Messaggioda Ombra » 02/04/2012, 22:52

blkid non è installato e non lo trova nei repo

serve un po' di iniziativa nelle ricerche, comunque dovrebbe essere in util-linux
Ombra
wiki member
wiki member
 
Messaggi: 475
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: montare partizioni in automatico all'avvio

Messaggioda AS » 02/04/2012, 23:34

Codice: Seleziona tutto
$ aptitude show libblkid1
Pacchetto: libblkid1                               
Stato: installato
Installato automaticamente: no
Versione: 2.20.1-4
Priorità: richiesto
Sezione: libs
Responsabile: LaMont Jones <lamont@debian.org>
Dimensione pacchetto installato: 250 k
Dipende: libc6 (>= 2.7), libuuid1 (>= 2.16)
Pre-dipende: multiarch-support
Descrizione: libreria di identificativi per dispositivi a blocchi
 La libreria blkid permette ai programmi di sistema come fsck e mount di trovare
 in modo rapido e facile i dispositivi a blocchi attraverso i loro UUID e LABEL.
 Ciò evita agli amministratori di doversi riferire ai file system tramite il
 nome del loro dispositivo (che deve essere noto in anticipo), permettendo
 invece di usare un sistema di attribuzione dei nomi logico.
Homepage: http://userweb.kernel.org/~kzak/util-linux/


Codice: Seleziona tutto
BLKID(8)                     System Administration                    BLKID(8)

NAME
       blkid - locate/print block device attributes

SYNOPSIS
       blkid -L label | -U uuid

       blkid [-dghlv] [-c file] [-w file] [-o format]
             [-s tag] [-t NAME=value] [device ...]

       blkid -p [-O offset] [-S size] [-o format] [-s tag]
                [-n list] [-u list] device ...

       blkid -i [-o format] [-s tag] device ...

DESCRIPTION
       The  blkid  program  is  the command-line interface to working with the
       libblkid(3) library.  It  can  determine  the  type  of  content  (e.g.
       filesystem  or  swap)  that  a  block device holds, and also attributes
       (tokens, NAME=value pairs) from the content  metadata  (e.g.  LABEL  or
       UUID fields).

       blkid  has  two  main forms of operation: either searching for a device
       with a specific NAME=value pair, or displaying NAME=value pairs for one
       or more specified devices.
Se la casa del tuo vicino brucia, la cosa ti riguarda, e parecchio.
Avatar utente
AS
Hero Member
Hero Member
 
Messaggi: 1169
Iscritto il: 01/05/2010, 10:22

Re: montare partizioni in automatico all'avvio

Messaggioda boozta » 03/04/2012, 21:16

Codice: Seleziona tutto
root@debian:/home/daniele# blkid
/dev/sda1: LABEL="Win XP" UUID="14C61620035638F8" TYPE="ntfs"
/dev/sdb1: UUID="CE8059B38059A32F" TYPE="ntfs"
/dev/sdb2: UUID="fbac0c76-b7e0-424f-993b-6c4a566b64f8" TYPE="ext3"
/dev/sdb5: UUID="1dcc128e-bd6e-4a68-8cb1-362bfee0eb77" TYPE="ext3"
/dev/sdb6: UUID="88460d87-49b0-49ee-a18d-4d02d2d56b11" TYPE="swap"
/dev/sdb7: UUID="1558083c-6aa5-43cf-baca-e77b68b652ef" SEC_TYPE="ext2" TYPE="ext3"
/dev/sdc1: LABEL="Dati" UUID="795949C02FB6E393" TYPE="ntfs"
root@debian:/home/daniele#

forse ho capito l'errore, il filesystem sbagliato! mettevo ext3 invece di ntfs...che cojone!
boozta
Jr. Member
Jr. Member
 
Messaggi: 66
Iscritto il: 25/03/2012, 14:14

Re: montare partizioni in automatico all'avvio

Messaggioda AS » 03/04/2012, 22:59

Quindi hai risolto, o no? Se si, metti il tag [risolto] al primo post, altrimenti spiega la sistuazione. :)
Se la casa del tuo vicino brucia, la cosa ti riguarda, e parecchio.
Avatar utente
AS
Hero Member
Hero Member
 
Messaggi: 1169
Iscritto il: 01/05/2010, 10:22

Re: montare partizioni in automatico all'avvio

Messaggioda boozta » 05/04/2012, 8:15

risolto, ma ho dovuto modificare l'etichetta Win XP in Win_XP altrimenti non montava il disco.
Grazie
boozta
Jr. Member
Jr. Member
 
Messaggi: 66
Iscritto il: 25/03/2012, 14:14


Torna a Installazione

Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti