[RISOLTO] Incompatibilità APU Raven Ridge

Discussioni sulla compatibilità dell'Hardware con linux, Drivers, ...

[RISOLTO] Incompatibilità APU Raven Ridge

Messaggioda BubuXP » 09/05/2018, 3:23

Ho fatto l'errore di cambiare il mio caro Intel i3-4160 con un nuovo AMD 2400G.
Appena installato Debian Sid, noto che non riconosce la GPU Vega 11 integrata nel processore, forzando la risoluzione 1024x768 su un monitor full HD.
Ho provato con Ubuntu 18.04 e lì invece sembra funzionare a dovere, nonostante il kernel e mesa siano un po' più indietro con il numero di versione rispetto a Sid.
Noto allora che serve il firmware, ma su Debian questi sono fermi a 9 mesi fa e non c'è ancora quello che serve a questa GPU nei repository ufficiali.
Quindi copio manualmente i file del firmware dove dovrebbero stare (/lib/firmware/amdgpu/) ma ottengo solo un freeze dello schermo durante il boot, eppure il PC sembra reagire ad alcuni tasti, non è un freeze totale.
Ho provato a mettere anche il Liquorix kernel, e anche il 4.17~rc3 presente su experimental, ma niente.

A questo punto non riesco a cogliere cosa abbia Ubuntu che Debian non ha. Domani posterò dei log, al momento non ho la possibilità di farli.

Su internet sembra che nessuno usi questa APU con Debian, a parte un bug aperto nel pacchetto del firmware dove si chiede di aggiornarlo per supportare Raven Ridge.
Ultima modifica di BubuXP il 09/05/2018, 21:09, modificato 2 volte in totale.
Avatar utente
BubuXP
Hero Member
Hero Member
 
Messaggi: 752
Iscritto il: 17/12/2011, 4:20
Località: Sicilia orientale

Re: Incompatibilità APU Raven Ridge

Messaggioda BubuXP » 09/05/2018, 11:00

Ho risolto, il problema sono i parametri di compilazione del kernel, quelli di default di Debian (e anche di Liquorix, che è basato su quello di Debian) non vanno bene. Nonostante sia nel ramo Unstable, credo che per favorire la stabilità del sistema gli sviluppatori di Debian preferiscano disabilitare quelle funzioni sperimentali o ancora non considerate stabili, e di conseguenza sono state disabilitate quelle funzionalità necessarie al riconoscimento della GPU integrata, che essendo recente non può vantare ancora un codice considerato stabile.

Invece di ricompilare il kernel ho preferito installare uno degli ultimi kernel da Ubuntu mainline, che dovrebbe essere un kernel vanilla con un set minimo di patch indispensabili, e senza modificare null'altro (a parte aggiungere il firmware in /lib/firmware/amdgpu/) Debian ha riconosciuto tutto e subito.
Ultima modifica di BubuXP il 09/05/2018, 20:39, modificato 1 volta in totale.
Avatar utente
BubuXP
Hero Member
Hero Member
 
Messaggi: 752
Iscritto il: 17/12/2011, 4:20
Località: Sicilia orientale

Re: Incompatibilità APU Raven Ridge

Messaggioda Aki » 09/05/2018, 19:09

BubuXP ha scritto:erano i parametri di compilazione del kernel. Quelli di default di Debian non vanno bene, tengono disattivate alcune funzioni che probabilmente sono sperimentali e per non inficiare la stabilità del sistema non attivano.
Ho installato un kernel da Ubuntu mainline, senza modificare null'altro (a parte aggiungere il firmware) e ha riconosciuto tutto.

A beneficio di altri utenti, puoi inviare in allegato il file di configurazione del kernel che è risultato funzionante ? Puoi specificare esattamente quale versione del firmware hai installato ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 7804
Iscritto il: 27/12/2007, 16:59

Re: Incompatibilità APU Raven Ridge

Messaggioda BubuXP » 09/05/2018, 21:00

Aki ha scritto:A beneficio di altri utenti, puoi inviare in allegato il file di configurazione del kernel che è risultato funzionante ? Puoi specificare esattamente quale versione del firmware hai installato ?

Oggi pomeriggio stavo modificando il testo del mio messaggio ma proprio quando l'ho inviato il sito è andato offline. L'ho modificato adesso.

In allegato a questo messaggio c'è la configurazione del kernel che sto usando, ma anche le configurazioni dei kernel 4.16.x che si trovano nel sito di Ubuntu mainline (riportato nel secondo messaggio dopo la modifica) funzionano (e probabilmente anche i 4.15.x, kernel precedenti non supportano Raven Ridge).

I firmware li ho linkati sempre nel secondo messaggio dopo la modifica. Bastano solo i file che iniziano con la stringa "raven", ma volendo si può copiare tutto il contenuto della cartella "amdgpu" presente sul git su /lib/firmware/amdgpu/
Allegati
config-4.17.0~rc4.7z
Configurazione del kernel funzionante con Raven Ridge
(44.93 KiB) Scaricato 9 volte
Avatar utente
BubuXP
Hero Member
Hero Member
 
Messaggi: 752
Iscritto il: 17/12/2011, 4:20
Località: Sicilia orientale

Re: [RISOLTO] Incompatibilità APU Raven Ridge

Messaggioda Aki » 10/05/2018, 7:19

Grazie. In ogni caso, mi sembra una piattaforma hardware non ancora ben supportata: https://www.phoronix.com/scan.php?page= ... Mobo-Linux
Aki
Global Moderator
Global Moderator
 
Messaggi: 7804
Iscritto il: 27/12/2007, 16:59

Re: [RISOLTO] Incompatibilità APU Raven Ridge

Messaggioda BubuXP » 10/05/2018, 9:39

Aki ha scritto:Grazie. In ogni caso, mi sembra una piattaforma hardware non ancora ben supportata: https://www.phoronix.com/scan.php?page= ... Mobo-Linux


Ancora è troppo presto per me giudicare, dato che ce l'ho da poco tempo, ma da quando sono riuscito a farla riconoscere non mi ha dato più problemi con un uso normale (solo video, grafica 2D, niente 3D).
Considera anche che l'articolo è di febbraio, e che sono passati quasi tre mesi.

EDIT: Ecco i primi problemi, appena lo schermo va in pausa non si riaccende più, invece se il sistema entra in sospensione non si risveglia più...
Avatar utente
BubuXP
Hero Member
Hero Member
 
Messaggi: 752
Iscritto il: 17/12/2011, 4:20
Località: Sicilia orientale

Re: [RISOLTO] Incompatibilità APU Raven Ridge

Messaggioda BubuXP » 18/07/2018, 9:34

Per informare che da ieri è arrivato il kernel 4.17.6 su unstable e finalmente è stato anche abilitato il supporto a Raven Ridge.
Non è invece stato aggiornato il pacchetto dei firmware non-free, quindi bisogna ancora prelevare manualmente il firmware come descritto nei post precedenti (oppure prelevare il mio pacchetto aggiornato artigianalmente dal "repositorio" in firma).
Avatar utente
BubuXP
Hero Member
Hero Member
 
Messaggi: 752
Iscritto il: 17/12/2011, 4:20
Località: Sicilia orientale


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite