[RISOLTO]Suono sparito dopo aggiornamento del 21Giugno

Audio, Video, Grafica...

[RISOLTO]Suono sparito dopo aggiornamento del 21Giugno

Messaggioda barlafuss » 23/06/2018, 11:05

Visto che ci si lamenta che ci sono pochi interventi, ho pensato di crearmi un problema :-)
A parte gli scherzi, con l'aggiornamento in oggetto non posso piu' scegliere in system-setting(kde) "Built In Audio Analog Stereo", devo usare forzatamente il dispositivo audio "GF108 High Definition Audio Controller Digital Sorround 7.1(HDMI)". Ma cosi' non ho il suono (forse perche' dovrei usare l'uscita digitale non i jack?). Anche lanciando system setting da root, tutte le varie opzioni di dispositivo audio sono in grigio, l'unica selezionabile e' quella HDMI che mi crea problemi. A livello di moduli, ho provato a verificarli con una lista memorizzata a sistema funzionante, ma non noto differenze, tutti i vari moduli del suono sono caricati.
Siccome avevo necessita' di far ripartire il sistema, non ho potuto fare molte altre verifiche, ho caricato con timeshift (a mio giudizio un grande programma ...) l'ultimo back up di sistema funzionante e via. Ora però non vorrei andare incontro allo stesso problema, aggiornando di nuovo. Qui sotto riporto parte del log apt dove si vede i pacchetti aggiornati/installati dall'aggiornamento del 21. Come faccio a capire quale di questi ha causato il problema al dispositivo audio?
Codice: Seleziona tutto
Start-Date: 2018-06-21  16:59:26    Commandline: apt full-upgrade   
Install: libcdio18:amd64 (2.0.0-2, automatic), pkg-config:amd64 (0.29-4+b1, automatic), fluid-soundfont-gm:amd64 (3.1-5.1, automatic), libiso9660-11:amd64 (2.0.0-2, automatic)
Upgrade: libmpv1:amd64 (0.27.2-1, 0.27.2-1+b1), timidity-daemon:amd64 (2.13.2-41, 2.14.0-3), libkf5networkmanagerqt6:amd64 (5.46.0-1, 5.47.0-1), dbus-x11:amd64 (1.12.8-2, 1.12.8-3), libisccfg160:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), libdbus-1-3:amd64 (1.12.8-2, 1.12.8-3), gnupg-utils:amd64 (2.2.7-1, 2.2.8-1), python-samba:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), gpg-wks-client:amd64 (2.2.7-1, 2.2.8-1), libkf5modemmanagerqt6:amd64 (5.46.0-1, 5.47.0-1), oxygen-icon-theme:amd64 (5:5.46.0-1, 5:5.47.0-1), gnupg-l10n:amd64 (2.2.7-1, 2.2.8-1), libwbclient0:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), aspell-gl-minimos:amd64 (0.5-44, 0.5-45), dbus:amd64 (1.12.8-2, 1.12.8-3), libirs160:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), bind9-host:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), speedtest-cli:amd64 (2.0.0-2, 2.0.2-1), libxmmsclient6:amd64 (0.8+dfsg-18.1+b4, 0.8+dfsg-18.1+b5), dnsutils:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), libcdio-cdda2:amd64 (10.2+0.94+2-2+b1, 10.2+0.94+2-2+b2), nano:amd64 (2.9.7-1, 2.9.8-1), gpg-wks-server:amd64 (2.2.7-1, 2.2.8-1), gpg:amd64 (2.2.7-1, 2.2.8-1), libisc169:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), mime-support:amd64 (3.60, 3.61), gcc-6-base:amd64 (6.4.0-17, 6.4.0-18), dirmngr:amd64 (2.2.7-1, 2.2.8-1), samba-libs:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), libcdio-paranoia2:amd64 (10.2+0.94+2-2+b1, 10.2+0.94+2-2+b2), ppp:amd64 (2.4.7-2+2, 2.4.7-2+3), libisc-export169:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), samba-common:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), libgcrypt20:amd64 (1.8.2-2, 1.8.3-1), liblwres160:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), python-pkg-resources:amd64 (39.1.0-1, 39.2.0-1), gpgv:amd64 (2.2.7-1, 2.2.8-1), libkf5prison5:amd64 (5.46.0-1, 5.47.0-1), python3-pkg-resources:amd64 (39.1.0-1, 39.2.0-1), wpasupplicant:amd64 (2:2.6-16, 2:2.6-17), libsmbclient:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), smbclient:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), samba-common-bin:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), libdns-export1100:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), breeze-icon-theme:amd64 (4:5.46.0-1, 4:5.47.0-1), gnupg2:amd64 (2.2.7-1, 2.2.8-1), dictionaries-common:amd64 (1.27.4, 1.27.6), timidity:amd64 (2.13.2-41+b1, 2.14.0-3), libisccc160:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), dbus-user-session:amd64 (1.12.8-2, 1.12.8-3), libpsm2-2:amd64 (10.3-37-1, 10.3.58-1), libbind9-160:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), gnupg:amd64 (2.2.7-1, 2.2.8-1), libdns1100:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), vcdimager:amd64 (0.7.24+dfsg-1, 2.0.1+dfsg-2), libjs-sphinxdoc:amd64 (1.7.4-1, 1.7.5-3), gpg-agent:amd64 (2.2.7-1, 2.2.8-1), libvcdinfo0:amd64 (0.7.24+dfsg-1, 2.0.1+dfsg-2), gpgconf:amd64 (2.2.7-1, 2.2.8-1), mplayer:amd64 (2:1.3.0-8, 2:1.3.0-8+b1), gpgsm:amd64 (2.2.7-1, 2.2.8-1), gstreamer1.0-plugins-ugly:amd64 (1.14.1-1, 1.14.1-1+b1), libdatrie1:amd64 (0.2.11-1, 0.2.12-1), libdatrie-dev:amd64 (0.2.11-1, 0.2.12-1)
End-Date: 2018-06-21  17:01:17   Start-Date: 2018-06-21  17:04:35
Commandline: apt autoremove
Remove: libcdio17:amd64 (1.0.0-2+b1), libiso9660-10:amd64 (1.0.0-2+b1)
End-Date: 2018-06-21  17:04:37

Qui alcune info sul mio sistema :
Codice: Seleziona tutto
Host: debian Kernel: 4.16.0-2-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.12.5   Distro: Debian GNU/Linux buster/sid
Audio:     Card-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel
Card-2: NVIDIA GF108 High Definition Audio driver: snd_hda_intel  Sound Server: ALSA v: k4.16.0-2-amd64
Ultima modifica di barlafuss il 24/06/2018, 11:10, modificato 1 volta in totale.
barlafuss
Full Member
Full Member
 
Messaggi: 110
Iscritto il: 21/03/2007, 13:03

Re: Suono sparito dopo aggiornamento del 21Giugno

Messaggioda Aki » 23/06/2018, 13:16

Puoi inviare il log generto con lo script cicato in calce al mio messaggio in rosso ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8099
Iscritto il: 27/12/2007, 16:59

Re: Suono sparito dopo aggiornamento del 21Giugno

Messaggioda barlafuss » 23/06/2018, 14:49

Eccolo.
Allegati
log_23Jun_154353.xz
(71.22 KiB) Scaricato 46 volte
barlafuss
Full Member
Full Member
 
Messaggi: 110
Iscritto il: 21/03/2007, 13:03

Re: Suono sparito dopo aggiornamento del 21Giugno

Messaggioda barlafuss » 23/06/2018, 15:21

barlafuss
Full Member
Full Member
 
Messaggi: 110
Iscritto il: 21/03/2007, 13:03


Re: Suono sparito dopo aggiornamento del 21Giugno

Messaggioda barlafuss » 24/06/2018, 10:41

Confermo che anche il mio utente e' nel gruppo audio.
L'ho eliminato, come suggerito. Faccio un reboot, se l'audio funziona, aggiorno, reboot e verifico.

Per ora grazie mille
barlafuss
Full Member
Full Member
 
Messaggi: 110
Iscritto il: 21/03/2007, 13:03

Re: Suono sparito dopo aggiornamento del 21Giugno

Messaggioda barlafuss » 24/06/2018, 11:10

Allora, non avendo letto bene il suggerimento, ho rimosso solo il mio utente dal gruppo audio, ma cosi' non funziona ancora.
Rimuovendo *anche* timidity, al successivo boot l'audio ritorna a funzionare.

Grazie ancora per la dritta
barlafuss
Full Member
Full Member
 
Messaggi: 110
Iscritto il: 21/03/2007, 13:03

Re: [RISOLTO]Suono sparito dopo aggiornamento del 21Giugno

Messaggioda Aki » 24/06/2018, 13:30

Felice di esserti stato utile. Happy Debian & happy hacking
Aki
Global Moderator
Global Moderator
 
Messaggi: 8099
Iscritto il: 27/12/2007, 16:59

Re: [RISOLTO]Suono sparito dopo aggiornamento del 21Giugno

Messaggioda Stemby » 04/07/2018, 1:28

Ringrazio anch'io: la soluzione (meglio, la toppa) presentata in lista ha risolto anche il mio problema.

TL;DR:
Codice: Seleziona tutto
# aptitude purge timidity-daemon

(su Debian testing).

Nient'altro.

Ciao!
Stemby
wiki member
wiki member
 
Messaggi: 1428
Iscritto il: 11/04/2009, 15:47
Località: Missaglia (LC)


Torna a Multimedia

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti