Wrong magic byte, come risolvere?

Discussioni relative alle distribuzioni derivate da Debian: Ubuntu, Mint, Kanotix, Knoppix, Clonezilla, etc.

Wrong magic byte, come risolvere?

Messaggioda Palo_Pd » 27/07/2018, 15:44

Salve, ho alcuni problemi con un software "Bit4id Pin Manager" ad ogni aggiornamento mi trovo sempre la seguente string:
Codice: Seleziona tutto
Elaborazione dei trigger per libc-bin (2.23-0ubuntu10)...
/sbin/ldconfig.real: /usr/lib/libbit4opki.so.conf is not an ELF file - it has the wrong magic bytes at the start.

In rete non ho trovo molto che mi aiutasse. Avete qualche suggerimento.

Grazie
Palo_Pd
Sr. Member
Sr. Member
 
Messaggi: 436
Iscritto il: 07/03/2006, 7:56

Re: Wrong magic byte, come risolvere?

Messaggioda mark » 27/07/2018, 16:08

ai tempi avevo seguito la guida e funzionava
http://guide.debianizzati.org/index.php/Carta_Nazionale/Regionale_dei_Servizi

se si tratta di altro dovresti essere piu specifico e descrivere meglio
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 652
Iscritto il: 10/01/2007, 16:53

Re: Wrong magic byte, come risolvere?

Messaggioda Palo_Pd » 28/07/2018, 22:24

Grazie, ci darò un'occhiata e spero che funzioni!
Palo_Pd
Sr. Member
Sr. Member
 
Messaggi: 436
Iscritto il: 07/03/2006, 7:56

Re: Wrong magic byte, come risolvere?

Messaggioda Palo_Pd » 30/07/2018, 8:49

mark ha scritto:ai tempi avevo seguito la guida e funzionava
...

Una curiosità, la guida parla del lettore EMV Smartcard Reader, mentre io ho un lettore , identificato dal lsusb come
"Bus 002 Device 006: ID 058f:9540 Alcor Micro Corp. AU9540 Smartcard Reader" che non è lo stesso.
Palo_Pd
Sr. Member
Sr. Member
 
Messaggi: 436
Iscritto il: 07/03/2006, 7:56

Re: Wrong magic byte, come risolvere?

Messaggioda mark » 30/07/2018, 20:27

ecco qui, il mio è un modello che ha già qualche anno
Codice: Seleziona tutto
lsusb |grep Card
Bus 004 Device 002: ID 072f:9000 Advanced Card Systems, Ltd ACR38 AC1038-based Smart Card Reader
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 652
Iscritto il: 10/01/2007, 16:53

Re: Wrong magic byte, come risolvere?

Messaggioda Aki » 30/07/2018, 22:28

intervento di moderazione: discussione trasferita da "Indice ‹ Generale ‹ Generale" a "Indice ‹ Generale ‹ Derivate da Debian" essendo la discussione relativa a Ubuntu con file apparentemente non facenti parte di pacchetti distribuiti ufficialmente dal progetto Debian.
Palo_Pd ha scritto:Salve, ho alcuni problemi con un software "Bit4id Pin Manager" ad ogni aggiornamento mi trovo sempre la seguente string:
Codice: Seleziona tutto
Elaborazione dei trigger per libc-bin (2.23-0ubuntu10)...
/sbin/ldconfig.real: /usr/lib/libbit4opki.so.conf is not an ELF file - it has the wrong magic bytes at the start.


L'errore che viene segnalato è relativo ad un non meglio specificato /sbin/ldconfig.real (programma che non esiste in debian) e che ha assonanze con ldconfig, ovvero il configuratore del linker dinamico del sistema operativo. Dal messaggio che hai riportato, sembrerebbe che nella tua installazione (di ubuntu ?) si sia pasticciato, per cui il linker cerca di utilizzare un file (/usr/lib/libbit4opki.so.conf) che non è una libreria dinamica, ma un file di configurazione ed, infatti, il linker lo riconosce come un file non in formato ELF (ELF sta per "Executable and linkable format" ed è - anche - il formato binario delle librerie dinamiche): da qui l'errore. Per far scomparire l'errore, devi verificare la configurazione del linker dinamico ed eventualmente eliminare o spostare i file che non sono librerie dinamiche.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8103
Iscritto il: 27/12/2007, 16:59

Re: Wrong magic byte, come risolvere?

Messaggioda Aki » 15/08/2018, 10:53

@Palo_Pd: potresti, quando possibile, dare un riscontro ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8103
Iscritto il: 27/12/2007, 16:59

Re: Wrong magic byte, come risolvere?

Messaggioda Palo_Pd » 14/10/2018, 23:48

Scusate, ma ho avuito alcuni problemi e non mi è stato possibile rispondere prima. Appena libero cercherò di darvi riscontro...ah, Aki, il sistema è Mint.
Palo_Pd
Sr. Member
Sr. Member
 
Messaggi: 436
Iscritto il: 07/03/2006, 7:56


Torna a Derivate da Debian

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti