Firefox supercity e plugin flashplayer

Discussioni relative a Debian e Linux

Firefox supercity e plugin flashplayer

Messaggioda KOMAD » 14/09/2018, 9:02

Salve a tutti. Da qualche giorno è stata cambiata la versione di firefox e da quel momento non riesco più ad aprire la pagina del gioco di facebook "supercity" (viene visualizzato il caricamento fino al 100% del gioco e rimane li inchiodato).
Ho pensato che potrebbe trattarsi del solito problema legato al plugin adobe. Mi sono scaricato la nuova versione (il pacchetto tar.gz version 31.0.0.108 dal sito ufficiale adobe.) Ho provveduto a copiare manualmente il pacchetto libflashplayer.so nella dir. /usr/lib/mozilla/plugins. Purtroppo non funziona. Chiedo aiuto.
ps. versione debian 9 stabile.
KOMAD
Jr. Member
Jr. Member
 
Messaggi: 68
Iscritto il: 20/02/2011, 23:00

Re: Firefox supercity e plugin flashplayer

Messaggioda Selky » 15/09/2018, 16:53

Ciao,
prova vedere nella finestra del plugin (about:addons) che versione ti da di flash. Se è quella vecchia, ti basta cancellare il file pluginreg.dat dal tuo profilo. Si ricreerà aggiornato al successivo avvio del browser.

Non uso le nuove versioni e al momento non so darti maggiori indicazioni.

P.S.
Durante l'aggiornamento in Debian si viene avvisati di qualcosa o no? La nuova versione è totalmente diversa e porta diversi cambiamenti non di poco conto.
Motivo per cui ho bloccato firefox.
Selky
wiki member
wiki member
 
Messaggi: 1418
Iscritto il: 30/12/2011, 1:00

Re: Firefox supercity e plugin flashplayer

Messaggioda KOMAD » 15/09/2018, 20:24

Selky ha scritto:.... nella finestra del plugin (about:addons) che versione ti da di flash.

Io ho La Shockwave Flash 31.0.0.108......che mi sembra quella nuova....
Selky ha scritto:.Se è quella vecchia, ti basta cancellare il file pluginreg.dat dal tuo profilo. .
Da dove dovrei cancellarlo? io ho provato a cancellare tutta la cartella .mozilla ma alla fine non succede nulla....

Ps. eventualmente come faccio a tornare alla vecchia versione di firefox?
KOMAD
Jr. Member
Jr. Member
 
Messaggi: 68
Iscritto il: 20/02/2011, 23:00

Re: Firefox supercity e plugin flashplayer

Messaggioda Selky » 16/09/2018, 16:49

KOMAD ha scritto:Io ho La Shockwave Flash 31.0.0.108......che mi sembra quella nuova....
Sì è la nuova versione del plugin Flash.
KOMAD ha scritto:
Selky ha scritto:.Se è quella vecchia, ti basta cancellare il file pluginreg.dat dal tuo profilo. .
Da dove dovrei cancellarlo? io ho provato a cancellare tutta la cartella .mozilla ma alla fine non succede nulla....
Non dovevi cancellare tutto il profilo, così facendo se non hai un backup di questo, perdi tutte le tue configurazioni, segnalibiri, ecc...
Nella cartella del tuo profilo dovevi cancellare solo il file che ti ho evidenziato.

KOMAD ha scritto:Ps. eventualmente come faccio a tornare alla vecchia versione di firefox?
Quando ho bisogno di una vecchia versione utilizzo questo http://snapshot.debian.org/
Nel tuo caso per Firefox 52 (versione esr precedente alla v.60), scegliendo quella adatta al tuo sistema (32-64bit) o altro.
http://snapshot.debian.org/package/fire ... 2.9.0esr-1
Questa per la lingua italiana: http://snapshot.debian.org/package/fire ... 2.9.0esr-1

La nuova versione di Firefox (v.60) è parecchio diversa e bisogna ricordarsi di creare un backup del proprio profilo prima di procedere con l'aggiornamento (questo se non ricordo male dalla versione 55 del browser).

Purtroppo al momento nei repo Debian il plugin "freshplayerplugin" (utile per usufruire del plugin Pepper Flash Player su Firefox) non è compatibile con le nuove versioni di Firefox. Altrimenti potevi provare...
Selky
wiki member
wiki member
 
Messaggi: 1418
Iscritto il: 30/12/2011, 1:00

Re: Firefox supercity e plugin flashplayer

Messaggioda KOMAD » 18/09/2018, 22:27

.....Sto provando ad effettuare il dowgrade. Purtroppo ho problemi con le dipendenze ed anche se effettuo: dpkg -i *.deb mi dice che ho versioni di dipendenze più aggiornate. Provo a lanciare : apt-get install -f ed immancabilmente mi reinstalla la versione più aggiornata.....
Per caso devo cambiare completamente i repo? mettendo quindi:
Codice: Seleziona tutto
https://snapshot.debian.org/archive/debian/20091004T111800Z/ lenny main
https://snapshot.debian.org/archive/debian-security/20091004T121501Z/ lenny/updates main

.....Devo anche sostituire lenny con stretch ?
KOMAD
Jr. Member
Jr. Member
 
Messaggi: 68
Iscritto il: 20/02/2011, 23:00

Re: Firefox supercity e plugin flashplayer

Messaggioda Selky » 19/09/2018, 13:13

Ciao, colpa mia che ho dato per scontato alcuni punti.

1) rimuovi firefox-esr
io sono solita usare
Codice: Seleziona tutto
apt-get remove --purge nome_pacchetto

2) scarichi i file deb che ti ho indicato.
3) installi manualmente i deb
4) per evitare che con un upgrade ti si aggiorni la versione, blocchi firefox-esr col pinning.

P.S.
Sono su stretch e il tutto funziona senza intoppi. Ho anche provato a disabilitare temporaneamente il pinning per provare la nuova v.60 per poi tornare alla mia versione solita di Firefox-esr.
Selky
wiki member
wiki member
 
Messaggi: 1418
Iscritto il: 30/12/2011, 1:00

Re: Firefox supercity e plugin flashplayer

Messaggioda KOMAD » 19/09/2018, 22:22

.....Ripeto, i file .deb scaricati non si possono installare manualmente con dpkg in quanto ci sono problemi con le dipendenze. Manca qualche passaggio.
Inoltre apt-mark old version_nome_pacchetto è possibile effetturlo solo dopo l'installazione del pacchetto interessato......
KOMAD
Jr. Member
Jr. Member
 
Messaggi: 68
Iscritto il: 20/02/2011, 23:00

Re: Firefox supercity e plugin flashplayer

Messaggioda KOMAD » 19/09/2018, 22:26

......Per questo motivo credo che bisogna configurare nuovi repo (come quelli elencati sopra).
KOMAD
Jr. Member
Jr. Member
 
Messaggi: 68
Iscritto il: 20/02/2011, 23:00

Re: Firefox supercity e plugin flashplayer

Messaggioda Selky » 20/09/2018, 0:43

Premetto...
Sono su stretch, rifiuto le nuove versioni del browser Mozilla ma ogni volta che ne esce una nuova, tento lo stesso per togliermi lo sfizio e verificare di persona in caso di interventi, come ora. La procedura che ti ho postato è quella che applico di continuo.
KOMAD ha scritto:.....Ripeto, i file .deb scaricati non si possono installare manualmente con dpkg in quanto ci sono problemi con le dipendenze. Manca qualche passaggio.
E io ribadisco che si possono installare tranquillamente, fatto non so quante volte senza problemi proprio per firefox-esr. L'ultima volta dopo essere intervenuta la prima volta in questo thread.

Il punto è che se non posti l'ouptut di qualcosa (quali sono le dipendenze mancanti?), è difficile provare ad aiutarti.
Se durante l'installazione non ti viene suggerito nulla, scompatta il deb per leggere nel file "control" quali sono le dipendenze richieste e vedi se le hai o meno disponibili sul tuo sistema, in caso contrario le devi installare.

I
KOMAD ha scritto:noltre apt-mark old version_nome_pacchetto è possibile effetturlo solo dopo l'installazione del pacchetto interessato......
Chi ha parlato di
Codice: Seleziona tutto
apt-mark old version_nome_pacchetto
? Non ho assolutamente citato tale comando e non ha nulla a che fare con ciò che ti ho scritto. Ho parlato di pinning.

Fino a qualche giorno fa la v.52 di firefox-esr era disponibile per stretch, è impossibile che tutto ad un tratto non sia più installabile.
Selky
wiki member
wiki member
 
Messaggi: 1418
Iscritto il: 30/12/2011, 1:00

Re: Firefox supercity e plugin flashplayer

Messaggioda KOMAD » 21/09/2018, 7:46

Posto i messaggi di errore:
Codice: Seleziona tutto
dpkg -i firefox-esr_52.9.0esr-1_amd64.deb firefox-esr-l10n-hsb_52.9.0esr-1_all.deb
(Lettura del database... 211740 file e directory attualmente installati.)
Preparativi per estrarre firefox-esr_52.9.0esr-1_amd64.deb...
Viene lasciato "deviazione di /usr/bin/firefox in /usr/bin/firefox.real da firefox-esr"
Estrazione di firefox-esr (52.9.0esr-1) su (52.9.0esr-1)...
Preparativi per estrarre firefox-esr-l10n-hsb_52.9.0esr-1_all.deb...
Estrazione di firefox-esr-l10n-hsb (52.9.0esr-1) su (52.9.0esr-1)...
dpkg: problemi con le dipendenze impediscono la configurazione di firefox-esr:
 firefox-esr dipende da libevent-2.1-6 (>= 2.1.8-stable); comunque:
  Il pacchetto libevent-2.1-6 non è installato.
 firefox-esr dipende da libhunspell-1.6-0; comunque:
  Il pacchetto libhunspell-1.6-0 non è installato.
 firefox-esr dipende da libnss3 (>= 2:3.28); comunque:
  La versione di libnss3:amd64 nel sistema è 2:3.26.2-1.1+deb9u1.
 firefox-esr dipende da zlib1g (>= 1:1.2.11.dfsg); comunque:
  La versione di zlib1g:amd64 nel sistema è 1:1.2.8.dfsg-5.

dpkg: errore nell'elaborare il pacchetto firefox-esr (--install):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di firefox-esr-l10n-hsb:
 firefox-esr-l10n-hsb dipende da firefox-esr (>= 52.9.0esr-1); comunque:
  Il pacchetto firefox-esr non è ancora configurato.
 firefox-esr-l10n-hsb dipende da firefox-esr (<< 52.9.0esr-1.1~); comunque:
  Il pacchetto firefox-esr non è ancora configurato.

dpkg: errore nell'elaborare il pacchetto firefox-esr-l10n-hsb (--install):
 problemi con le dipendenze - lasciato non configurato
Elaborazione dei trigger per mime-support (3.60)...
Elaborazione dei trigger per gnome-menus (3.13.3-9)...
Elaborazione dei trigger per desktop-file-utils (0.23-1)...
Elaborazione dei trigger per hicolor-icon-theme (0.15-1)...
Elaborazione dei trigger per man-db (2.7.6.1-2)...
Si sono verificati degli errori nell'elaborazione:
 firefox-esr
 firefox-esr-l10n-hsb

Ho provato anche a scaricare a mano le dipendenze e questo è il risultato:
Codice: Seleziona tutto
/home/gianluca9# apt-get install firefox-esr_52.9.0esr-1_amd64.deb firefox-esr-l10n-hsb_52.9.0esr-1_all.deb libevent-2.1-6 libhunspell-1.6-0 libhunspell-1.6-0 libnss3 zlib1g
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Il pacchetto libevent-2.1-6 non ha versioni disponibili, ma è nominato da un altro
pacchetto. Questo potrebbe indicare che il pacchetto è mancante, obsoleto
oppure è disponibile solo all'interno di un'altra sorgente

Il pacchetto libhunspell-1.6-0 non ha versioni disponibili, ma è nominato da un altro
pacchetto. Questo potrebbe indicare che il pacchetto è mancante, obsoleto
oppure è disponibile solo all'interno di un'altra sorgente

E: Impossibile trovare il pacchetto firefox-esr_52.9.0esr-1_amd64.deb
E: Impossibile trovare alcun pacchetto tramite il glob "firefox-esr_52.9.0esr-1_amd64.deb"
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "firefox-esr_52.9.0esr-1_amd64.deb"
E: Impossibile trovare il pacchetto firefox-esr-l10n-hsb_52.9.0esr-1_all.deb
E: Impossibile trovare alcun pacchetto tramite il glob "firefox-esr-l10n-hsb_52.9.0esr-1_all.deb"
E: Impossibile trovare alcun pacchetto tramite l'espressione regolare "firefox-esr-l10n-hsb_52.9.0esr-1_all.deb"
E: Il pacchetto "libevent-2.1-6" non ha candidati da installare
E: Il pacchetto "libhunspell-1.6-0" non ha candidati da installare
E: Il pacchetto "libhunspell-1.6-0" non ha candidati da installare

e anche:
Codice: Seleziona tutto
/home/gianluca9# apt-get install libevent-2.1-6 libhunspell-1.6-0 libhunspell-1.6-0 libnss3 zlib1g
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Il pacchetto libevent-2.1-6 non ha versioni disponibili, ma è nominato da un altro
pacchetto. Questo potrebbe indicare che il pacchetto è mancante, obsoleto
oppure è disponibile solo all'interno di un'altra sorgente

Il pacchetto libhunspell-1.6-0 non ha versioni disponibili, ma è nominato da un altro
pacchetto. Questo potrebbe indicare che il pacchetto è mancante, obsoleto
oppure è disponibile solo all'interno di un'altra sorgente

E: Il pacchetto "libevent-2.1-6" non ha candidati da installare
E: Il pacchetto "libhunspell-1.6-0" non ha candidati da installare
E: Il pacchetto "libhunspell-1.6-0" non ha candidati da installare

.....Forse dovrei provare a scaricare a mano (senza apt) le dipendenze..... però non riesco a trovarle
KOMAD
Jr. Member
Jr. Member
 
Messaggi: 68
Iscritto il: 20/02/2011, 23:00

Re: Firefox supercity e plugin flashplayer

Messaggioda Selky » 23/09/2018, 13:13

Ciao, ti sta dicendo di installare delle dipendenze con versioni presenti nella testing Buster.
Di solito dopo il dpkg, si utilizza un
Codice: Seleziona tutto
# apt-get install -f
per provare a sistemare le dipendenze.
Hai sistemato il pinning del browser?

Prova a creare il log di APT tramite questo script http://guide.debianizzati.org/index.php ... i_al_forum
e allegalo come file compresso non .txt.
Così vediamo se c'è qualcosa a monte che interferisce e le impostazioni che hai dato.


P.S.
la lingua del browser che stai installando è serbo non italiano, è una tua scelta o ti sei confuso?
Selky
wiki member
wiki member
 
Messaggi: 1418
Iscritto il: 30/12/2011, 1:00


Torna a Generale

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite