regolazione luminosità

Discussioni relative all'ambiente grafico X (Xfree e XOrg)

regolazione luminosità

Messaggioda mlibero » 12/11/2018, 15:44

ciao,
ho un acer 4810tg (ormai datato ma che funziona bene) con doppia scheda grafica, uso stretch con kde.
questa doppia scheda mi aveva già dato dei problemi con jessie aggiornata da wheezy con cui ho convissuto, ma adesso con stretch se ne sono aggiunti altri.

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710/M92 [Mobility Radeon HD 4330/4350/4550] (rev ff)

vgaswitcheroo disabilita la scheda ati sia alimentato da batteria che da corrente

cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS-Audio: :Off:0000:01:00.1
1:DIS: :DynOff:0000:01:00.0
2:IGD:+:Pwr:0000:00:02.0

1- all'avvio alcune volte lo schermo è nero e devo riavviare con ctrl+f5 e poi due volte ctrl+canc, ed al riavvio a volte non cambia niente e devo ripetere l'operazione.
2- sempre all'avvio ho schermo nero e solo la fraccetta del mouse, ctrl+canc e appaiono le icone per il riavvio o spegnimento e quelle funzionano e riavvio.
3- se utilizzo il tasto Fn per diminuire o aumentare la luminosità, la luminosità si regola, ma il sistema si blocca sull'ultima schermata e non va più niente tranne il movimento del mouse e devo spegnere col tasto d'accensione.
ho disinstallato powerdevil e non ho alcun programma di risparmio energetico.
penso che ci sia una impostazione predefinita nel bios perchè se avvio con alimentazione di rete la luminosità è al massimo, con batteria invece è al minimo.
credo che questi problemi dipendano tutti dalla scheda intel, infatti se dal bios imposto come predefinita la scheda ati va tutto bene e riesco a regolare la luminosità col tasto Fn, ci riesco anche fino alla schermata di grub, poi però quando il sistema si avvia si ripresenta il problema.
allego i file xorg.0.log e xorg.1.log.

mlibero
Allegati
Xorg.1.zip
(4.04 KiB) Scaricato 14 volte
Xorg.0.zip
(7.95 KiB) Scaricato 16 volte
mlibero
Sr. Member
Sr. Member
 
Messaggi: 417
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda s3v » 12/11/2018, 18:26

Affinché qualcuno possa aiutarti devi fornire maggiori informazioni. A tal proposito ti invito ad analizzare l'output generato tramite questo script.
mlibero ha scritto:vgaswitcheroo disabilita la scheda ati sia alimentato da batteria che da corrente

Altra informazione utile è sapere da dove hai preso quel programma e spiegare quale scheda grafica vuoi usare.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5589
Iscritto il: 31/12/2008, 11:54

Re: regolazione luminosità

Messaggioda mlibero » 12/11/2018, 20:04

allego lo script che mi è stato chiesto, spero di aver fatto tutto bene.
per quello che riguarda la scelta della scheda, con wheezy e poi con jessie dovevo usare una procedura con vgaswithcheroo per escludere la scheda ati, ho installato stretch da cd per cambio HD, quindi non aggiornata da jessie e non ho dovuto fare niente, ho verificato con
cat /sys/kernel/debug/vgaswitcheroo/switch
ed ho visto che la scheda ati era esclusa.
vorrei usare la scheda intel.

mlibero
Allegati
log_12nov_194632.xz
(39.2 KiB) Scaricato 17 volte
mlibero
Sr. Member
Sr. Member
 
Messaggi: 417
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda s3v » 12/11/2018, 22:41

Dal log che hai postato salta all'occhio questo:
Codice: Seleziona tutto
-- Logs begin at Mon 2018-11-12 19:39:21 CET, end at Mon 2018-11-12 19:47:02 CET. --
nov 12 19:39:21 debian kernel: Your BIOS is broken; DMAR reported at address 0!
                               BIOS vendor: INSYDE; Ver: V2.31; Product Version: V2.31

da cui sono arrivato qui:
...
There are some systems currently known to be potentially affected by this issue. For all of those except the HP xw4600 Workstation and the Dell Precision M6400, all of the following conditions must be true before you hit the bug:

You must be using the 32-bit edition of Fedora 12
You must have no memory beyond the 4GB address area (practically speaking, this means you must have around 2.5GB of physical RAM or less)
Virtualization features (VT-d) must be disabled in the BIOS


If any of the above is not the case, you should not encounter this issue. If you think you may be suffering from this issue, look for a kernel log message including something similar to:

Your BIOS is broken; DMAR reported at address fed10000 returns all ones!

or:

Your BIOS is broken; DMAR reported at address zero!
...

qui e qui:
...
same warning messages for my HP-DC7800 , CentOS 6.2 (2.6.32-279.el6.x86_64 #1 SMP)
but it disappears after I switch on the virturalization option in BIOS
(get into BIOS
Security > System Security, and enable
Virtualization Technology (VTx)and Virtualization Technology Directed I/O (VTd)
After reboot, warning messages disappear.
...

Inoltre la scheda integrata non sembra essere in funzione neanche se viene impostata come predefinita:
Codice: Seleziona tutto
...
nov 12 19:39:21 debian kernel: DMAR: Disabling IOMMU for graphics on this chipset
...


Domanda: nel tuo BIOS è abilitata la virtualizzazione? Nel caso non fosse abilitata, puoi abilitarla e riallegare il log? Sarebbero utili anche foto delle tue pagine di configurazione del BIOS.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5589
Iscritto il: 31/12/2008, 11:54

Re: regolazione luminosità

Messaggioda mlibero » 13/11/2018, 12:32

nel bios non ho trovato alcuna voce che riguarda la virtualizzazione, per quello che riguarda la scheda grafica mi da solo due opzioni, discreta o switchable, che vuol dire che posso solo escludere la scheda intel, con switchable il bios si autoregola, con alimentazione da rete attiva la scheda ati, con batteria quella intel.
non metto in dubbio i risultati dello script, posso però dirti che se imposta dal bios "discrete", cioè la scheda ati, le prestazioni sono diverse che con switchable, il computer la temperatura del computer è molto alta e non si verificano i problemi che ho descritto.
scusami, non so come mandare le foto del bios, non sono il massimo ed ho cercato di lavorarci un po per renderle meno pesanti, ma il file zippato di sei foto è di 4.3 MiB

mlibero
mlibero
Sr. Member
Sr. Member
 
Messaggi: 417
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda mlibero » 13/11/2018, 17:45

non so se funzionerà, è la prima volta che faccio quest'operazione, ho trovato che si possono inviare immagine ai forum con potimg.cc, questi sono i link che mi da:

Immagine
Immagine
Immagine
Immagine
Immagine
Immagine

mlibero
mlibero
Sr. Member
Sr. Member
 
Messaggi: 417
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda s3v » 13/11/2018, 18:46

Purtroppo, come avevi anticipato tu, non c'è quella opzione nel tuo BIOS, quindi quel messaggio di errore è dovuto a qualcos'altro.
Dal log io non vedo che viene caricato il driver Intel (i915) quindi viene usata la scheda discreta. Ma quel log lo hai generato con l'opzione "switchable" o "discrete"? Puoi allegare cortesemente il log generato con l'altra opzione?
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5589
Iscritto il: 31/12/2008, 11:54

Re: regolazione luminosità

Messaggioda mlibero » 13/11/2018, 20:04

il log l'ho generato con l'opzione switchable, uso solo quella perchè impostando discrete dal bios il portatile si surriscalda e molto.
alcune riflessioni
con l'opzione switchable, il sistema(prima dell'avvio di stretch) si comporta in modo differente se sotto alimentazione da corrente o da batteria e si autoregola immediatamente, se stacco la corrente lo schermo riduce la luminosità, quindi attiva la scheda integrata, se attacco la corrente la luminosità aumenta e quindi attiva la scheda ati.
con windows (ho windows 7 che non uso mai se non eccezionalmente) avviene lo stesso, tra l'altro la cosa non mi va bene perchè vorrei avere la possibilità di escludere la scheda ati anche sotto alimentazione e neanche con windows questo è possibile.
quello che osservo con stretch, dico osservo perchè non ho le competenze per altro, è che le prestazioni sono da scheda integrata, ma c'è qualcosa che manca al sistema per farla funzionare bene, i problemi 1 e 2 che ho descritto nel primo post avvengono saltuariamente, mentre quello con la regolazione della luminosità sempre.
tra l'altro non mi spiego come mai, fino a jessie, dove hanno messo nel kernel vgaswitcheroo che prima non c'era e bisognava installarlo, dovevo modificare dei file, crearne di nuovi e modificare fstab, da quello che mi ricordo, con la nuova installazione di stretch non ho dovuto fare niente, mi sono ritrovato con le stesse impostazioni di prima, almeno a giudicare dal risultato del comando
cat /sys/kernel/debug/vgaswitcheroo/switch
ho avviato con l'opzione discrete dal bios e generato il log che allego, il portatile funziona benissimo, e la regolazione della luminosità anche, terrei questa impostazione se non fosse per la temperatura alta che in estate aumenterebbe ancora.

mlibero
Allegati
log_13nov_192757.xz
(37.38 KiB) Scaricato 15 volte
mlibero
Sr. Member
Sr. Member
 
Messaggi: 417
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda s3v » 14/11/2018, 17:22

Dal log che hai fornito io vedo un:
Codice: Seleziona tutto
LoadModule: "radeon"

in entrambe le configurazioni. Non so da che dipenda, ma mi sono fatto l'idea che a causa di problemi del BIOS, la scheda integrata non venga utilizzata correttamente oppure per niente utilizzata.
È possibile che quando il sistema prova ad utilizzarla, tutto vada in crash e che tu sia costretto a forzare il riavvio?
Per quanto riguarda le prestazioni, è possibile che il degrado che tu attribuisci al cambio di scheda, sia in realtà dovuto ad altri fattori?
Comunque:
1) Puoi cortesemente riallegare il log in questi due casi?
1a) Aggiungi
Codice: Seleziona tutto
intel-iommu=off

alla riga che inizia con "GRUB_CMDLINE_LINUX_DEFAULT" nel file "/etc/default/grub". Ad esempio:
Codice: Seleziona tutto
GRUB_CMDLINE_LINUX_DEFAULT="intel-iommu=off"

e poi un:
Codice: Seleziona tutto
# update-grub

per rendere effettive le modifiche.
1b) Stessa cosa ma con:
Codice: Seleziona tutto
intel_iommu=igfx_off

Se non ti faccio perdere troppo tempo, puoi farlo per entrambe le configurazioni?
2) Il pacchetto "xserver-xorg-video-ati" lo hai installato tu?

Grazie.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5589
Iscritto il: 31/12/2008, 11:54

Re: regolazione luminosità

Messaggioda mlibero » 14/11/2018, 20:07

non mi fai perdere tempo, anzi, convivo con questi problemi da tanto tempo che se si riescono a risolvere per me è un grande favore.
1) Puoi cortesemente riallegare il log in questi due casi?

scusami per log intendi quello generato in /var/log oppure il log generato dallo script?
2) Il pacchetto "xserver-xorg-video-ati" lo hai installato tu?

si, tutte le installazioni le ho fatte da CD minimale e poi ho installato i vari programmi che mi servivano, compreso xorg.
comunque, proprio perchè voglio arrivare in fondo, qualcosa si comincia a capire, su un forum di ubuntu ho trovato:
da Ubuntu 14.04 in avanti, di base il sistema utilizza automaticamente solo la scheda integrata (IGP), mentre quella dedicata va attivata manualmente (solo per sistemi Intel/AMD o AMD/AMD con driver open source Radeon)

presumo che sia lo stesso per debian, dal che si spiega il perchè con stretch non ho dovuto configurare witcheroo.

mlibero
mlibero
Sr. Member
Sr. Member
 
Messaggi: 417
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda s3v » 14/11/2018, 20:32

mlibero ha scritto:scusami per log intendi quello generato in /var/log oppure il log generato dallo script?

Quelli dello script.
mlibero ha scritto:si, tutte le installazioni le ho fatte da CD minimale e poi ho installato i vari programmi che mi servivano, compreso xorg.

Allora puoi rimuoverlo visto che le scheda viene gestita dal driver fornito da "xserver-xorg-video-radeon".
mlibero ha scritto:presumo che sia lo stesso per debian, dal che si spiega il perchè con stretch non ho dovuto configurare witcheroo.

Sì, vga_switcheroo è stato incluso da tempo come modulo del kernel.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5589
Iscritto il: 31/12/2008, 11:54

Re: regolazione luminosità

Messaggioda mlibero » 14/11/2018, 23:07

ho fatto quello che mi hai chiesto e allego i log, dopo upgrade-grub nel dubbio ho riavviato.
intanto faccio delle prove.
ho kalilinux, debian derivata, su pennetta usb con una partizione persistence che mantiene le modifiche fatte.
a parte il fatto che è molto lenta, la regolazione della luminosità va bene e così ho provato a verificare delle cose
all'avvio la situazione è questa
Codice: Seleziona tutto
cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS: :DynOff:0000:01:00.0
1:IGD:+:Pwr:0000:00:02.0
2:DIS-Audio: :DynOff:0000:01:00.1

ho generato il log dallo script e te lo mando, magari può aiutare.
cosa vuol dire
Codice: Seleziona tutto
Allora puoi rimuoverlo visto che le scheda viene gestita dal driver fornito da "xserver-xorg-video-radeon"

devo rimuovere xorg?

mlibero
Allegati
kalilinux_log_14Nov_204105.xz
(51.3 KiB) Scaricato 12 volte
log_14nov_222144.xz
(39.08 KiB) Scaricato 14 volte
log_14nov_222231.xz
(39.09 KiB) Scaricato 13 volte
mlibero
Sr. Member
Sr. Member
 
Messaggi: 417
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda mlibero » 15/11/2018, 10:49

come non detto, anche su kalilinux stesso problema, se utilizzo il tasto fn per regolare la luminosità il sistema rallenta al limite del blocco, stretch si blocca del tutto.
ho trovato su questo sito una spiegazione, anche se un po datata, https://www.lffl.org/2012/11/amd-hybrid ... punto.html , magari può servire.

mlibero
mlibero
Sr. Member
Sr. Member
 
Messaggi: 417
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda s3v » 15/11/2018, 17:56

mlibero ha scritto:devo rimuovere xorg?

No, solo il pacchetto "xserver-xorg-video-ati".

Dai log che hai inviato pare che nulla sia cambiato, quindi strada sbagliata.
Ho notato solo ora che in "Xorg.0.log":
Codice: Seleziona tutto
[    23.533] (II) modeset(0): [DRI2] Setup complete
[    23.533] (II) modeset(0): [DRI2]   DRI driver: i965
[    23.533] (II) modeset(0): [DRI2]   VDPAU driver: i965
[    23.533] (--) RandR disabled
[    23.545] (II) SELinux: Disabled on system
[    23.557] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    23.557] (II) AIGLX: enabled GLX_ARB_create_context
[    23.557] (II) AIGLX: enabled GLX_ARB_create_context_profile
[    23.557] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
[    23.557] (II) AIGLX: enabled GLX_INTEL_swap_event
[    23.557] (II) AIGLX: enabled GLX_SGI_swap_control
[    23.557] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[    23.557] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[    23.557] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
[    23.557] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    23.558] (II) AIGLX: Loaded and initialized i965

Quindi la scheda intel viene vista. Abbiamo perso solo tempo e consumato spazio sull'hard disk del server, errore mio, scusa.

Cambiando approccio ho trovato [ur=https://ubuntuforums.org/showthread.php?t=1620063l]questo[/url] che sembra proprio il tuo problema.
Puoi provare a rimuovere quanto aggiunto in "/etc/default/grub" e sostituirlo prima con questo:
Codice: Seleziona tutto
GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux""

e poi con:
Codice: Seleziona tutto
GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux acpi_backlight=vendor""

? In entrambi i casi serve successivamente il consueto "update-grub2" + riavvio.
Non so sinceramente se tali parametri siano ancora validi con il kernel che attualmente stai utilizzando o solo per kernel più datati che necessitavano di tali workaround per risolvere determinati problemi.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5589
Iscritto il: 31/12/2008, 11:54

Re: regolazione luminosità

Messaggioda mlibero » 15/11/2018, 19:31

niente, mi dispiace, tutto come prima.
ti mando i log con le modifiche su grub.
volevo rimuovere xserver-xorg-video-ati ma apt mi fa rimuovere anche
apt-get -s remove xserver-xorg-video-ati
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno RIMOSSI:
xserver-xorg-video-all xserver-xorg-video-ati

va bene e continuo?
Allegati
log_15nov_184655.xz
(39.09 KiB) Scaricato 11 volte
log_15nov_181428.xz
(39.23 KiB) Scaricato 10 volte
mlibero
Sr. Member
Sr. Member
 
Messaggi: 417
Iscritto il: 23/09/2007, 17:54

Prossimo

Torna a X

Chi c’è in linea

Visitano il forum: Google [Bot] e 1 ospite