regolazione luminosità

Discussioni relative all'ambiente grafico X (Xfree e XOrg)

Re: regolazione luminosità

Messaggioda s3v » 19/11/2018, 21:37

mlibero ha scritto:volevo rimuovere xserver-xorg-video-ati ma apt mi fa rimuovere anche
apt-get -s remove xserver-xorg-video-ati
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno RIMOSSI:
xserver-xorg-video-all xserver-xorg-video-ati

va bene e continuo?

Sì, il pacchetto "xserver-xorg-video-all" è in realtà un metapacchetto per cui serve solo per richiamare tutte le sue dipendenze.
L'unica accortezza è quella di marcare come "manual" i pacchetti che ti verranno proposti per la disinstallazione automatica (autoremove) da apt; nella guida è comunque spiegato come fare.

Visto che anche questa strada è un buco nell'acqua, rimuovi le modifiche fatte a "/etc/default/grub" (e consueto "update-grub").
Nei log di sistema (quelli che si trovano in "/var/log") che appare quando si verifica il blocco del sistema alla pressione dei tasti per la regolazione della luminosità?
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5589
Iscritto il: 31/12/2008, 11:54

Re: regolazione luminosità

Messaggioda mlibero » 20/11/2018, 17:35

ciao,
non so da dove cominciare, una domanda
Nei log di sistema (quelli che si trovano in "/var/log") che appare quando si verifica il blocco del sistema alla pressione dei tasti per la regolazione della luminosità?

a quali log presenti in /var/log ti riferisci, i log che crea sono quelli che ti ho inviato nel primo post, xorg.0.log e xorg.1.log, ce ne sono altri come messages e messages.1, forse ti riferisci a quelli?
nel frattempo ho installato il kernel 4.18 preso da backports, nella speranza di qualche miglioramento, invece accade quello che accadeva anche nelle prove fatte con kalilinux con kernel 4.18
kernel 4.18

cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS-Audio: DynOff:0000:01:00.1
1:IGD:+:Pwr:0000:00:02.0
2:DIS: DynOff:0000:01:00.0

lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710/M92 [Mobility Radeon HD 4330/4350/4550]

cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS-Audio: DynOff:0000:01:00.1
1:IGD:+:Pwr:0000:00:02.0
2:DIS: DynPwr:0000:01:00.0

echo OFF > cat /sys/kernel/debug/vgaswitcheroo/switch

cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS-Audio: DynOff:0000:01:00.1
1:IGD:+:Pwr:0000:00:02.0
2:DIS: DynOff:0000:01:00.0

il comando lspci riattiva la scheda ati,

ho riprovato a regolare la luminosità col tasto fn sempre col kernel 4.18 e il problema è lo stesso.
ho provato una serie di comandi alt+rsist+r e poi anche ctrl+f5, dopo tanto tempo e una serie di avvertimenti si ferma su utente ma non mi da la possibilità di loggarmi come amministratore, comando su, poi password, ma appeno digito la prima lettera mi dice password incorrect, dopo più tentativi provo con startx, dopo vari messaggi di errore mi dice di aver generato dei log in /home/utente/.local/share/xorg che ti invio, e dopo tanto tempo ancora sembra che si avvii kde, ma c'è solo la freccetta del mouse e schermo nero, per riavviare ho usato la combinazione altgr+rsist+le varie lettere reisub.
scusami se scrivo tanto, vorrei essere più conciso, ma non ci riesco.

mlibero
Allegati
Xorg.2.zip
(6.13 KiB) Scaricato 13 volte
Xorg.1.zip
(6.22 KiB) Scaricato 13 volte
mlibero
Sr. Member
Sr. Member
 
Messaggi: 417
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda mlibero » 20/11/2018, 19:03

altra prova, ho trovato questo post https://ubuntuforums.org/showthread.php?t=2192471 , ho provato a creare il file
/usr/share/X11/xorg.conf.d/20-intel.conf come suggerisce nel kernel 4.14
Section "Device"
Identifier "card0"
Driver "intel"
Option "Backlight" "intel_backlight"
BusID "PCI:0:2:0"
EndSection

al riavvio la regolazione della luminosità non blocca più il sistema, ma il mouse non apre più nè file nè cartelle, però almeno il blocco non è totale e con ctrl+alt+f5 riesco ad uscire da xorg e riavviare.

mlibero
mlibero
Sr. Member
Sr. Member
 
Messaggi: 417
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda s3v » 26/11/2018, 18:27

mlibero ha scritto:a quali log presenti in /var/log ti riferisci, i log che crea sono quelli che ti ho inviato nel primo post, xorg.0.log e xorg.1.log, ce ne sono altri come messages e messages.1, forse ti riferisci a quelli?

Sì, a quelli.
Quando accade il problema, ci dovrebbe essere traccia in uno di questi log.
mlibero ha scritto:nel frattempo ho installato il kernel 4.18 preso da backports, nella speranza di qualche miglioramento, invece accade quello che accadeva anche nelle prove fatte con kalilinux con kernel 4.18

Se il problema non è mai stato segnalato in precedenza e non lo è tuttora, più vai avanti con le versioni del kernel e più scendono le probabilità che qualcosa si sblocchi.
Ciò è dovuto al fatto che la modifica che ha dato origine al tutto, se non corretta, è poi diventata la base per altre modifiche successive. Questo sempre nel caso che il problema non sia stato segnalato da qualche parte; io, dopo numerose ricerche, non ne ho trovato traccia.
Avatar utente
s3v
Global Moderator
Global Moderator
 
Messaggi: 5589
Iscritto il: 31/12/2008, 11:54

Re: regolazione luminosità

Messaggioda mlibero » 30/11/2018, 12:21

faccio ancora delle prove con kalilinux-live su usb con una partizione persistence che mantiene tutte le modifiche fatte.
non ci capisco più niente.
intanto ho scoperto che il kernel si avvia di default con la scheda intel attivata e quella discreta disattivata.
il comando lspci | grep -i vga non modifica più niente su tutti e due i sistemi ma...?
i comandi
Per attivare la GPU che è scollegata (ma non le uscite di commutazione):
echo ON > /sys/kernel/debug/vgaswitcheroo/switch

Per connettere la scheda grafica integrata con le uscite:
echo IGD > /sys/kernel/debug/vgaswitcheroo/switch

Per connettere la scheda grafica dedicata con le uscite:
echo DIS > /sys/kernel/debug/vgaswitcheroo/switch

Per disattivare la scheda grafica che è attualmente scollegata:
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

non modificano niente.
poi, al primo avvio kalilinux sembra funzionare bene, ma ai successivi riavvii i problemi si ripresentano.
a differenza di stretch che la regolazione della luminosità blocca completamente il sistema, su kalilinux semplicemente lo rallenta, di molto è vero, ma aspettando un po si riesce a lavorarci.
aprendo i file log messages e messages.1 su terminale, non mi fa vedere tutto il file, ma solo una parte, te li mando lo stesso, ti mando anche i file log di kalilinux, magari può servire.
sono convinto che tutto dipenda da vgaswitcheroo che non spegne o disattiva completamente la scheda discreta, e questo crea un conflitto, tra l'altro, relativamente a quei comandi di vgaswitcheroo, non capisco cosa vuol dire disattivare e scollegare, se dal bios imposto l'avvio con la scheda discreta, per il sistema la scheda intel semplicemente non esiste, è scollegata, lspci non la vede.
intanto, in attesa di una possibile soluzione, sto usando la scheda discreta, per il momento la temperatura è accettabile e tutto il resto funziona bene.

mlibero
Allegati
kalilinux-Xorg.0.zip
(9.16 KiB) Scaricato 13 volte
messages.1.zip
(21.57 KiB) Scaricato 12 volte
messages.zip
(4.98 KiB) Scaricato 14 volte
mlibero
Sr. Member
Sr. Member
 
Messaggi: 417
Iscritto il: 23/09/2007, 17:54

Re: regolazione luminosità

Messaggioda mlibero » 30/11/2018, 12:31

non mi sono accorto di non poter mandare più di tre allegati, ti mando adesso il log messages di kalilinux.

mlibero
Allegati
kalilinux-messages.zip
(97.7 KiB) Scaricato 12 volte
mlibero
Sr. Member
Sr. Member
 
Messaggi: 417
Iscritto il: 23/09/2007, 17:54

Precedente

Torna a X

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron