Amd ryzen 2500u Gpu Drivers

Discussioni relative all'ambiente grafico X (Xfree e XOrg)

Amd ryzen 2500u Gpu Drivers

Messaggioda Governator » 19/03/2019, 14:57

Ciao a tutti i debianizzati!
Non riesco ad abilitare l'accelerazione hardware sul mio portatile (dell latitude 5495) con cpu-gpu (integrata) come da oggetto. La Scheda video integrata dovrebbe essere una vega 10. Quando accedo a cinnamon mi dice che la modalità è in rendering softwarre, la cpu infatti sta mediamente più alta in hidle (attorno al 20 %) e non riesco ad utilizzare il monitor esterno (non viene rilevato). Qualcuno sa suggerirmi come procedere per installare i driver video per questa scherda che è integrata? Ho cercato a destra ed a manca ma per ora nulla ancora di risolto. Ho installato anche un test phoronix-test-suite_6.8.0_all che dovrebbe andare fluido quando tutto funzionerà a dovere. Sul sito di amd non c'è traccia di driver per debian/linux.
Spero come sempre in un grosso vostro aiuto! In passato ho sempre risolto!

Grazie!
Help!!! :'(
Governator
Sr. Member
Sr. Member
 
Messaggi: 314
Iscritto il: 27/06/2008, 19:30

Re: Amd ryzen 2500u Gpu Drivers

Messaggioda Governator » 19/03/2019, 15:22

Ho provato a seguire anche questa guida purtroppo senza risultati.

I seguenti pacchetti hanno dipendenze non soddisfatte:
amdgpu-lib32 : Dipende: libdrm2-amdgpu:i386 (= 1:2.4.82-511655)
Dipende: libdrm-amdgpu-amdgpu1:i386 (= 1:2.4.82-511655)
Dipende: libllvm5.0-amdgpu:i386 (= 1:5.0-511655)
Dipende: libwayland-amdgpu-client0:i386 (= 1.14.90-511655)
Dipende: libwayland-amdgpu-server0:i386 (= 1.14.90-511655)
Dipende: libxatracker2-amdgpu:i386 (= 1:17.2.4-511655)
Dipende: libgbm1-amdgpu:i386 (= 1:17.2.4-511655)
Dipende: libegl1-amdgpu-mesa:i386 (= 1:17.2.4-511655)
Dipende: libegl1-amdgpu-mesa-drivers:i386 (= 1:17.2.4-511655)
Dipende: libwayland-amdgpu-egl1-mesa:i386 (= 1:17.2.4-511655)
Dipende: libgles1-amdgpu-mesa:i386 (= 1:17.2.4-511655)
Dipende: libgles2-amdgpu-mesa:i386 (= 1:17.2.4-511655)
Dipende: libglapi-amdgpu-mesa:i386 (= 1:17.2.4-511655)
Dipende: libgl1-amdgpu-mesa-glx:i386 (= 1:17.2.4-511655)
Dipende: libgl1-amdgpu-mesa-dri:i386 (= 1:17.2.4-511655)
Dipende: libosmesa6-amdgpu:i386 (= 1:17.2.4-511655)
Dipende: mesa-amdgpu-vdpau-drivers:i386 (= 1:17.2.4-511655)
amdgpu-pro-lib32 : Dipende: libgl1-amdgpu-pro-glx:i386 (= 17.50-511655)
Dipende: libegl1-amdgpu-pro:i386 (= 17.50-511655)
Dipende: libgles2-amdgpu-pro:i386 (= 17.50-511655)
Dipende: libgl1-amdgpu-pro-dri:i386 (= 17.50-511655)
Dipende: libgbm1-amdgpu-pro:i386 (= 17.50-511655)
vulkan-amdgpu-pro:i386 : Dipende: libc6:i386 (>= 2.17) ma non è installabile
Dipende: libgcc1:i386 (>= 1:4.2) ma non è installabile
Dipende: libstdc++6:i386 (>= 4.6) ma non è installabile
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.
Governator
Sr. Member
Sr. Member
 
Messaggi: 314
Iscritto il: 27/06/2008, 19:30

Re: Amd ryzen 2500u Gpu Drivers

Messaggioda Aki » 19/03/2019, 22:04

Ciao,

Nei messaggi precedenti non hai indicato il riferimento alla guida specifica che hai citato.

Premetto che non ho esperienza diretta per l’hardware da te citato, ma suggerirei l’upgrade da Debian Stretch a Debian Buster (prossima Debian Stabile) e l’installazione del pacchetto https://packages.debian.org/buster/xserver-xorg-video-amdgpu e sue dipendenze, compreso il firmware specifico per la scheda grafica.
Aki
Global Moderator
Global Moderator
 
Messaggi: 8613
Iscritto il: 27/12/2007, 16:59

Re: Amd ryzen 2500u Gpu Drivers

Messaggioda Aki » 24/03/2019, 16:38

@Governator: puoi aggiornare la discussione ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 8613
Iscritto il: 27/12/2007, 16:59


Torna a X

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti