Imac problemi xorg e scheda video

Discussioni sulla compatibilità dell'Hardware con linux, Drivers, ...

Imac problemi xorg e scheda video

Messaggioda Alkatron » 03/05/2020, 21:27

Ho installato debian su un Imac, pero parte solo in modalita testo, ho dovuto modificare il grub aggiungendo le opzioni
Codice: Seleziona tutto
nomodeset 3
Senza queste opzioni parte, riesco a fare il login via ssh da un altro computer ma lo schermo suo e bloccato

Queste le specifiche del computer
lshw.txt
(23.98 KiB) Scaricato 31 volte

Se poi provo a lanciare startx si rifuta e questo e il log
Xorg.0.log
(13.93 KiB) Scaricato 20 volte

Sicuramente e un problema di scheda video, pero su internet i vari driver xorg-video-ecc che tutti consigliano li ho gia, quindi non saprei come procedere.
Grazie in anticipo :)
Alkatron
Jr. Member
Jr. Member
 
Messaggi: 88
Iscritto il: 30/06/2010, 13:49

Re: Imac problemi xorg e scheda video

Messaggioda mark » 04/05/2020, 9:58

la tua scheda video è questa
Codice: Seleziona tutto
RV530/M56-P [Mobility Radeon X1600]

l'errore più significativo mi sembra questo
Codice: Seleziona tutto
(EE) Screen 0 deleted because of no matching config section.

quindi dovresti verificare la configurazione di xorg in
Codice: Seleziona tutto
/etc/X11/xorg.conf
 e/o
/etc/X11/xorg.conf.d
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 776
Iscritto il: 10/01/2007, 16:53

Re: Imac problemi xorg e scheda video

Messaggioda Juva » 04/05/2020, 12:36

Alcuni anni fa ho preparato una guida per problemi simili, ma su Mac con processore PPC e non Intel come il tuo.
Prova a dare un'occhiata, magari ti è utile.
http://guide.debianizzati.org/index.php ... PC_G3_e_G5
Guarda di cosa si ciba chi vorrebbe nutrire gli altri.
Juva
Full Member
Full Member
 
Messaggi: 209
Iscritto il: 19/07/2010, 12:50

Re: Imac problemi xorg e scheda video

Messaggioda Rudi » 04/05/2020, 12:44

Codice: Seleziona tutto
[   300.504] (EE) open /dev/dri/card0: No such file or directory

Gia visto in passato questo errore, probabilmente ti manca il firmware della scheda video.
Controlla e nel caso installa firmware-linux-nonfree
Rudi
Full Member
Full Member
 
Messaggi: 184
Iscritto il: 12/11/2005, 6:14

Re: Imac problemi xorg e scheda video

Messaggioda Alkatron » 04/05/2020, 18:39

Ecco allego
xorg.conf.txt
(2.42 KiB) Scaricato 18 volte

Ho levato i parametri dal grub
Codice: Seleziona tutto
modeset 3
per fare un avvio normale
Aggiungo anche il log di sistema
msgs.txt
(73.03 KiB) Scaricato 26 volte

e quello di xorg
xorg.0.log
(14.84 KiB) Scaricato 20 volte


@Rudi: li ho gia installati
@Juva: non ho lo schermo spento solo che si blocca

Grazie a tutti
Alkatron
Jr. Member
Jr. Member
 
Messaggi: 88
Iscritto il: 30/06/2010, 13:49

Re: Imac problemi xorg e scheda video

Messaggioda Aki » 04/05/2020, 19:26

Hai provato a disabilitare il boot EFI (ammesso che sia possibile) ? Vedi https://bugs.freedesktop.org/show_bug.cgi?id=26891
Aki
Global Moderator
Global Moderator
 
Messaggi: 9348
Iscritto il: 27/12/2007, 16:59

Re: Imac problemi xorg e scheda video

Messaggioda mark » 04/05/2020, 21:40

la tua scheda dovrebbe essere supportata dal driver radeon
radeon - ATI/AMD RADEON video driver

quindi sostituirei in xorg.conf
Codice: Seleziona tutto
Driver "amdgpu"

con
Codice: Seleziona tutto
Driver "radeon"   
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 776
Iscritto il: 10/01/2007, 16:53

Re: Imac problemi xorg e scheda video

Messaggioda Alkatron » 05/05/2020, 20:34

Ho sostituito amdgpu con radeon, lo schermo rimane bloccato ma il log cambia leggermente
xorg.log.txt
(11.35 KiB) Scaricato 30 volte


P.S.
Non so se puo essere utile come informazione, ma risco cmq a collegarmi sia via ssh che via vnc senza problemi
Alkatron
Jr. Member
Jr. Member
 
Messaggi: 88
Iscritto il: 30/06/2010, 13:49

Re: Imac problemi xorg e scheda video

Messaggioda mark » 05/05/2020, 21:46

devi avviare senza le opzioni
Codice: Seleziona tutto
nomodeset 3

per il resto mi sembra che la scheda sia riconosciuta da xorg come
Codice: Seleziona tutto
ATI Mobility Radeon X1600
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 776
Iscritto il: 10/01/2007, 16:53

Re: Imac problemi xorg e scheda video

Messaggioda Alkatron » 05/05/2020, 22:08

Gia avevo rimosso le opzioni nel log precedente
Alkatron
Jr. Member
Jr. Member
 
Messaggi: 88
Iscritto il: 30/06/2010, 13:49

Re: Imac problemi xorg e scheda video

Messaggioda mark » 06/05/2020, 9:35

ok, allora personalmente come prima cosa proverei a cambiare kernel, quello che stai usando è il predefinito? in ogni caso proverei a fare un downgrade ad un kernel della serie 4.9

se anche questo fallisce proverei con il driver vesa, quindi in xorg.conf:
Codice: Seleziona tutto
Driver "vesa"
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 776
Iscritto il: 10/01/2007, 16:53

Re: Imac problemi xorg e scheda video

Messaggioda Aki » 07/05/2020, 10:29

Aki ha scritto:Hai provato a disabilitare il boot EFI (ammesso che sia possibile) ? Vedi https://bugs.freedesktop.org/show_bug.cgi?id=26891

@Alkatron:
se può essere utile a meglio orientarti, dai log inviati risulta che la scheda video non è correttamente inizializzata dal kernel con il kernel module "radeon":
Codice: Seleziona tutto
May  4 19:13:15 debian kernel: [    0.000000] Linux version 4.19.0-8-686-pae (debian-kernel@lists.debian.org) (gcc version 8.3.0 (Debian 8.3.0-6)) #1 SMP Debian 4.19.98-1+deb10u1 (2020-04-27)
[..]
May  4 19:13:15 debian kernel: [    6.167372] [drm] initializing kernel modesetting (RV530 0x1002:0x71C5 0x106B:0x0080 0x00).
May  4 19:13:15 debian kernel: [    6.167423] radeon 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xa2a2
May  4 19:13:15 debian kernel: [    6.167450] radeon 0000:01:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0x2222
May  4 19:13:15 debian kernel: [    6.167549] [drm] radeon: finishing device.
[..]
May  4 19:13:15 debian kernel: [    6.167562] [drm] radeon: cp finalized
May  4 19:13:15 debian kernel: [    6.168075] radeon: probe of 0000:01:00.0 failed with error -22

Come vedi, il modulo radeon fallisce nell'inizializzazione della scheda grafica RV530/M56-P [Mobility Radeon X1600], con segnalazioni anche relative al riconoscimento delle ROM della scheda, il che fa supporre che l'inizializzazione della scheda grafica sia incompleta da parte del firmware del computer. Nel bug report che ti ho segnalato ci sono informazioni interessanti in tal senso, anche se non riferite esattamente alla tua stessa scheda grafica.

Non avendo tu fornito analogo log per il modulo del kernel amdgpu, non è possibile effettuare un confronto, ma mi aspetto che il risultato sia analogo.

mark ha scritto:ok, allora personalmente come prima cosa proverei a cambiare kernel, quello che stai usando è il predefinito? in ogni caso proverei a fare un downgrade ad un kernel della serie 4.9

@mark: perché ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 9348
Iscritto il: 27/12/2007, 16:59

Re: Imac problemi xorg e scheda video

Messaggioda mark » 07/05/2020, 13:03

@Aki: nel mio caso in passato aveva funzionato con una scheda radeon, diverso modello e diverso kernel, premettendo che sia un tentativo rapido che non richieda riconfigurazioni particolari, ovviamente
Avatar utente
mark
Hero Member
Hero Member
 
Messaggi: 776
Iscritto il: 10/01/2007, 16:53

Re: Imac problemi xorg e scheda video

Messaggioda Aki » 07/05/2020, 18:16

nota di moderazione: discussione trasferita nella sezione "Hardware"
Aki
Global Moderator
Global Moderator
 
Messaggi: 9348
Iscritto il: 27/12/2007, 16:59

Re: iMac4,1: scheda grafica Mobility Radeon X1600"

Messaggioda Aki » 09/05/2020, 10:26

Ciao Alkatron,

Hai fatto progressi ?

Che ne dici se modifichiamo il titolo da "Imac problemi xorg e scheda video" a "iMac4,1: scheda grafica Mobility Radeon X1600" ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 9348
Iscritto il: 27/12/2007, 16:59

Prossimo

Torna a Hardware

Chi c’è in linea

Visitano il forum: Google [Bot] e 3 ospiti

cron