Webcam asus F200M

Discussioni sulla compatibilità dell'Hardware con linux, Drivers, ...

Webcam asus F200M

Messaggioda Andrea9876 » 04/05/2020, 0:17

Salve a tutti,
ho ripreso dopo qualche anno a usare il "pinguino" e ho installato debian buster su un portatilino della asus (modello F200M)
funziona praticamente tutto a parte la webcam integrata:
in poche parole da cheese o skype vedo solo nero nell'area video
a complicare la questione "buster" a volte riconosce la webcam a volte no, dico così perchè dall'output di *lsusb* a volte vedo un device
Codice: Seleziona tutto
Bus 001 Device 118: ID 04f2:b483 Chicony Electronics Co., Ltd

altre volte no
credo sia quel device la webcam perchè quando lo vedo da *lsusb* e avvio cheese il led della webcam lampeggia e vedo si lo schermo nero ma non ricevo messaggio "nessun dispositivo trovato".

Allego i 2 file log come richiesto dalla vostra guida.
Spero possiate aiutarmi.
Intanto vi ringrazio.
Allegati
log2.txt
(38.78 KiB) Scaricato 14 volte
log.txt
(148 KiB) Scaricato 14 volte
Andrea9876
Newbie
Newbie
 
Messaggi: 1
Iscritto il: 03/05/2020, 23:38

Re: Webcam asus F200M

Messaggioda Aki » 10/05/2020, 13:15

Ciao, dal log inviato, risulta:

- computer usato:
Codice: Seleziona tutto
[    0.000000] DMI: ASUSTeK COMPUTER INC. X200MA/X200MA, BIOS X200MA.504 11/13/2014

- versione di Debian:
Codice: Seleziona tutto
Distributor ID: Debian
Description:    Debian GNU/Linux 10 (buster)
Release:        10
Codename:       buster

- la tua webcam è riconosciuta come "Chicony Electronics Co., USB2.0 VGA UVC WebCam":
Codice: Seleziona tutto
Bus 001 Device 006: ID 04f2:b483 Chicony Electronics Co., Ltd
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          239 Miscellaneous Device
  bDeviceSubClass         2
  bDeviceProtocol         1 Interface Association
  bMaxPacketSize0        64
  idVendor           0x04f2 Chicony Electronics Co., Ltd
  idProduct          0xb483
  bcdDevice           99.14
  iManufacturer           0
  iProduct                1 USB2.0 VGA UVC WebCam
  iSerial                 0
  bNumConfigurations      1

Dal log risulta che per qualche motivo non sia correttamente inizializzata:
Codice: Seleziona tutto
grep "1-3" log.txt
[    3.178816] usb 1-3: new high-speed USB device number 2 using xhci_hcd
[    3.373044] usb 1-3: config 1 interface 1 altsetting 4 endpoint 0x81 has invalid wMaxPacketSize 0
[    3.380364] usb 1-3: New USB device found, idVendor=04f2, idProduct=b483, bcdDevice=99.14
[    3.380377] usb 1-3: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    3.380385] usb 1-3: Product: USB2.0 VGA UVC WebCam
[   15.286587] uvcvideo 1-3:1.0: Entity type for entity Extension 2 was not initialized!
[   15.286593] uvcvideo 1-3:1.0: Entity type for entity Extension 5 was not initialized!
[   15.286597] uvcvideo 1-3:1.0: Entity type for entity Processing 3 was not initialized!
[   15.286601] uvcvideo 1-3:1.0: Entity type for entity Camera 1 was not initialized!
[   15.286949] input: USB2.0 VGA UVC WebCam: USB2.0 V as /devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.0/input/input19
[ 1275.545978] usb 1-3: reset high-speed USB device number 2 using xhci_hcd
[ 1276.433692] usb 1-3: USB disconnect, device number 2
[ 1277.005922] usb 1-3: new high-speed USB device number 5 using xhci_hcd
[ 1277.198994] usb 1-3: config 1 interface 1 altsetting 4 endpoint 0x81 has invalid wMaxPacketSize 0
[ 1277.205437] usb 1-3: New USB device found, idVendor=04f2, idProduct=b483, bcdDevice=99.14
[ 1277.205452] usb 1-3: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[ 1277.205462] usb 1-3: Product: USB2.0 VGA UVC WebCam
[ 1277.834550] uvcvideo 1-3:1.0: Entity type for entity Extension 2 was not initialized!
[ 1277.834554] uvcvideo 1-3:1.0: Entity type for entity Extension 5 was not initialized!
[ 1277.834556] uvcvideo 1-3:1.0: Entity type for entity Processing 3 was not initialized!
[ 1277.834558] uvcvideo 1-3:1.0: Entity type for entity Camera 1 was not initialized!
[ 1277.834693] input: USB2.0 VGA UVC WebCam: USB2.0 V as /devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.0/input/input26
[ 1278.406556] usb 1-3: USB disconnect, device number 5
[ 1279.814653] uvcvideo 1-3:1.0: Entity type for entity Camera 1 was not initialized!
[ 1279.815643] input: USB2.0 VGA UVC WebCam: USB2.0 V as /devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.0/input/input27

Orientativamente, direi che il modulo del kernel uvcvideo (che serve ad interfacciarsi con la webcam) non riesce ad inizializzarla. Potresti trovare beneficio provando ad installare un kernel più recente, ad esempio quello di buster-backports [0].

[0] https://packages.debian.org/buster-backports/linux-image-5.4.0-0.bpo.2-amd64
Aki
Global Moderator
Global Moderator
 
Messaggi: 9348
Iscritto il: 27/12/2007, 16:59

Re: Webcam asus F200M

Messaggioda Aki » 17/05/2020, 9:44

@Andrea9876: ciao, hai aggiornamenti ?
Aki
Global Moderator
Global Moderator
 
Messaggi: 9348
Iscritto il: 27/12/2007, 16:59


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti