[RISOLTO] Debian 10.04 non trova reti wifi

La rete, Internet, configurazione di Servizi e tutto ciò che permette la comunicazione tra macchine

[RISOLTO] Debian 10.04 non trova reti wifi

Messaggioda Professorfalken » 20/06/2020, 8:43

Buongiorno a tutti, ho installato da poco Debian 10.04 e ho riscontrato il problema che ho scritto nel titolo del post

Già dal momento in cui andavo a collegarmi alla rete tramite Wi-Fi per installare il SO mi dava problemi non trovandomi nessuna rete ( quando ce ne erano ) e costringendomi ad usare il cavo. Una volta installato il Sistema Operativo ho scaricato e installato i firware di Realtek senza errori. Solo che quando è andato a modificare il file che li contiene mi ha generato questa schermate.

Per problemi di spazio nel messaggio ho dovuto creare un file .txt e metterci dentro tutto l'output

Ho incluso anche il risultato del comando dmesg

https://mega.nz/file/1zwXybhS#xMA34BBrE ... P1j_mjkVL0
Ultima modifica di Professorfalken il 20/06/2020, 15:39, modificato 1 volta in totale.
Professorfalken
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 04/06/2020, 21:55

Re: Debian 10.04 non trova reti wifi

Messaggioda Aki » 20/06/2020, 9:06

Se leggi il log che hai inviato risulta:
[ 0.066934] [Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x25 (or later)
[ 1.939504] [Firmware Bug]: ACPI(PXSX) defines _DOD but not _DOS
[ 14.158086] bluetooth hci0: firmware: failed to load rtl_bt/rtl8723b_fw.bin (-2)
[ 14.158126] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
[ 14.158170] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_fw.bin failed with error -2
[ 14.158172] Bluetooth: hci0: RTL: firmware file rtl_bt/rtl8723b_fw.bin not found
[ 14.389642] rtl8723be: Using firmware rtlwifi/rtl8723befw_36.bin
[ 14.389831] rtl8723be 0000:0a:00.0: firmware: failed to load rtlwifi/rtl8723befw_36.bin (-2)
[ 14.389886] rtl8723be 0000:0a:00.0: Direct firmware load for rtlwifi/rtl8723befw_36.bin failed with error -2
[ 14.389894] rtl8723be 0000:0a:00.0: firmware: failed to load rtlwifi/rtl8723befw.bin (-2)
[ 14.389941] rtl8723be 0000:0a:00.0: Direct firmware load for rtlwifi/rtl8723befw.bin failed with error -2
[ 14.389942] rtlwifi: Loading alternative firmware rtlwifi/rtl8723befw.bin
[ 26.288376] r8169 0000:08:00.0: firmware: failed to load rtl_nic/rtl8106e-1.fw (-2)
[ 26.289496] r8169 0000:08:00.0: Direct firmware load for rtl_nic/rtl8106e-1.fw failed with error -2
[ 26.289500] r8169 0000:08:00.0 enp8s0: unable to load firmware patch rtl_nic/rtl8106e-1.fw (-2)

Se vedi, il kernel tenta di caricare i seguenti firmware che non trova: rtl8723b_fw.bin , rtl8723befw_36.bin , rtl8106e-1.fw

Questi file sono nei pacchetto firmware-realtek.deb ; sembrerebbe, pertanto, che non hai installato questo pacchetto o che l'installazione non sia andata a buon fine.

Per installarli, puoi provare ad impartire i seguenti comandi come utente root:
Codice: Seleziona tutto
wget http://ftp.us.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-realtek_20190114-2_all.deb
dpkg -i firmware-realtek_20190114-2_all.deb
Aki
Global Moderator
Global Moderator
 
Messaggi: 9488
Iscritto il: 27/12/2007, 16:59

Re: Debian 10.04 non trova reti wifi

Messaggioda Professorfalken » 20/06/2020, 15:38

Ho installato il pacchetto che mi hai detto e adesso trova le varie linee Wi-Fi e si connette senza problemi. Grazie per l'aiuto ;) p.s. quando sono andato ad installarlo mi è venuta la solita schermata con tutti i driver mancanti.....
Professorfalken
Newbie
Newbie
 
Messaggi: 6
Iscritto il: 04/06/2020, 21:55

Re: Debian 10.04 non trova reti wifi

Messaggioda Aki » 20/06/2020, 18:18

Professorfalken ha scritto: Grazie per l'aiuto ;) p.s. quando sono andato ad installarlo mi è venuta la solita schermata con tutti i driver mancanti.....

Figurati. Non sono driver mancanti, ma firmware mancanti, cioé software che è eseguito direttamente all'interno dei microprocessori dei componenti hardware. Ne devi installare altri ancora per la scheda grafica e per il bluetooth. dal tuo log precedente risulta malfunzionamento della scheda grafica:
Codice: Seleziona tutto
[  890.996118] nouveau 0000:09:00.0: bus: MMIO write of 8000001f FAULT at 6013d4 [ IBUS ]
[  901.244896] nouveau 0000:09:00.0: bus: MMIO write of 8000001f FAULT at 6013d4 [ IBUS ]
Aki
Global Moderator
Global Moderator
 
Messaggi: 9488
Iscritto il: 27/12/2007, 16:59


Torna a Network

Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti