Non riesco ad installare MYSQL5 da dotdeb

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.
Rispondi
decola
Full Member
Full Member
Messaggi: 202
Iscritto il: 26/08/2005, 13:53

Non riesco ad installare MYSQL5 da dotdeb

Messaggio da decola »

Ciao a tutti!
Ho una Debian Stable (3.1) e ho inserito le repository di Dotdeb per installare MYSQL5 (le avevo già usate con successo per PHP5) con questo comando:

apt-get install mysql-client-5.0 mysql-server-5.0 php5-mysql

Ma la risposta è la seguente :-(
Come mai?
Grazie.


Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mysql-client-5.0: Depends: libdbi-perl but it is not installable
Depends: libdbd-mysql-perl (>= 1.2202) but it is not going to be installed
mysql-server-5.0: Depends: libdbi-perl but it is not installable
E: Broken packages
net_deity
Full Member
Full Member
Messaggi: 210
Iscritto il: 16/08/2005, 12:34

Re: Non riesco ad installare MYSQL5 da dotdeb

Messaggio da net_deity »

Il problema è che nel repository non è presente una versione sufficientemente aggiornata di:

->libdbi-perl

Io ho una debian box con sid...e nei repository è presente mysql5 tutto il pacchetto compreso di MysqlQueryBrowser e MysqlAdministrator.

Prova a mixare le release...qui trovi un'ottima guida che ti spiega come avere accesso ai diversi repository mixare_release


:ciauz:
Powered->Debian Sid [img align=left]http://pkg-mono.alioth.debian.org/banners/monodeb.png[/img]
decola
Full Member
Full Member
Messaggi: 202
Iscritto il: 26/08/2005, 13:53

Re: Non riesco ad installare MYSQL5 da dotdeb

Messaggio da decola »

Grazie, avevi ragione...tutto sistemato.
Rispondi