Dipendenze da python (versione 2.4) come soddisfarle?

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.
Rispondi
Belzebu
Newbie
Newbie
Messaggi: 39
Iscritto il: 10/10/2005, 11:26

Dipendenze da python (versione 2.4) come soddisfarle?

Messaggio da Belzebu »

Installando pacchetti sviluppati con python 2.4 per ubuntu non riesco a soddisfare le dipendenze dal pacchetto python.

Nell'elenco delle dipendenze compare python(>=2.4).

Sul mio sistema l'outputdi
$ dpkg -l python é:

Codice: Seleziona tutto

Desiderato=sconosciUto/Installato/Rimosso/P:eliminato/H:bloccato
| Stato=Non/Installato/file Config./U:spacchett./conf. Fallita/H:inst.parzial.
|/ Err?=(nessuno)/H:bloc./necess.Reinst./X=entrambi (Stato,Err: maiusc.=grave)
||/ Nome                                        Versione                                    Descrizione
+++-===========================================-===========================================-======================================================================================================
ii  python                                      2.3.5-3                                     An interactive high-level object-oriented language (default version)
L'output di
$ dpkg -l python??? é:

Codice: Seleziona tutto

Desiderato=sconosciUto/Installato/Rimosso/P:eliminato/H:bloccato
| Stato=Non/Installato/file Config./U:spacchett./conf. Fallita/H:inst.parzial.
|/ Err?=(nessuno)/H:bloc./necess.Reinst./X=entrambi (Stato,Err: maiusc.=grave)
||/ Nome                                        Versione                                    Descrizione
+++-===========================================-===========================================-======================================================================================================
un  python-tk                                   <non definita>                              (descrizione non disponibile)
un  python2.1                                   <non definita>                              (descrizione non disponibile)
ii  python2.3                                   2.3.5-8                                     An interactive high-level object-oriented language (version 2.3)
ii  python2.4                                   2.4.2-1                                     An interactive high-level object-oriented language (version 2.4)
non esistendo una versione di "python" superiore a 2.3.5 come faccio a firzare dpkg o apt ad utilizzare python2.4 al posto di python?

E' sufficiente modificare il file control?
Rispondi