Errore compilazione

Sezione dedicata alle problematiche sull'uso dei tool di installazione e gestione di pacchetti, in una distribuzione Debian-based.
Rispondi
Tacco
Jr. Member
Jr. Member
Messaggi: 55
Iscritto il: 07/09/2005, 11:00

Errore compilazione

Messaggio da Tacco »

Ho installato il player musicale "Quod libet" e per ascoltare i brani con estensione flac occorrono le librerie flac.
Ho scaricato dal sito il file pyflac-0.0.4.tar.gz.
Per installarle occorre installare prima swig1.3, python-dev e libflac-dev e l'ho fatto.
Ho dato make per poter poi creare il pacchetto con checkinstall

$ make
e questo e' l'errore che mi da:

make: Nothing to be done for `all'.
./setup.py install
running install
running build
running build_py
running build_ext
building 'flac/_sw_metadata' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -fPIC -I/usr/include/python2.3 -c flac/sw_metadata_wrap.c -o build/temp.linux-i686-2.3/flac/sw_metadata_wrap.o
flac/sw_metadata_wrap.c:703: warning: function declaration isn't a prototype
flac/sw_metadata_wrap.c:885: warning: function declaration isn't a prototype
flac/sw_metadata_wrap.c:1288: warning: function declaration isn't a prototype
flac/sw_metadata_wrap.c:1310: warning: function declaration isn't a prototype
flac/sw_metadata_wrap.c: In function `FLAC__StreamMetadata_VorbisComment_Entry_matches':
flac/sw_metadata_wrap.c:1886: error: incompatible type for argument 1 of `FLAC__metadata_object_vorbiscomment_entry_matches'
flac/sw_metadata_wrap.c: At top level:
flac/sw_metadata_wrap.c:1941: warning: function declaration isn't a prototype
flac/sw_metadata_wrap.c:1953: warning: function declaration isn't a prototype
flac/sw_metadata_wrap.c:1974: warning: function declaration isn't a prototype
flac/sw_metadata_wrap.c:6559: warning: function declaration isn't a prototype
flac/sw_metadata_wrap.c:214: warning: `SWIG_TypeDynamicCast' defined but not used
flac/sw_metadata_wrap.c:402: warning: `SWIG_UnpackDataName' defined but not usedflac/sw_metadata_wrap.c:482: warning: `SWIG_PropagateClientData' defined but not used
flac/sw_metadata_wrap.c:1181: warning: `SWIG_Python_MustGetPtr' defined but not used
flac/sw_metadata_wrap.c:1195: warning: `SWIG_Python_ConvertPacked' defined but not used
flac/sw_metadata_wrap.c:1478: warning: `SWIG_Check_int' defined but not used
flac/sw_metadata_wrap.c:1519: warning: `SWIG_CheckUnsignedLongInRange' defined but not used
flac/sw_metadata_wrap.c:1603: warning: `SWIG_Check_unsigned_SS_int' defined but not used
flac/sw_metadata_wrap.c:1765: warning: `SWIG_Check_unsigned_SS_long_SS_long' defined but not used
flac/sw_metadata_wrap.c:1927: warning: `SWIG_Check_char' defined but not used
flac/sw_metadata_wrap.c:6670: warning: `SWIG_Python_addvarlink' defined but not used
error: command 'gcc' failed with exit status 1
make: *** [install] Error 1

Di cosa si tratta?
Cosa posso fare?
Avatar utente
The_Noise
Hero Member
Hero Member
Messaggi: 827
Iscritto il: 29/03/2005, 8:00

Re: Errore compilazione

Messaggio da The_Noise »

Non c'è in debian quella libreria? (Mi sembra strano) Ad occhio e croce dovrebbe chiamarsi qualcosa come libpython-flac o giù di lì.

Fai una ricerca.


:ciauz:
Tacco
Jr. Member
Jr. Member
Messaggi: 55
Iscritto il: 07/09/2005, 11:00

Re: Errore compilazione

Messaggio da Tacco »

Risolto.
Si chiama python-flac
Grazie
Rispondi