Pagina 1 di 1

Problema con libc6

Inviato: 14/10/2005, 17:47
da Poker
Ciao a tutti.
Premetto che sono un novizio su linux e per questo mi sono installato Kubuntu ( ad installare debian nn ci riuscivo ).
Ora mi ero deciso a ricompilare il kernel per poter installare un bootsplash, ho seguito la guida del sito per farlo ma, quando arrivo ad installare tramite apt:

apt-get install bootsplash

mi da il seguente messaggio:

Alcuni pacchetti non possono essere installati. Questo può voler
dire che è stata richiesta una situazione impossibile oppure, se
si sta usando la distribuzione "unstable", che alcuni pacchetti
richiesti non sono ancora stati creati o rimossi da incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
bootsplash: Dipende: libc6 (>= 2.3.2.ds1-21) ma 2.3.2.ds1-20ubuntu14 sta per essere installato
E: Pacchetto non integro


Ho gia' eseguito:

apt-get install libc6

Qualcuno mi puo' aiutare?

Grazie tante :)

Re: Problema con libc6

Inviato: 14/10/2005, 18:35
da Fart
Questo errore vuol dire che la versione del pacchetto che devi installare non è ancora disponibile in tutte le sue dipendenze nei repository per la tua versione della distro...anche se non sò se kubuntu abbia un analogo di stable unstable...
comunque generalmente è una questione di tempo, devi attendere che alcuni pacchetti entrino nella tua versione ...magari basta qualche giorno... :-D

Re: Problema con libc6

Inviato: 14/10/2005, 18:43
da Poker
devo ripetere allora ogni tanto apt-get install boosplash ?

Re: Problema con libc6

Inviato: 14/10/2005, 20:18
da MaXeR
il problema è legato...ad ubuntu...

mi spiego...
come si può capire da
libc6 (>= 2.3.2.ds1-21) ma 2.3.2.ds1-20ubuntu14
hai nel sistema una versione meno recente delle libc6... quelle che hai sono compilate dal team di ubuntu (motivo per il quale appare quel "ubuntu14" al termine...

i pacchetti di bootsplash, invece, sono per Debian, esattamente per unstable (però dovrebbero funzionare anche su testing)!

quindi... o aggiorni le libc6 (prendendole da una versione successiva di ubuntu), ma non è una scelta da suggerire ad un novizio...

piuttosto potresti ricompilarti il pacchetto:

Codice: Seleziona tutto

# apt-get source bootsplash --compile
eventualmente installando i pacchetti richiesti per la compilazione con

Codice: Seleziona tutto

# apt-get build-deps bootsplash
questo è l'unico metodo che mi viene in mente...

:ciauz:

Re: Problema con libc6

Inviato: 14/10/2005, 21:36
da Poker
metto la debian. So che avro' tanti problemi all'inzio dato che e' una release difficile, ma una volta sistemata se non altro' avro' una release pura e spero di nn incappare in quell'errore.

Re: Problema con libc6

Inviato: 14/10/2005, 23:30
da keltik
i pacchetti di bootsplash, invece, sono per Debian, esattamente per unstable (però dovrebbero funzionare anche su testing)!
forse sono sfortunato io ma ... su testing NON funzionano. in pratica il problema si ha con il pacchetto sysv-rc-bootsplash (se non ricordo male), che non riesce a patchare gli scripts di init.

Re: Problema con libc6

Inviato: 15/10/2005, 9:44
da MaXeR
quel pacchetto non funziona nè su testing nè su sid..
il problema è dovuto ad acuni cambiamenti negli script rcS e rc, che non rendono possibile applicare le vecchie patch...

oggi, se riesco a trovare tempo, provo a spostare per adattarle al nuovo sistema (visto che ho contattato il maintainer, ma non ha risposto...)!

appena riesco vi faccio sapere!!!!

ciauu

Re: Problema con libc6

Inviato: 15/10/2005, 9:47
da Shatsar
Poker ha scritto:
metto la debian. So che avro' tanti problemi all'inzio dato che e' una release difficile, ma una volta sistemata se non altro' avro' una release pura e spero di nn incappare in quell'errore.
Bravo! e poi torna qua a raccontarci come è andata :-D

Re: Problema con libc6

Inviato: 16/10/2005, 17:09
da Poker
Shatsar ha scritto:
Poker ha scritto:
metto la debian. So che avro' tanti problemi all'inzio dato che e' una release difficile, ma una volta sistemata se non altro' avro' una release pura e spero di nn incappare in quell'errore.
Bravo! e poi torna qua a raccontarci come è andata :-D
Sta andando decisamente male. Tento di installare le cose e ogni volta trovo dipendenze nn soddisfate, a volte le dipendenzo sono soddisfatte ma da errori su Qt e qualcos'altro.
Provo a fare apt-ugrade e mi cancella l'immagine del kernel... che casino :'(