[CONCLUSO] Guide NON compatibili per Wheezy o Jessie

Discussioni relative alla Gestione del wiki Guide@Debianizzati.Org
Rispondi
Avatar utente
HAL 9000
wiki member
wiki member
Messaggi: 1547
Iscritto il: 10/08/2009, 10:01

[CONCLUSO] Guide NON compatibili per Wheezy o Jessie

Messaggio da HAL 9000 »

Questa è la lista dei link alle guide non compatibili con Wheezy e nemmeno con Jessie. E si tratta di guide non marcate come "old", "stub", "guida da adottare" e non riservate a testing o Sid. Ogni link è accompagnato dal template "Versioni compatibili" corrispondente. :)
http://guide.debianizzati.org/index.php ... en_CTL-460 {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... SB_scanner {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... nte_Chroot {{Versioni compatibili|Sarge|Etch|Lenny|Squeeze}}
http://guide.debianizzati.org/index.php ... ui_netbook {{Versioni compatibili|Lenny|Squeeze}}
http://guide.debianizzati.org/index.php ... an_Squeeze {{Versioni compatibili|Lenny|Squeeze}}
http://guide.debianizzati.org/index.php ... eeePC_900A {{Versioni compatibili|Lenny}}
http://guide.debianizzati.org/index.php ... spire_1450 {{Versioni compatibili|Lenny}}
http://guide.debianizzati.org/index.php ... 2_2373_CS8 {{Versioni compatibili|Lenny|Squeeze}}
http://guide.debianizzati.org/index.php ... oftware_HP {{Versioni compatibili|Etch|Lenny|Squeeze}}
http://guide.debianizzati.org/index.php ... ida_a_Grub {{Versioni compatibili|Sarge|Etch|Lenny}}
http://guide.debianizzati.org/index.php ... _pagespeed {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... _su_Debian {{Versioni compatibili|Lenny|Squeeze}}
http://guide.debianizzati.org/index.php ... _DVD_e_Mp3 {{Versioni compatibili|Lenny|Squeeze}}
http://guide.debianizzati.org/index.php ... _SCX-4521F {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... zando_CUPS {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... erver_SNMP {{Versioni compatibili|Etch|Lenny|Squeeze}}
http://guide.debianizzati.org/index.php ... ySQL_e_PHP {{Versioni compatibili|Sarge|Etch|}}
http://guide.debianizzati.org/index.php ... xmark_z640 {{Versioni compatibili|Etch|Lenny|}}
http://guide.debianizzati.org/index.php ... ail_Server {{Versioni compatibili|Lenny | Squeeze}}
http://guide.debianizzati.org/index.php ... _mobloquer {{Versioni compatibili|Lenny | Squeeze}}
http://guide.debianizzati.org/index.php ... sktop_Xfce {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... ng_per_AMD {{Versioni compatibili|Lenny|Squeeze}}
http://guide.debianizzati.org/index.php?title=Pyzor {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php?title=Razor {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... _operativo {{Versioni compatibili|Lenny|Squeeze}}
http://guide.debianizzati.org/index.php ... di_dominio {{Versioni compatibili|Sarge}}
http://guide.debianizzati.org/index.php ... ebian_Etch {{Versioni compatibili|Etch}}
http://guide.debianizzati.org/index.php ... bian_Lenny {{Versioni compatibili|Lenny}}
http://guide.debianizzati.org/index.php ... an_Squeeze {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... ot_e_MySql {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... ot_e_MySql {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... con_Debian {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... easeMonkey {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... awei_K4510 {{Versioni compatibili|Squeeze}}
Sono da verificare, aggiungendo la compatibilità a Wheezy e/o Jessie, oppure da marcare come "{{Guida da adottare}}" se possono essere utili (se qualcuno ci lavorasse) o come "{{Old}}" se obsolete e inutili. E ovviamente potete adottarle. ;)

Per dubbi c'è questa discussione. Squeeze inoltre si considera "supportata" fino a febbraio 2016 (via LTS).
Ultima modifica di HAL 9000 il 28/02/2016, 18:03, modificato 3 volte in totale.
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 10 "buster" (PC): installazione, aggiornamento da versione 9.
Avatar utente
s3v
Hero Member
Hero Member
Messaggi: 5946
Iscritto il: 31/12/2008, 11:54

Re: Guide NON compatibili per Wheezy o Jessie

Messaggio da s3v »

Propongo di marcare come "da adottare" tutte le guide che fanno riferimento ad hardware (notebook, stampanti, etc,). Presumibilmente la periferica o la macchina è ancora in giro e ha senso un'adozione.
Tieniamo conto del fatto che una guida, una volta spostata nel namespace "old", non compare più tra i risultati di una ricerca e, pertanto, tenderei a contrassegnare come "old" il minor numero di guide possibile.
Avatar utente
HAL 9000
wiki member
wiki member
Messaggi: 1547
Iscritto il: 10/08/2009, 10:01

Re: [IN CORSO... ] Guide NON compatibili per Wheezy o Jessie

Messaggio da HAL 9000 »

Giuste osservazioni. :)

La lista inoltre è generata con uno script, ma non c'è stato ancora alcun controllo da parte mia. Quindi non va dato nemmeno per scontato che ci sia da fare qualcosa, come nel caso delle guide di installazione di una data versione o anche quelle su configurazioni molto dettagliate e divise per versione con un template, che devono restare come sono.
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 10 "buster" (PC): installazione, aggiornamento da versione 9.
Avatar utente
ferdybassi
Administrator
Administrator
Messaggi: 3320
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: [IN CORSO... ] Guide NON compatibili per Wheezy o Jessie

Messaggio da ferdybassi »

Sembra ancora valida. I driver per le Bamboo Pen dovrebbero diventare parte integrante dei kernel 4.0
Tutte quelle riguardanti l'hardware sono difficili da giudicare. Se non possediamo l'hardware in questione possiamo limitarci a dire se in Wheezy/Jessie esistono dei pacchetti nuovi e se è ancora necessario compilare i driver a mano...
http://guide.debianizzati.org/index.php ... nte_Chroot {{Versioni compatibili|Sarge|Etch|Lenny|Squeeze}}
Da verificare. I pacchetti della guida ci sono solo per Squeeze e Sid...
http://guide.debianizzati.org/index.php ... ui_netbook {{Versioni compatibili|Lenny|Squeeze}}
Parla solo di come configurare Fluxbox, quindi dovrebbe essere ancora attuale.
http://guide.debianizzati.org/index.php ... an_Squeeze {{Versioni compatibili|Lenny|Squeeze}}
Ancora valida.
http://guide.debianizzati.org/index.php ... oftware_HP {{Versioni compatibili|Etch|Lenny|Squeeze}}
Valida, ma da aggiornare. Ho già inserito nella guida il link alle istruzioni aggiornate da trascrivere.
http://guide.debianizzati.org/index.php ... ida_a_Grub {{Versioni compatibili|Sarge|Etch|Lenny}}
Valida se esiste ancora il pacchetto grub-legacy
Valida.
http://guide.debianizzati.org/index.php ... _su_Debian {{Versioni compatibili|Lenny|Squeeze}}
Da Wheezy non vale più.
http://guide.debianizzati.org/index.php ... _DVD_e_Mp3 {{Versioni compatibili|Lenny|Squeeze}}
Ancora valida.
Di base sembra buona. Vogliamo rivederla? IO non ho stampanti USB...
http://guide.debianizzati.org/index.php ... erver_SNMP {{Versioni compatibili|Etch|Lenny|Squeeze}}
Ancora buona.
http://guide.debianizzati.org/index.php ... ySQL_e_PHP {{Versioni compatibili|Sarge|Etch|}}
Parla di Apache 1.3, quindi non più attuale.
http://guide.debianizzati.org/index.php ... ail_Server {{Versioni compatibili|Lenny | Squeeze}}
Ancora buona. I nuovi Postfix però hanno introdotto nuove opzioni di configurazione, ma non saprei bene come integrare la guida...
http://guide.debianizzati.org/index.php ... _mobloquer {{Versioni compatibili|Lenny | Squeeze}}
Lo sviluppo del software è sospeso. Esiste un nuovo software, ci sarebbe da scrivere una nuova guida.
http://guide.debianizzati.org/index.php ... sktop_Xfce {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... ng_per_AMD {{Versioni compatibili|Lenny|Squeeze}}
Non uso queste cose, non so.
http://guide.debianizzati.org/index.php?title=Pyzor {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php?title=Razor {{Versioni compatibili|Squeeze}}
http://guide.debianizzati.org/index.php ... _operativo {{Versioni compatibili|Lenny|Squeeze}}
Ancora buone.

... segue...
Avatar utente
ferdybassi
Administrator
Administrator
Messaggi: 3320
Iscritto il: 28/12/2006, 4:22
Località: S. Angelo Lodigiano (LO)

Re: [IN CORSO... ] Guide NON compatibili per Wheezy o Jessie

Messaggio da ferdybassi »

Fanno parte della "linea" delle guide su OpenLDAP. Ne scrivo una per ogni versione di Debian. Quindi va da sé che le versioni vecchie sono obsolete, ma non saprei come trattarle. Possiamo metterle in Old, ma è anche vero che ci sono in giro dei server di dominio che funzionano ancora con Debian vecchie e a cui magari queste guide possono fare comodo...
Mai provate. A occhio mi sembrano ancora valide.
Dovrebbe essere ancora ok.
Obsoleta, la guida stessa rimanda a un'altra guida.
Forse obsoleta. Mi sembra che adesso avvenga tutto in automatico.
Avatar utente
HAL 9000
wiki member
wiki member
Messaggi: 1547
Iscritto il: 10/08/2009, 10:01

Re: [IN CORSO... ] Guide NON compatibili per Wheezy o Jessie

Messaggio da HAL 9000 »

Questo è dare una mano! :)
Questa sera do un'occhiata a quelle ancora in dubbio, e faccio un sommario dei cambiamenti da apportare.

Quelle dettagliate e divise per versione (come OpenLDAP) direi di lasciarle come sono, così da poter essere trovate con la ricerca. :)
Per l'hardware si può controllare i pacchetti, e quindi aggiungere le nuove versioni, anche senza un controllo vero e proprio di compatibilità, oppure come proposto da S3v marcarle come "da adottare". Entrambe le scelte hanno i loro vantaggi e svantaggi.
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 10 "buster" (PC): installazione, aggiornamento da versione 9.
Stemby
wiki member
wiki member
Messaggi: 1430
Iscritto il: 11/04/2009, 15:47
Località: Missaglia (LC)

Re: [IN CORSO... ] Guide NON compatibili per Wheezy o Jessie

Messaggio da Stemby »

ferdybassi ha scritto:
Sembra ancora valida. I driver per le Bamboo Pen dovrebbero diventare parte integrante dei kernel 4.0
Mmmm, io invece propenderei per considerarla old: ho una Wacom Bamboo Pen CTL-470/K e anni fa mi ero personalmente appuntato:
Funziona out-of-the-box a partire da Linux 3.3; basta installare xserver-xorg-input-wacom
Se poi mi dici che da Linux 4 sarà tutto incluso (ottima notizia!), a maggior ragione la guida mi sembra proprio del tutto obsoleta.

[EDIT]
ferdybassi ha scritto:
Fanno parte della "linea" delle guide su OpenLDAP. Ne scrivo una per ogni versione di Debian. Quindi va da sé che le versioni vecchie sono obsolete, ma non saprei come trattarle. Possiamo metterle in Old, ma è anche vero che ci sono in giro dei server di dominio che funzionano ancora con Debian vecchie e a cui magari queste guide possono fare comodo...
Se le linee guida non sono cambiate, si considera "old" tutto ciò che non è ufficialmente supportato da Debian; direi quindi di marcare come old tutto ciò che si riferisce a versioni precedenti a Squeeze (che è ancora supportata?).

Per facilitare gli utenti alla ricerca della guida "per la versione precedente di Debian" si potrebbe aggiungere direttamente un link all'interno della guida subito successiva, creando così una catena: Squeeze ha un link a Lenny, Lenny a Etch e così via.
[/EDIT]

Grazie a tutti per l'impegno!
Avatar utente
HAL 9000
wiki member
wiki member
Messaggi: 1547
Iscritto il: 10/08/2009, 10:01

Re: [IN CORSO... ] Guide NON compatibili per Wheezy o Jessie

Messaggio da HAL 9000 »

Ne ho sistemata qualcuna, marcate come obsolete e da adottare altre. Di seguito un sommario delle modifiche apportate e di quel che resta da fare, ma ne avrò sicuramente perse per strada. :)

Marcate obsolete:
http://guide.debianizzati.org/index.php ... eeePC_900A (Lenny nel titolo, sarebbe comunque da spostare e rinominare prima di modificare il template)
Da marcare obsolete a febbraio 2016 (fine "supporto" Squeeze LTS):
Marcate come da adottare:
http://guide.debianizzati.org/index.php ... zando_CUPS (pacchetti da cambiare, comandi non più esistenti...)
http://guide.debianizzati.org/index.php ... nte_Chroot (pacchetto non più esistente, non chiaro se sia ancora permesso)
Marcate come da controllare:
Aggiunta compatibilità con Wheezy:
http://guide.debianizzati.org/index.php ... _DVD_e_Mp3 (se qualcuno la testa per Jessie e controlla/aggiunge i relativi pacchetti, si può aggiungere anche Jessie)
http://guide.debianizzati.org/index.php ... con_Debian (amule non presente in Jessie)
http://guide.debianizzati.org/index.php ... _pagespeed (da verificare le configurazioni di apache per Jessie)
Aggiunta compatibilità con Wheezy e Jessie:
Aggiunta compatibilità con tutte le versioni:
Lasciate come sono:
http://guide.debianizzati.org/index.php ... ida_a_Grub (c'è grub-legacy, quindi non è obsoleta, ma non è chiaro se il template debba essere cambiato o no)
http://guide.debianizzati.org/index.php ... ySQL_e_PHP (c'è il link alla guida successiva, e poi è tra le più lette, quindi la lascerei lì; si era già trattato l'argomento in precedenza)
tutte quelle OpenLDAP (come sopra, per il momento; se proprio c'è da ridiscutere come comportarsi in queste casi, magari in una nuova discussione; personalmente mi vedo d'accordo a lasciarle così)
Da sistemare/verificare:
http://guide.debianizzati.org/index.php ... an_Squeeze (loganalyzer fa parte dei repository, più il titolo richiama a Debian Squeeze)
http://guide.debianizzati.org/index.php ... oftware_HP (modifica in corso da parte di Ferdybassi)
Ultima modifica di HAL 9000 il 01/06/2015, 9:15, modificato 2 volte in totale.
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 10 "buster" (PC): installazione, aggiornamento da versione 9.
Avatar utente
HAL 9000
wiki member
wiki member
Messaggi: 1547
Iscritto il: 10/08/2009, 10:01

Re: [IN CORSO... ] Guide NON compatibili per Wheezy o Jessie

Messaggio da HAL 9000 »

Ho cambiato altre due guide, marcandole come "da adottare". Quella CUPS in particolare utilizza ancora cupsys, più comandi non più esistenti.
Quella Apache in chroot non è chiaro se le stesse funzionalità sono possibili senza il pacchetto (ergo "da adottare") o se invece sarà da marcare obsoleta a febbraio 2016.

Resta quella su syslog, che però avendo Squeeze nel titolo forse può restare così, al limite si può creare una nuova pagina per Wheezy/Jessie o rinominarla. L'unica novità è che ora (da Jessie o via backports di Wheezy) loganalyzer fa parte dei repository ufficiali.

Il resto si può considerare concluso, almeno fino alla fine del supporto per Squeeze (febbraio 2016).
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 10 "buster" (PC): installazione, aggiornamento da versione 9.
Avatar utente
HAL 9000
wiki member
wiki member
Messaggi: 1547
Iscritto il: 10/08/2009, 10:01

Re: [DA CONT. 2016-02] Guide NON compatibili per Wheezy o Je

Messaggio da HAL 9000 »

Aggiorno questa discussione, perché con il termine del supporto LTS di Squeeze tra poco più di una settimana, il 29 febbraio 2016, c'è da ultimare l'assegnazione delle ultime guide rimaste alla categoria obsoleta/da adottare e quindi da considerare concluso questo task.

Da marcare come obsolete (oppure, dove specificato, come "da adottare"):
Chiunque può verificarle (preferibilmente) per Jessie, testing/Stretch o unstable/Sid, oppure almeno per Wheezy; o proporre diversamente. E ovviamente, anche una volta rese obsolete, le guide potranno comunque essere adottate.

Aggiornerò nuovamente questa discussione a marzo.
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 10 "buster" (PC): installazione, aggiornamento da versione 9.
Avatar utente
HAL 9000
wiki member
wiki member
Messaggi: 1547
Iscritto il: 10/08/2009, 10:01

Re: [CONCLUSO] Guide NON compatibili per Wheezy o Jessie

Messaggio da HAL 9000 »

Aggiunte a quelle "da adottare":
Rese obsolete:
Considero questa discussione conclusa, domani (29 febbraio 2016) termina anche il supporto LTS a Debian 6 ("Squeeze").

Sono state aggiornate, limitatamente alle descrizioni del supporto LTS per Squeeze anche:
Il supporto ufficiale a Debian 7 ("Wheezy") terminerà verso aprile 2016, e Wheezy sarà "supportata" (non-ufficialmente) via LTS più o meno fino ad aprile 2018, almeno per i principali pacchetti e principali architetture, e le ultime due guide saranno da aggiornare nuovamente con il nuovo repository. Evito quindi di aprire una nuova discussione, per il momento.
(Proporrò comunque di ridurre, se non eliminare, dai repository ufficiali il richiamo a LTS, e lasciarlo soltanto nell'altro, anche se spero che diventi ufficiale. ;) )
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 10 "buster" (PC): installazione, aggiornamento da versione 9.
Rispondi