guida compilazione kernel: serve un aggiornamento?

Discussioni relative alla Gestione del wiki Guide@Debianizzati.Org
Rispondi
Ombra
wiki member
wiki member
Messaggi: 476
Iscritto il: 11/08/2007, 18:06
Località: Bologna

guida compilazione kernel: serve un aggiornamento?

Messaggio da Ombra »

Ciao a tutti,

provando a compilare un kernel della serie 5.x mi sono accorto che la configurazione (make menuconfig o simili) fallisce poiché mancano 2 pacchetti:

Codice: Seleziona tutto

apt-get install bison flex
ho delle installazioni vetuste, non sono sicuro se con una nuova installazione dei pacchetti raccomandati nella guida questi due vengono installati come dipendenze..
Nel caso aggiornerei la guida, qualcuno può confermare ( o smentire?)
Sto usando un kernel vanilla 5.2.5, per vedere l'errore è sufficiente dare

Codice: Seleziona tutto

make menuconfig
Avatar utente
HAL 9000
wiki member
wiki member
Messaggi: 1547
Iscritto il: 10/08/2009, 10:01

Re: guida compilazione kernel: serve un aggiornamento?

Messaggio da HAL 9000 »

Intendi l'articolo dell'e-zine?
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 10 "buster" (PC): installazione, aggiornamento da versione 9.
Ombra
wiki member
wiki member
Messaggi: 476
Iscritto il: 11/08/2007, 18:06
Località: Bologna

Re: guida compilazione kernel: serve un aggiornamento?

Messaggio da Ombra »

Intendi l'articolo dell'e-zine?
in effetti non ho specificato, intendo questa guida, che, per quanto vecchia, per me ha sempre funzionato
Avatar utente
HAL 9000
wiki member
wiki member
Messaggi: 1547
Iscritto il: 10/08/2009, 10:01

Re: guida compilazione kernel: serve un aggiornamento?

Messaggio da HAL 9000 »

Ok, non l'avevo proprio vista. :)

Se vuoi occuparti dell'aggiornamento della guida, sarebbe fantastico. Penso che richieda di sicuro qualche intervento di modifica.
Intanto segnalo che module-init-tools è stato sostituito da kmod, e kernel-package (che contiene make-kpkg) è in sid/unstable ma non si trova né in buster né in bullseye (ed è installabile in stretch solo via backports).
Ricordarsi di modificare il primo messaggio della discussione per aggiungere [RISOLTO] prima del titolo, quando conclusa.

Wiki: APT e Repository, Comandi utili, Collabora.
Manuali di Debian 10 "buster" (PC): installazione, aggiornamento da versione 9.
Rispondi